Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in OCaml
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in OCaml
ID: USN-3437-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS
Datum: Di, 3. Oktober 2017, 22:55
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8869

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============4707511772303172412==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="IfkfBhM7sO0XDT9bIo6x5gh9aNAMQki0F"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--IfkfBhM7sO0XDT9bIo6x5gh9aNAMQki0F
Content-Type: multipart/mixed;
boundary="DicQVt7kMOS20jKeeKjdC4PeTCOseOMo7";
protected-headers="v1"
From: Marc Deslauriers <marc.deslauriers@canonical.com>
Reply-To: Ubuntu Security <security@ubuntu.com>
To: ubuntu-security-announce@lists.ubuntu.com
Message-ID: <38bcd99a-4380-c003-280f-7b975640d112@canonical.com>
Subject: [USN-3437-1] OCaml vulnerability

--DicQVt7kMOS20jKeeKjdC4PeTCOseOMo7
Content-Type: text/plain; charset=utf-8
Content-Language: en-C
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3437-1
October 03, 2017

ocaml vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 LTS

Summary:

OCaml applications could be made to crash, expose sensitive information, or
run programs.

Software Description:
- ocaml: ML language implementation with a class-based object system

Details:

Radek Micek discovered that OCaml incorrectly handled sign extensions. A
remote attacker could use this issue to cause applications using OCaml to
crash, to possibly obtain sensitive information, or to possibly execute
arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 LTS:
ocaml 4.01.0-3ubuntu3.1

In general, a standard system update will make all the necessary changes.

References:
https://www.ubuntu.com/usn/usn-3437-1
CVE-2015-8869

Package Information:
https://launchpad.net/ubuntu/+source/ocaml/4.01.0-3ubuntu3.1



--DicQVt7kMOS20jKeeKjdC4PeTCOseOMo7--

--IfkfBhM7sO0XDT9bIo6x5gh9aNAMQki0F
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCgAGBQJZ0+q7AAoJEGVp2FWnRL6Tp7sQAJI+OT51m3e5GL5jJferAbtP
qOyDvLMidP66knCUa4UDLm6M0Xx7KamgEHIm269pzl3ldATAeUBoQeLRIiIm5YHG
Q2JqUv4bDz+gwcVwYzWNWhq5YlE1VXjJAQcQ1UdUsH+dazb1fw9dHfDAfWL3aAGO
KViCvNZQShC32ZMHX0n7hBxG5bJtAwON7ExO2voGpkiJF5ei/X5pqit4AgKI005A
Rw6aN7qy/JFm75LCmavtsWo5fyW14oXm7QNnKCBd6tkpqThuSrVbHc/toVKTxeT5
jIyoCboZNfo1X1Egm3T9mCfacX/l8jprizaRYBeiJ+PrZYj4KbbOzEQ+/UONbGVX
ZB1xVrzxIPMZsQBuQvRcbH/ALW5C33tANzY6SG4PyvFeEPu3K5YGJoAlGx1TKqxE
SmWp2a5+gc06TIGDTQD1/Tz+2Xe1LHWojn+QiJyFB1VFzkuHj9ILg9zHefFiioVi
3w8dqK5m35EEQWCvR/wAoRK+WRfygOoeBsCCmQnNx8pnw4aD6DtYUPhIUI+XOYeW
FddyA2599dWZOtVPBDEtkxk8kYoGds6u1DmPw4nqgo7/KHIqEH2NXf0WE3JlHXM1
v69oCvHSncLinvFoPDCsR07HKogWebF8vcawHmmmxiM8WJ69ThXA3j0VPIb/2aYN
zDqNrLsRkG8RLE23Iq2R
=67so
-----END PGP SIGNATURE-----

--IfkfBhM7sO0XDT9bIo6x5gh9aNAMQki0F--


--===============4707511772303172412==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============4707511772303172412==--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung