Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Pufferüberlauf in krb5
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in krb5
ID: openSUSE-SU-2017:2993-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.2, SUSE openSUSE Leap 42.3
Datum: Sa, 11. November 2017, 00:23
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15088

Originalnachricht

   openSUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2993-1
Rating: important
References: #1065274
Cross-References: CVE-2017-15088
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for krb5 fixes the following securitz issueÖ

- CVE-2017-15088: A buffer overflow in get_matching_data() was fixed that
could under specific circumstances be used to execute code (bsc#1065274)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1266=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1266=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

krb5-1.12.5-12.1
krb5-client-1.12.5-12.1
krb5-client-debuginfo-1.12.5-12.1
krb5-debuginfo-1.12.5-12.1
krb5-debugsource-1.12.5-12.1
krb5-devel-1.12.5-12.1
krb5-doc-1.12.5-12.1
krb5-mini-1.12.5-12.1
krb5-mini-debuginfo-1.12.5-12.1
krb5-mini-debugsource-1.12.5-12.1
krb5-mini-devel-1.12.5-12.1
krb5-plugin-kdb-ldap-1.12.5-12.1
krb5-plugin-kdb-ldap-debuginfo-1.12.5-12.1
krb5-plugin-preauth-otp-1.12.5-12.1
krb5-plugin-preauth-otp-debuginfo-1.12.5-12.1
krb5-plugin-preauth-pkinit-1.12.5-12.1
krb5-plugin-preauth-pkinit-debuginfo-1.12.5-12.1
krb5-server-1.12.5-12.1
krb5-server-debuginfo-1.12.5-12.1

- openSUSE Leap 42.3 (x86_64):

krb5-32bit-1.12.5-12.1
krb5-debuginfo-32bit-1.12.5-12.1
krb5-devel-32bit-1.12.5-12.1

- openSUSE Leap 42.2 (i586 x86_64):

krb5-1.12.5-6.6.1
krb5-client-1.12.5-6.6.1
krb5-client-debuginfo-1.12.5-6.6.1
krb5-debuginfo-1.12.5-6.6.1
krb5-debugsource-1.12.5-6.6.1
krb5-devel-1.12.5-6.6.1
krb5-doc-1.12.5-6.6.1
krb5-mini-1.12.5-6.6.1
krb5-mini-debuginfo-1.12.5-6.6.1
krb5-mini-debugsource-1.12.5-6.6.1
krb5-mini-devel-1.12.5-6.6.1
krb5-plugin-kdb-ldap-1.12.5-6.6.1
krb5-plugin-kdb-ldap-debuginfo-1.12.5-6.6.1
krb5-plugin-preauth-otp-1.12.5-6.6.1
krb5-plugin-preauth-otp-debuginfo-1.12.5-6.6.1
krb5-plugin-preauth-pkinit-1.12.5-6.6.1
krb5-plugin-preauth-pkinit-debuginfo-1.12.5-6.6.1
krb5-server-1.12.5-6.6.1
krb5-server-debuginfo-1.12.5-6.6.1

- openSUSE Leap 42.2 (x86_64):

krb5-32bit-1.12.5-6.6.1
krb5-debuginfo-32bit-1.12.5-6.6.1
krb5-devel-32bit-1.12.5-6.6.1


References:

https://www.suse.com/security/cve/CVE-2017-15088.html
https://bugzilla.suse.com/1065274

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung