Login
Login-Name Passwort


 
Newsletter
Werbung

Do, 11. Dezember 2003, 00:00

Installations-Bericht Red Hat 7.1 (Seawolf)

Die Installation von Red Hat 7.1 auf einem PC wird hier beschrieben.

Hardware

Als Testsystem stand ein Big Tower mit folgender Hardware zur Verfügung:

  • Dual-Prozessorsystem mit 2 x 400 MHz Pentium II
  • Arbeitsspeicher 320 MB
  • Adaptec 2940 SCSI-Controller
  • Toshiba DVD-ROM SD-M1201
  • Yamaha CD-Brenner CRW 6416 S
  • Adaptec 2940 U2W SCSI-Controller
  • 2 IBM DNES 309170W Hard-Disks
  • 3COM-LAN-Karte 3c905B (10/100 Mbit) PCI
  • AVM Fritz ISDN-Card PCI
  • Elsa ErazorIII Grafikkarte
  • Eizo Flex-Scan F563-T

Installation

Die Installation erfolgt über das eingebaute DVD-Laufwerk und soll neben einer vorhandenen Windows 2000-Installation über den LILO als Dual-Boot-Konfiguration eingerichtet werden. Bei der nach dem Booten erscheinenden Text-Maske entscheide ich mich für eine benutzerdefinierte Installation im Text-Modus und gebe auf der Kommandozeile "text expert" ein. Im weiteren Verlauf fällt auf, daß zu den vorhandenen Installationstypen der Typ "Laptop" neu hinzugekommen ist. Ganz neu ist die Einrichtung einer Firewall schon während der Installationsphase. Hier kann man zwischen den Stufen "Hoch", "Mittel", "Keine" und "Benutzerdefiniert" entscheiden! Nicht schlecht, oder?

Danach ist die Sprach-Unterstützung auszuwählen, wobei man zusätzliche Sprachversionen gleich mitinstallieren kann. Die Auswahl der "Standard-Spracheinstellung" rundet diesen Punkt sinnvoll ab. Bei der Partitionierung wähle ich Disk-Druid, da es wesentlich einfacher zu handhaben ist als "fdisk". Ich lege eine 50 MB große Boot-Partion auf /dev/sda1 an, die ich vor der Win2000-Installation mit Partition Magic für Linux schon vorbereitet hatte. Zusätzlich eine 3 GB große Root-Partition und ein Swap-Bereich von 500 MB, da inzwischen von Red Hat empfohlen wird, die Swap-Partition 1,5 x Hauptspeicher anzulegen. Leider vermisse ich, wie bei SuSE mittlerweile üblich, die Möglichkeit, das Dateisystem als ReiserFS einzurichten. Da ich mich im text-expert-Installations-Modus befinde, hoffe ich, daß diese Möglichkeit, genau wie das Einrichten von RAID-Partitionen, seinen Platz im grafischen Installations-Modus gefunden hat.

Ich verwende die Methode, LILO in den Master Boot Record zu schreiben. Automatisch wird die NTFS-Partition erkannt und als zweiter zu startender Menüpunkt "DOS" vorgeschlagen, was ich gleich in w2000 abändere.

Im weiteren Verlauf wird die Elsa Erazor III als "Riva TNT2" erkannt, was soweit OK ist. Den Monitor richte ich wieder benutzerdefiniert ein. Horizontalfrequenz 30-86 kHz, Vertikalfrequenz 55-160 Hz, so wie es das Eizo Monitorhandbuch angibt. Bei der folgenden Frage nach der Auflösung erscheinen wie bisher drei Spalten mit entsprechender Farbtiefe von 8, 16 und 24 Bit. Hier vermisse ich die Einstellmöglichkeit 32 Bit. Red Hats X-Configurator gibt diese Möglichkeit noch nicht her. Ich entscheide mich erst mal für 24 Bit mit einer Auflösung von 1024x768 Bildpunkten, was völlig für meine Bedürfnisse ausreicht.

Nach der gewohnten Auswahl der zu installierenden Software-Pakete beginnt Red Hat das eigentliche Einrichten der definierten Partitionen und Installieren der ausgewählten Pakete, wobei bei einer kleinen Installation auch CD 2 eingelegt werden mußte. Nach dem obligatorischen "Herzlichen Glückwunsch, Ihre Installation wurde erfolgreich abgeschlossen", öffnet sich beim Reboot sogar die CD-Schublade des Installations-Mediums selbstständig.

Erster Reboot

Beim ersten Reboot erscheint die gewohnte Auswahl-Maske und Red Hat bootet bis auf ein paar USB-Meldungen sauber durch, was auf der Konsole mit den Worten

Red Hat Linux release 7.1 (seawolf)
Kernel 2.4.2-2 on a 2-processor i686

zu erkennen ist. Nach dem ersten Login passe ich meine Umgebung mit dem Aufruf von "ntsysv" hinsichtlich dem Start der Dienste beim Booten auf meine Bedürfnisse und mein System an. Auf der Kommandozeile starte ich dann X und muß feststellen, daß Gnome bei Red Hat immer noch die Nase vorn hat. Ich starte "switchdesk" und wähle KDE als Standard-Desktop, was beim nächsten Start von X auch wunderbar klappt. Allerdings ist das neue KDE, das in der Version 2.1.1 mitgeliefert wird, schon recht schwerfällig, was Performance anbelangt, aber dafür sehr schön, was das Design anbelangt. Es wird ja auch gleich die komplette K-Office Suite mitgeliefert, die für den kleinen Office-Betrieb ausreicht.

Nun, da ja alles bisher soweit geklappt hat, schaue ich mir gleich das angeblich neue Konfigurations-Tool zum Herstellen einer Internet-Verbindung an. Es trägt nicht mehr den Namen isdn-config, sondern wird ab dieser Version von Red Hat internet-config genannt. Man kann nämlich gleich nach dem Start dieses Tools zwischen "ADSL oder T-DSL", "ISDN" und "Modem" auswählen und seine Konfiguration mit den entsprechenden Provider- und Zugangsdaten abschließen. Ein direkter Verbindungsaufbau war zu dieser Zeit allerdings noch nicht möglich.

Nachdem ich mir die Oberfläche und vorhandenen Tools etwas angeschaut hatte, entschloss ich mich, einen neuen Kernel zu erstellen, damit das System optimal auf meine Hardware abgestimmt ist, und um zu überprüfen, ob der Compilerlauf, im Gegensatz zur Red Hat 7.0, mit den mitgelieferten Kernel-Sourcen ohne Probleme stattfindet. Ich beendete die X-Session, da ich das Kernel-Konfigurations-Tool auf der Kommandozeile bevorzuge. Als erstes mußte ich feststellen, daß der symbolische Link in /usr/src nicht wie gewohnt linux, sondern als linux-2.4 auf die Kernelsourcen zeigte. Na denn, erstmal egal. Der Start von "make menuconfig" klappte und ich stellte die entsprechenden Parameter auf meine vorhandene Hardware ein.

make dep clean bzImage"

und der Compiler lief los. Die Meldungen flitzten nur so vorbei, doch das make blieb nach ca. 5 Minuten mit folgender Error-Message stehen:

arch/i386/kernel/kernel.o: In function 'pci_fixup_vt8363':
arch/i386/kernel/kernel.o(.text.init+0x3767):undefined reference to 'noautodma'
make: ***[vmlinux] Fehler 1

Na, da hab ich bestimmt einen Parameter übersehen, was laut Fehlermeldung in dem Bereich PCI oder DMA zu suchen ist. "make menuconfig" gestartet, alles nochmal überprüft und erneut den Compiler-Lauf gestartet, was aber mit genau der gleichen Error-Meldung endete. Das Ganze ging dann nochmal so und ich entschied mich, die neuesten Kernel-Sourcen 2.4.3 auf mein System zu packen. Den Link habe ich dann auch gleich von /usr/src/linux auf mein Verzeichnis /usr/src/linux-2.4.3 nach alt bekannter Art angelegt.

make menuconfig
make dep clean bzImage

und der Compiler lief los. Mit den neuen Kernel-Sourcen hat alles auf Anhieb geklappt.

make modules && make modules_install

System.map und bzImage nach /boot kopiert, lilo.conf angepasst, lilo aufgerufen, System neu gestartet. Alles bestens. Entweder waren die Sourcen des mitgelieferten Kernel 2.4.2-2 beim Download der Red Hat 7.1 beschädigt worden oder Red Hat hat da mal wieder, na ja? Vielleicht war ich auch zu blöd zum Kernel-Konfigurieren, obwohl ich dies nun bestimmt schon zum 2763. Mal so gemacht habe. Es wird sich vielleicht herausstellen, wenn andere mit annähernd gleicher Hardware auf die gleiche Error-Message treffen.

Fazit

Die Red Hat 7.1 gefällt mir persönlich sehr gut. Sie wird mit einem aktuellen Kernel der Serie 2.4.x sowie mit einem neuen KDE-Desktop 2.1.1 auf den Markt geschickt und gehört mit Sicherheit zu den stabilsten Distributionen, die es in diesem Umfeld gibt. Die Installation sollte auch für einen Anfänger, der das Ganze dann grafisch nachvollzieht, keine Probleme bereiten. Ausschlaggebend ist immer der Bezug zu Linux an sich. Ich sage immer, "Linux ist eine Philosophie", und auf keinen Fall ein Windows. Wie sich diese Version auf einem Notebook installieren läßt, werde ich in einem folgenden Artikel berichten.

Bis dahin wünsche ich allen Linux-Freunden viel Spaß mit der neuen Red Hat 7.1.

Kommentare (Insgesamt: 0 || Kommentieren )
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung