Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
 Registrieren
    Profil      Private Nachrichten   Login
[gelöst] Probleme mit Grub1 und IDE- USB- Festplatte
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 17. Jan 2012 0:52   Titel: [gelöst] Probleme mit Grub1 und IDE- USB- Festplatte Antworten mit Zitat

Hallo in die Runde,

ich schlage mich gerade mal wieder mit einem besonderen Problem herum. Ich versuche, das openSUSE 12.1 zu testen, bevor ich es als Ersatz für das 11.4 auf der Hauptplatte verwende.

Speicherort ist eine alte 40 GB- IDE- Festplatte, die ich in ein USB- Gehäuse gesteckt habe. Die ist funktionstüchtig und hat schon mehrere Distris ans Laufen gebracht- aber: alles außer rpm- Systemen mit Grub 1. Die sollen Schwierigkeiten mit der Kombination IDE / USB haben. Und sowas habe ich auch festgestellt.

Nach der Installation bootete das System in der ersten Stufe, kam aber nicht zum Anmeldebildschirm, sondern rebootete immer wieder nach dem Auswahlbildschirm. Nach 3 oder 4 Anläufen kam zuletzt immer eine Meldung: Kernelpanik. Auch das Mageia 1 hat die gleichen Malaisen, das dürfte wohl nicht an openSUSE liegen.

Ich habe so einiges versucht; das will ich jetzt nicht schildern.

(1) Nicht recht fündig wurde ich aber bei der Suche, den Grub 1 des openSUSE durch einen Grub 2 zu ersetzen. Habt ihr einen Tip, wie ich das nur für die Testinstallation machen kann? Dies: "grub2 Install Howto bei openSUSE= Install grub2 rpm package: # zypper install grub2" fand ich nur dazu. Das läuft auch an (mit gewissen Schwierigkeiten, weil die Quelle zu Grub 2 bei SUSE schwach ist), die Installation bricht aber mehrfach kurz vor 100% ab.

(2) Muß ich den Grub 1 aus der Installation entsorgen, bevor ich die Grub 2- Installation versuche? Ich habe für die Versuche eine 100 MB- /boot- Partition eingerichtet und eingehängt; die wird auch mit /boot/grub belegt. Kubuntu 11.04 war damit bootbar.

(3) Muß ich chroot verwenden, oder reicht das, wenn ich die Versuche von einer opensUSE Live- DVD auf root- Konsole aus mache?

Weiß hier jemand im Detail, wie ich das Problem lösen kann?

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0


Zuletzt bearbeitet von Phoenix am 06. Feb 2012 0:38, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3492

BeitragVerfasst am: 17. Jan 2012 2:27   Titel: Re: Probleme mit Grub1 und IDE- USB- Festplatte Antworten mit Zitat

Phoenix hat folgendes geschrieben::
Nach der Installation bootete das System in der ersten Stufe, kam aber nicht zum Anmeldebildschirm, sondern rebootete immer wieder nach dem Auswahlbildschirm.

Welcher "Auswahlbildschirm"? Der des soeben auf der Platte installierten Bootloaders? Wenn ja, kann der Bootloader geladen werden und es besteht überhaupt kein Bedarf darum herumzufummeln. Wenn das Booten des Kernels dann nicht funktioniert bekommt man vom Bootlader eine Fehlermeldung, wenn nötig zuvor mit ESC in dessen Textmodus wechseln. Dort kann man bei GRUB auch an allen Einstellungen herumschrauben, bis er bootet.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

brum
Gast





BeitragVerfasst am: 17. Jan 2012 11:42   Titel: so ein quatsch Antworten mit Zitat

> Nicht recht fündig wurde ich aber bei der Suche, den Grub 1 des openSUSE durch einen Grub 2 zu ersetzen

Warum zum Frell willst Du das machen???
Kannst Du den den Grub2 administrieren?
Sei froh, das der Grub1 noch verwendet wird!

Gruß brum
 

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 17. Jan 2012 17:43   Titel: Re: Probleme mit Grub1 und IDE- USB- Festplatte Antworten mit Zitat

Janka hat folgendes geschrieben::
Welcher "Auswahlbildschirm"? Der des soeben auf der Platte installierten Bootloaders? Wenn ja, kann der Bootloader geladen werden und es besteht überhaupt kein Bedarf darum herumzufummeln. Wenn das Booten des Kernels dann nicht funktioniert bekommt man vom Bootlader eine Fehlermeldung, wenn nötig zuvor mit ESC in dessen Textmodus wechseln. Dort kann man bei GRUB auch an allen Einstellungen herumschrauben, bis er bootet.


Hallo Janka,

Auswahlbildschirm habe ich das Bild genannt, welches als erstes grafisches Bild nach Start des Systems (Grub- Auswahlbild?) sichtbar ist. Also das, wo man entweder den zu nutzenden Kernel auswählen kann oder z:B. den sicheren Modus wählen kann.

Anmeldebildschirm ist dann das Bild, wo man den Nutzer auswählen kann und ggfs. das Paßwort eingibt.

Ich habe schon einige Darstellungen von Grub bei ganz anderen Gelegenheiten bekommen; bei dem mehrfachen Reboot wird garnichts angezeigt, es läuft nur ein Stapel Textanzeigen durch, worauf wieder der Auswahlbildschirm erscheint. Ich muß wohl den Start nochmals durchziehen und die Meldung abfotografieren, wenn das A und der unterstrichene Pfeil mitten auf der Tastatur wie wild blinken. Da ist dann irgendwas von Kernelpanik zu lesen.

Nur habe ich den gleichen Effekt, ganz gleich, ob ich openSUSE 11.4. 12.1 oder Mageia 1 installiert habe. Das war auch ganz gleich, als ich noch keine /boot- Partition eingerichtet hatte.

Ich hab von einem Anwender den Hinweis erhalten, daß es mit Grub 1 und einer IDE- Platte an USB unerwartete Schwierigkeiten geben könne. Das ist nicht allein auf meinem Mist gewachsen. Ich hab auch mehrfach Grubdateien angesehen, finde aber zunächst keine Fehler.

Wie gesagt, bei Systemen mit Grub 2 funktioniert das Booten einwandfrei wie gewohnt bei der Platte. Ich habe ja noch eine andere USB- Platte, die aber vom SATA- Typ ist; da booten die Systeme einwandfrei, ganz gleich, ob es Grub 1 oder Grub 2- Systeme sind.

Ich vermute, das hier die Übergaben von stage 1 zu 1,5 oder 1,5 zu 2 beim Grub fehlgeleitet werden; ich weiß nur nicht, wie ich das ermittlen kann. Welche Dateien müßte ich dazu auslesen und hier posten?

Mit ??

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 17. Jan 2012 18:01   Titel: Re: so ein quatsch Antworten mit Zitat

brum hat folgendes geschrieben::
> Nicht recht fündig wurde ich aber bei der Suche, den Grub 1 des openSUSE durch einen Grub 2 zu ersetzen

Warum zum Frell willst Du das machen???
Kannst Du den den Grub2 administrieren?
Sei froh, das der Grub1 noch verwendet wird!


Hallo brum,

wer zum Direx ist Frell? Shocked
Aber im Ernst, mir geht es hier nur darum, das openSUSE 12.1 auf der genannten Festplatte bootfähig zu installieren und dann ausprobieren zu können. Mit Grub 1 bootet das dort absolut nicht. (Auf der internen Hauptplatte geht das aber bestens)

Ich hatte alternativ die Idee, in einer Bootpartition allein den Grub 2 zu installieren und dann auf / den originalen Grub 1 zu belassen. Das habe ich zwar auch bereits probiert, bekomme die Installation seitens openSUSE Live aber nicht hin. Wahrscheinlich darf ich die Bootpartition im Installationsfall (noch) nicht nach /boot einhängen.

Wäre die Installation gelungen, wollte ich den Grub 2 so einstellen, daß er mit chailoader + 1 den Grub 1 startet.

Andererseits wäre ich genauso froh, die Fehler bei Originalinstallation mit Grub 1 beheben zu können.Nur weiß ich eben nicht, an welcher Schraube ich da drehen müßte. Die Mißlichkeit bei meiner USB- Kombination scheint kein Allgemeingut zu sein.

Eigentlich wollte openSUSE ja schon jetzt bei der 12.1 auf Grub 2 umgestiegen sein, hat das im letzten Augenblick aber abgebogen. Nicht daß ich scharf drauf wäre, den Grub 2 einzusetzen... bei aptrosid hatte ich genug Theater damit.Twisted Evil

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

logout



Anmeldungsdatum: 29.01.2011
Beiträge: 65

BeitragVerfasst am: 17. Jan 2012 18:46   Titel: Re: so ein quatsch Antworten mit Zitat

Phoenix hat folgendes geschrieben::

Wäre die Installation gelungen, wollte ich den Grub 2 so einstellen, daß er mit chailoader + 1 den Grub 1 startet.
Andererseits wäre ich genauso froh, die Fehler bei Originalinstallation mit Grub 1 beheben zu können.Nur weiß ich eben nicht, an welcher Schraube ich da drehen müßte. Die Mißlichkeit bei meiner USB- Kombination scheint kein Allgemeingut zu sein.
Eigentlich wollte openSUSE ja schon jetzt bei der 12.1 auf Grub 2 umgestiegen sein, hat das im letzten Augenblick aber abgebogen. Nicht daß ich scharf drauf wäre, den Grub 2 einzusetzen... bei aptrosid hatte ich genug Theater damit.Twisted Evil
Nette Grüße
Phoenix

Moin,
wenn es wirklich nur an Grub liegt, hatte ich Dir folgendes schon mal empfohlen:
http://gag.sourceforge.net/
Damit kannst Du Deine Partitionen sogar nochmal extra per Passwort schützen.
Warum Grub, wenn's auch einfach geht?
Gruß logout
_________________
Hmm,wo ist eigentlich die Any-Key Taste?
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3492

BeitragVerfasst am: 17. Jan 2012 21:32   Titel: Re: Probleme mit Grub1 und IDE- USB- Festplatte Antworten mit Zitat

Phoenix hat folgendes geschrieben::
Ich muß wohl den Start nochmals durchziehen und die Meldung abfotografieren, wenn das A und der unterstrichene Pfeil mitten auf der Tastatur wie wild blinken. Da ist dann irgendwas von Kernelpanik zu lesen.

Dann wird ja offensichtlich sogar der Kernel geladen. Damit ist das kein Bootlader-Problem. Du musst beim Kernel oder der initrd suchen. Um das genauer zu analysieren braucht man die Kernelmeldungen vor dem Panic.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 18. Jan 2012 1:11   Titel: Re: so ein quatsch Antworten mit Zitat

logout hat folgendes geschrieben::

wenn es wirklich nur an Grub liegt, hatte ich Dir folgendes schon mal empfohlen:
http://gag.sourceforge.net/
Damit kannst Du Deine Partitionen sogar nochmal extra per Passwort schützen.
Warum Grub, wenn's auch einfach geht?


Hallo logout,

ich hatte das ganze soweit möglich im Netz recherchiert und bei mir gespeichert, bedauerlicherweise nicht notiert, daß das von Dir als Idee stammt. Ich war zwischenzeitlich auf einen Alternativ- Bootmanager Plop aufmerksam gemacht worden; auch der ist registriert.

Ich hab immer immense Schwierigkeiten, anderen Linuxern klarzumachen, was eigentlich meine Motivation für die Basteleien ist. Mir geht es darum, das Linux auch in Grenzfällen kennenzulernen, auch einiges auszuprobieren, was etwas seltsam scheint. Ich wollte zunächst probieren, was es mit einer Bootpartition auf sich hat, nachdem mir die Idee mit dem Ersatz des Grub 1 durch den Grub 2 in den Sinn kam. Weil das nicht glatt funktionierte, habe ich versucht, die openSUSE- Installation selbst mit dem Grub 2 zu versehen. Auch das ist mir bislang nicht gelungen.
Ich will noch versuchen, die Meldungen auf dem Bildschirm hier einzustellen; leider kann ich wohl kein Bild anhängen. (Ich nutze dann einen Filehoster).

Zur Nutzung der Alternativ- Bootmanager muß ich die Platte wieder aufräumen, weil ich nicht weiß, was als Rest erhalten geblieben ist. Dann muß ich die Installation neu machen, dabei aber beachten, den Grub 1 aus dem MBR herauszuhalten.

Aber wie gesagt, zuerst möchte ich ausprobieren, wie weit ich mit den Werkzeugen komme, die in den Distris stecken.

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 18. Jan 2012 1:17   Titel: Re: Probleme mit Grub1 und IDE- USB- Festplatte Antworten mit Zitat

Janka hat folgendes geschrieben::

Dann wird ja offensichtlich sogar der Kernel geladen. Damit ist das kein Bootlader-Problem. Du musst beim Kernel oder der initrd suchen. Um das genauer zu analysieren braucht man die Kernelmeldungen vor dem Panic.


Hallo Janka,

geht das aus dem Bildschirmfoto von vorhin hervor? Ich hoffe, Dir sagt das mehr als mir. http://www.file-upload.net/download-4037996/Fehler_oS121.pdf.html

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3492

BeitragVerfasst am: 18. Jan 2012 2:58   Titel: Antworten mit Zitat

Da steht, dass der Kernel das initramfs nicht entpacken konnte, was vermutlich daran liegt, dass es an der gesuchten Stelle nur eine defekte Datei dieses Namens gibt. Finden tut er sie wohl, sonst würde er die Länge nicht kennen.

Boote das Rettungssystem von der DVD, mounte das root-Dateisystem der Platte nach /mnt, danach das /boot-Dateisystem der Platte nach /mnt/boot (sofern du dafür ein extra-Dateisystem hast). Versuche, den Inhalt des initramfs mit
Code:

# zcat /mnt/boot/initrd-3.1.0-1.2-desktop | cpio -t

zu listen. Wenn das nicht klappt ist diese Datei wohl tatsächlich defekt. Ansonsten ist entweder der Kernel defekt - unwahrscheinlich - oder das Entpacken funktioniert nur manchmal, weil USB-Adapter oder Rechner einen wackeligen Hardwaredefekt haben. Letzteres halte ich für das wahrscheinlichste Problem. Betreibst du diese externe Platte mit zusätzlichem Netzteil? Wenn nein, kann es sein, dass der USB-Port mittendrin abgeriegelt wird, weil sie von ihm zuviel Strom zieht.

Defektes RAM oder defekte Prozessorkühlung kommen in beiden Fällen in Frage, da das Entzippen des initramfs beides ordentlich beansprucht und keine Fehler verzeiht.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

brum
Gast





BeitragVerfasst am: 18. Jan 2012 10:26   Titel: grub1 Antworten mit Zitat

Hallo,

Kämpfer der Grub:

Was ist Frell ? Schau mal in die Wikipedia Wink
(Läuft gerade auf Anixe...)

Setze dich mal mit der Synaxt von Grub1 auseinander, das ist in kurzer zeit passiert.
Versuch dann das system "manuell" zu starten.

Du gibst dazu den kernel und die initram an und startest dann.
Die Grubshell beherrscht automatische Vervollständigung, wie die Bash, weil sie das Filesystem lesen kann. Anders herum, /boot muss ein Filesystem sein, was von Grub unterstützt wird.

Enter in die Grubshell mit [ESC] und schreibe (glaube (e]

----------------------------------
kernel [Festplatte]/boot/kernel
initrd [Festplatte]/boot/initrd oder wie das Sytem es bezeichnet
boot
----------------------------------
Denke an die Autovervollständigung Wink

Die Festplatte wird im Syntax mit hd bezeichnet, (hd0,0) = 1. Festplatte, 1.Partition

Möglicherweise erkennst du damit den Fehler.

Viel Spaß
brum
 

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 18. Jan 2012 18:25   Titel: Antworten mit Zitat

Hallo Janka,

Du gibst mir da Hinweise, die manches in ein neues Licht rücken könnten. Ich hab zunächst mal versucht, die initram überhaupt erst im System zu finden und dann anzusehen.
Code:
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/initrd
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/initrd-3.1.0-1.2-desktop
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/initrd.img-2.6.38-8-generic

finde ich da. Die Pfade verweisen auf die /boot- Partition (sda1).
Dieses Verzeichnis
Zitat:
file:///media/765cf4e9-ccdb-4db4-8362-92cc226e3eab/boot
ist leer, es liegt auf der /- Partition (sda2).
Nochmals sda1:
Code:
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/boot/boot/boot
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/boot/boot/grub
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/grub
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/grub

Da muß schon bei der Installation etwas schiefgelaufen sein. Alle Pfade stammen aus dem Konqueror per kopieren. Zu berücksichtigen ist hierbei, daß ich ja später den Versuch unternommen habe, den Grub 2 zu installieren. Irgendwelche Reparaturen dürften wenig sinnvoll sein; für mich ist es einfacher, / , /boot und /home zu formatieren und die Installation neu zu machen. Soll ich die /boot dabei besser entfernen?

Ein Rettungssystem kann ich wahrscheinlich nicht nutzen, da die Installation von einer 64bit Live- DVD aus erfolgte. Ich habe noch eine Installations- DVD mit 32bit; wahrscheinlich ist die Installation damit besser zu steuern?

Mechanische Defekte am USB- Stecksystem oder an der internen Hardware kann ich eher ausschließen, da ja eine 2. USB- Platte mit Mageia angesteckt ist und einwandfrei arbeitet; die kann per separatem Elektroschalter stillgesetzt werden. Natürlich arbeitet das Hauptsystem auf der internen Platte auch einwandfrei. Die hier betroffene USB- Platte hat ein separates Netzteil, ebenso mit separatem Stromschalter. Ich kenne den internen Aufbau des USB- Systems nicht; kann es da Probleme geben, wenn mehrere Stecker in einem Verteiler parallel eingesteckt sind? (Hier: 2 Festplatten und ein Kameraadapter) Die Teile sind zwar ohne Spannung funktionslos, aber die USB- Kabel führen in den Geräten ja auch irgendwo hin zu elektronischen Baugruppen, vielleicht mit Widerständen oder Spulen.

Seltsam bei den Versuchen war, daß ein Mageia 1 die gleichen Probleme hatte, ein Kubuntu, Kanotix Hellfire und Linux Mint LMDE dagegen nicht.

Hallo brum,

Zitat:
Kämpfer der Grub:

Was ist Frell ? Schau mal in die Wikipedia Wink
(Läuft gerade auf Anixe...)

Will heute nicht... http://de.wikipedia.org/wiki/Wikipedia:Protest_gegen_SOPA

Das wir ein wenig schwierig mit Deinen Tipps, weil ich im Grunde nicht weiß, ob ich Grub 1 oder Grub 2 habe; die Installation des Grub 2 verlief nur bis 98 %. Da mich aber interessiert, was passieren könnte, versuche ich eure Tipps noch alle. Kaputtmachen kann ich da wenig, weil ich die Platte ganz allein betreiben kann ohne das Hauptsystem auf der internen Platte (die ist abschaltbar).

Ich werde etwas länger brauchen, melde mich danach aber.

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3492

BeitragVerfasst am: 18. Jan 2012 18:55   Titel: Antworten mit Zitat

Phoenix hat folgendes geschrieben::

Nochmals sda1:
Code:
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/boot/boot/boot
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/boot/boot/grub
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/grub
file:///media/5e05357c-ce62-4f8b-927c-31d45560d9e3/boot/grub

Da muß schon bei der Installation etwas schiefgelaufen sein.

/boot/boot ist ein Symlink, der auf /boot zeigt. Daher kann man beliebig viele /boot im Pfad hintereinanderhängen, es klappt immer. Das ist auch richtig so.

Zitat:

Ein Rettungssystem kann ich wahrscheinlich nicht nutzen, da die Installation von einer 64bit Live- DVD aus erfolgte. Ich habe noch eine Installations- DVD mit 32bit; wahrscheinlich ist die Installation damit besser zu steuern?

Das ist völlig wumpe. Das SuSE-Rettungssystem ist eine Mini-Live-Distribution ohne GUI, die mit auf der Installations-DVD drauf ist. Es tut aber auch jedes andere bootbare Linux. Du hast doch offensichtlich eines. Mach das von mir beschriebene damit.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 583
Wohnort: HSK

BeitragVerfasst am: 18. Jan 2012 20:45   Titel: Antworten mit Zitat

Janka hat folgendes geschrieben::

/boot/boot ist ein Symlink, der auf /boot zeigt. Daher kann man beliebig viele /boot im Pfad hintereinanderhängen, es klappt immer. Das ist auch richtig so.

Zitat:

Ein Rettungssystem kann ich wahrscheinlich nicht nutzen, da die Installation von einer 64bit Live- DVD aus erfolgte. Ich habe noch eine Installations- DVD mit 32bit; wahrscheinlich ist die Installation damit besser zu steuern?

Das ist völlig wumpe. Das SuSE-Rettungssystem ist eine Mini-Live-Distribution ohne GUI, die mit auf der Installations-DVD drauf ist. Es tut aber auch jedes andere bootbare Linux. Du hast doch offensichtlich eines. Mach das von mir beschriebene damit.

Wumpe? Hier nicht geläufig...Rolling Eyes Ich meinte mit dem Einwand zum Livesystem auch nur, daß es dort den Aufruf von einem Rettungssystem nicht gibt. Ich hab's mit der Installationsscheibe nachgeholt.
Vorher hatte ich den Modus von brum probiert; das b bei Boot führte zunächst zurück zum Bootladerstart, dann kam aber plötzlich ein Fortschritt: das System wurde initialisiert, und der Anmeldebildschirm erschien. Ich habe einfach versucht, dort dann den Bootlader zu prüfen/ konfigurieren. Da kamen keine Änderungen. Reboot- und wieder das alte Spiel.

Danach habe ich das Rettungssystem probiert. Die Mountbefehle mußten mit /dev/sda1 ff beginnen. Der zcat- Befehl öffnete die initrd blitzartig, am Ende konnte ich
init - 49001 blocks - rescue:~#_
abschreiben. Deiner vorigen Beschreibung nach ist die Datei wohl vorhanden und auch nicht defekt.
Kerneldefekt schließe ich aus, weil ja zumindest einmal alles wie erwartet ablief.

Bliebe noch: Wackeliger Hardwaredefekt?? Da war doch mal was...Embarassed
Ich hatte in dem ausgeschlachteten Rechner zuletzt immer einen Bootmangel, weil die Bootplatte manchmal nur mit Kabelwackeln zu aktivieren war. Jetzt habe ich noch die 2. Platte auf Reserve liegen; ich bau bei Tageslicht das ganze mal um und mache alles neu. Mal sehen...

Danke für eure Geduld

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

brum
Gast





BeitragVerfasst am: 18. Jan 2012 21:27   Titel: Die Geister die ich rief Antworten mit Zitat

Besen, Besen, sei es gewesen... wer hat's Internet erfunden? Die Schweizer sind unschuldig ....

Wie will heute nicht? Das Suchfeld ist schon noch vorhanden, aber für schwarz-weiß-Blinde der frellige Link:
http://de.wikipedia.org/wiki/Frell

- have a lot og fun -
brum
 

Beiträge vom vorherigen Thema anzeigen:   
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy