Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Keine zwei Monitore mehr nach Umstieg auf SUSE 11.3 KDE 4.4.4

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 12. Dez 2010 18:36   Titel: Keine zwei Monitore mehr nach Umstieg auf SUSE 11.3 KDE 4.4.4

Hallo, ich habe mich endlich für einen Umstiieg von SUSE 11.1 / KDE3.5 auf SUSE 11.3 / KDE4.4.4 entschloasen und habe schon zu Beginn die ersten Probleme - fängt ja gut an. Vorher hatte ich 2 Monitore im Dual-Head Modus in Verwendung. Nachdem auch das Menü zum Grafikkarten-Einstellen aus YAST->Hardware verschwunden war hatte ich die EInstellungen endlich im KDE-Menü unter Systemeinstellungen gefunden. Dort werden mir beide Monitore VGA-0 (Verbunden) und DVI-0 (Verbunden) angezeigt aber in einer Klone-EInstellungen. Sobald ich mir den zweiten Monitor rechts oder links von VGA-0 verschiebe funktioniert das zwar, aber nur bis zum Abmelden. Wenn ich mich im System dann wieder neu anmelde sind beide Monitore wieder in der Klone-Einstellung. Ich verwende das RADEON Model RV280 5960. Kann mir da bitte jemand weiterhelfen?
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 12. Dez 2010 21:26   Titel:

Diese Einstellungen werden jetzt einheitlich über RANDR durchgeführt. Das eigentliche Kontrollprogramm ist "xrandr", das andere sind GUIs dafür bzw. ahmen dessen Funktion nach.

Eigentlich sollte KDE4 sich die letzte Einstellung vor dem Abmelden merken und nach dem Wiederanmelden automatisch anwenden. Melde dich mal nur einfach ab, statt den Rechner runterzufahren. Evtl. speichert er die Einstellungen sonst nicht.

Ansonsten kannst du auch einen Befehl
Code:

xrandr --output DVI-0 --right-of VGA-0 --auto

kurz vor das Ende (exec $WINDOWMANAGER) deiner ~/.xinitrc schreiben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 17. Dez 2010 16:45   Titel:

Hallo Janka, danke für den Tip der aber nur zur Hälfte funktioniert hat. MIt dem Kommando xrandr ......habe ich jetzt plötzlich zwei Bildschirme, aber ich habe keine ~/.xinitrc wo ich was reinschreiben könnte? Nach dem Abmelden habe ich das selbe Problem wie ich es Beschrieben hatte (siehe oben). Ich melde mich auch nur ab, ich fahre nicht herunter. Woher bekomme ich eine ~/.xinitrc? Ich habe im meinem Homeverzeichnis nur eine ~/.xinitrc.template gefunden??
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Dez 2010 20:14   Titel:

Benenne das Template um und füge die xrandr Zeile direkt vor dem "exec $WINDOWMANAGER" ein.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 17. Dez 2010 22:10   Titel:

Punktlandung! hat funktioniert - vielen Dank!!!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy