Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Problem mit der Namensauflösung

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Linux2468
Gast





BeitragVerfasst am: 24. Dez 2010 1:25   Titel: Problem mit der Namensauflösung

Hallo zusammen,

ich habe folgenes Problem:
Versuche ich einen Rechner bei mir im LAN zu pingen bzw. auf eine Dateifreigabe zuzugreifen muss ich immer den PC-Namen mit einem Punkt angeben. Gebe ich den PC-Namen ohne Punkt an wird beim pingen automatisch die Arbeitsgruppe angehängt und es wird eine öffentliche IP-Addresse angezeigt.

Ein Beispiel:
ping rechnername. ==> funktioniert
ping rechnername ==> ergibt rechnername.WORKGROUP (öffentliche IP) (Eingabe ohne ".")

An was kann das liegen und wie stell ich das richtig ein?
Versuche ich das selbe auf einem Windowsrechner ist es egal ob ich den Rechnername mit oder ohne "." angebe es funktioniert immer.

Danke
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 24. Dez 2010 12:03   Titel:

Würdest du uns die Distribution mitteilen, könnten wir vielleicht eine Antwort finden.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux2468
Gast





BeitragVerfasst am: 24. Dez 2010 15:31   Titel:

OpenSuse 11.2
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 25. Dez 2010 14:28   Titel:

Wer ist denn in dem Netzwerk der DNS-Server? Der Router oder der SuSE-Rechner? So wie es aussieht ist im DNS-Server ein anderer Domainname eingetragen als auf dem SuSE-Rechner.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux2468
Gast





BeitragVerfasst am: 26. Dez 2010 11:08   Titel:

So nun funktioniert es. Danke.

Der DNS-Server ist bei mir der Router.
Ich habe damals bei der Konfiguration in Yast --> Netzwerkeinstellungen unter Domainname WORKGROUP angegeben, weil ich sonst nicht speichern kann (Fehlermeldung: Ungültiger Domainname).

Ich habe nun manuell die /etc/resolv.conf geändert und dort eine Zeile mit "domain ." hinzugefügt.

Ich würde es schöner finden, wenn ich die Eisntellungen über yast vornehmen könnte. Gibt es einen Grund wieso ich ohne Angabe eines Domainnamen in yast nicht speichern kann?

vielen Dank
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 26. Dez 2010 19:06   Titel:

Gibt es vermutlich. Ich habe es bisher immer hingenommen und dort den Domainnamen eingetragen, der auch im DNS-Server eingetragen ist. Was du da gebastelt hast ist vermutlich ein Hack -- keine Gewähr, dass nicht irgendein Programm darüber stolpert.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy