Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CD läßt sich nach Umstieg SUSE11.1 -> 11.3 nicht immer lesen

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 30. Dez 2010 20:17   Titel: CD läßt sich nach Umstieg SUSE11.1 -> 11.3 nicht immer lesen

Hallo, ich bin gerade eben von SUSE11.1 auf SUSE11.3 umgestiegen habe in KDE4.4.4 ein merkwürdiges Problem:
1.Wenn ich eine Daten-DVD in das DVD-Laufwerk lege dauert es zwar bis das Fenster "kürzlich angeschlossene Geräte" aufgeht aber wenn ich dann nicht schnell genug die DVD mit Dolphin öffne solange dieses Fenster offen ist kann ich - nachdem dieses Fenster wieder verschwunden ist - im "Arbeitsplatz" die DVD nicht anklicken. Dh im "Arbeitsplatz" sehe zwar das die DVD eingelegt ist aber wenn ich die DVD dann anklicke geht der Konqueror auf aber ich sehe keine Daten. Auch sehe ich im "Arbeitsplatz" unmittelbar neben der DVD nicht den roten Balken.
2.Wenn ich aber nach dem Einlegen der DVD im Fenster "kürzlich angeschlossene Geräte" rechtzeitig die DVD mit Dolphin öffne solange das Fenster aktiv ist, dann sehe ich im "Arbetisplatz" neben der DVD den roten Balken und wenn ich die DVD anklicke auch die Daten im Konqueror.

Was läuft bei 1. falsch?
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 31. Dez 2010 17:20   Titel:

Hallo stimzuk

Ja, das deckt sich ziemlich gut mit meinen eigenen Erfahrungen. Auch ich bin gerade - aus naheliegenden Gründen - von der 11.1 auf die 11.3 umgestiegen.

Deine Variante 2. läuft bei mir ebenso ab. Bei der Variante 1. habe ich noch keine Möglichkeit gefunden, im "Arbeitsplatz" die CD oder DVD nachträglich zu öffnen. Klicken auf das CD-Symbol und Auswahl von "Mit Dolphin öffnen" oder "In neuem Fenster öffnen" führt zu einer Meldung, die klingt wie

"Es ist keine Anwendung zum Öffnen des Dateityps Blockorientiertes Gerät (inode/blockdevice) installiert.

Möchten Sie die Installation einer entsprechenden Anwendung versuchen?"

Klicken auf "Installieren" führt auf das Software-Installationsmodul von YaST, aber keine konkrete Software, die für das vorliegende Problem irgendwie weiterhelfen könnte.

So weit bin ich bisher gekommen. Mal schauen, ob sich noch eine Lösung findet. Die 11.1 war in dieser Hinsicht wirklich erheblich pflegeleichter.

Grüße aus Franken und alles Gute für 2011
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 01. Jan 2011 20:39   Titel:

Hallo Lotharb, ja die SUSE11.1. war super. Schauen wir mal ob uns jemand helfen kann. Das kann doch kein Problem sein - damit müßten doch alle SuSE 11.3 Anwender zu kämpfen haben. lg und auch alles gute für 2011 aus wien
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 01. Jan 2011 21:04   Titel:

Hallo stimzuk

Wo du recht hast, hast du recht: Die 11.1 war Spitze. Ich hätte keinen Grund gesehen für einen Umstieg auf eine jüngere Version, wenn nicht die support-Zeit auf ihr Ende zugehen würde.

Was ich inzwischen zu dem von dir aufgedeckten Problem herausgefunden habe: Es gab tatsächlich Anwender, die auf dasselbe Phänomen gestoßen sind; siehe z.B. hier. Es schien aber in praktisch allen früheren Fällen darauf hinauszulaufen, dass 1. ein Bug in den kio-Paketen der KDE4-Oberfläche vorlag, der 2. aber sehr schnell durch neue Programmversionen behoben wurde. Ich habe heute auf die aktuellsten Versionen der kio-Pakete aufgerüstet, es hat aber keine Veränderung gebracht.

Zur Umgehung des Problems habe ich heute eine Zeile in die /etc/fstab eingefügt, die es jedem Benutzer zu jedem Zeitpunkt erlaubt, das DVD-Laufwerk über Kommandozeile zu mounten. Das ist nicht mehr die Eleganz und der Komfort, die ich von früheren openSUSE-Versionen kenne, aber es funktioniert wenigstens.

Ich bin seit meiner Schulzeit und bleibe weiterhin ein großer Fan von Wien. Einer meiner Lieblingsfilme ist Der dritte Mann, schon allein wegen der unsterblichen Musik.

Grüße an die Donau
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 02. Jan 2011 21:54   Titel:

Hallo stimzuk

Ich weiß nicht, ob das, was ich jetzt berichten will, das geschilderte Problem löst. Ich denke aber, es ist wenigstens ein Fortschritt.

Wenn du nach dem Einlegen einer CD oder DVD das popup-Fenster "Kürzlich angeschlossene Geräte:" wieder vom desktop verschwinden lässt, dann ist es i.a. keine gute Idee, den Arbeitsplatz zu öffnen, um auf diesem Weg das Einbinden des Mediums zustandezubringen.

Das Fenster "Kürzlich angeschlossene Geräte:" ist nämlich nicht dauerhaft verschwunden, sondern findet sich als blaues icon mit CD/USB-Symbol rechts auf der Kontrollleiste. Klickst du darauf, kommt das popup wieder hoch, und du kannst dieselben Aktionen ausführen, als hättest du das popup gleich von Beginn an festgehalten.

Nach Anklicken des icons mit der rechten Maustaste wird ein Punkt "Einstellungen für 'Geräteüberwachung'" angeboten. Was dadurch herauszuholen ist betreffend Vereinfachung der Bedienung muss ich aber selbst noch herausfinden.

Warum die eingeschobene CD dennoch im "Arbeitsplatz" erscheint, sich dort aber - im Gegensatz zu früheren KDE-Versionen - nun keine sinnvolle Aktion damit ausführen lässt, kann ich mir auch nicht zusammenreimen.

Ich melde mich wieder, sobald ich mehr herausgefunden habe.

Frohes Schaffen
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 03. Jan 2011 10:59   Titel:

Der Unterschied ist eigentlich ganz simpel: Bei SuSE11.1 war per default ein Automounter aktiv. Das Medium wurde nach dem Einlegen automatisch gemountet, man brauchte daher überall nur noch zu Klicken und konnte auf das enthaltene Dateisystem zugreifen. Das ist bei SuSE11.3 nicht mehr der Fall hier wird das Medium nur noch gemountet, wenn man in dem "kürzlich angeschlossene Geräte"-Hilfsprogramm auf das "Gerät" geht und rechts auf das dann erscheinende Symbol daneben klickt. Das ist dann aber auch kein normales Mounten, sondern ein Automounten auf Anweisung. Den Unterschied erkennt man daran, dass das Laufwerk nicht verriegelt ist.

Will man das alte Verhalten zurückhaben, geht man auf "Systemeinstellungen->Erweitert->Wechselmedien->Automatisches Einbinden von Wechselmedien aktivieren"

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 03. Jan 2011 13:28   Titel:

Hallo Janka

Danke für deine Erläuterung. Sie trifft ins Schwarze, und ich betrachte das diskutierte Problem damit als gelöst. Ich habe meine veränderte /etc/fstab wieder zurückgesetzt, und das "Automounten auf Anweisung" klappt auf dem beschriebenen automatischen Weg weiterhin.

stimzuks und mein Fehler war es, über den "Arbeitsplatz" (gleichwertig sysinfo:/ im Konqueror) auf die eingelegte DVD zugreifen zu wollen - eben exakt so, wie es aus früheren openSUSE-Versionen vertraut war. Dass bei solchen Versuchen nun unter der 11.3 "seltsame" Fehlermeldungen (siehe mein Beitrag vom 31.12.2010) aufpoppen, ist nervig, aber natürlich nicht wirklich ein Problem.

Nun ist die Reihe an stimzuk, zu bewerten, ob er mit der angebotenen Lösung/Erklärung wirklich zufrieden ist.

Grüße an alle
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

stimzuk



Anmeldungsdatum: 26.11.2009
Beiträge: 59

BeitragVerfasst am: 04. Jan 2011 11:49   Titel:

Hallo Janka, Lotharb. Vielen Dank für Eure Unterstützung! Bestätigen kann ich aber einen 100% Erfolg leider nicht - nachdem ich mich im Urlaub den ganzen Tag nur mit den blöden DVD-Laufwerken in der SUSE 11.3 herumschlage als hätte ich nix besseres zu tun Crying or Very sad. Also zuerst einmal VIELEN Dank für den Tip das das Fenster "Kürzlich angeschlossene Geräte" nicht ganz verschwunden ist sondern auch nach dessen Verschwinden wieder aufrufbar ist - das hat mir eine Menge geholfen! Obwohl ich das Fenster vermutlich gar nicht brauche denn auch wenn das DVD-Laufwerk oder die angschlossenen USB-Festplatten und USB-Sticks nicht gleich gemountet werden sondern NUR im Arbeitsplatz-Konqueror angezeigt werden, kann ich sie dennoch im Arbeitsplatz-Konqueror entweder durch Rechte-Maus->Laufwerk-einbinden einhängen oder durch Linke-Maustaste->"Ein Neues Gerät wurde gefunden. Was möchten Sie nun tun?" durch eine Aktion einhängen lassen.
[b]Das eigentliche Problem das ich habe ist aber scheinbat ein anderes[/b]: Ich habe je nachdem in welches DVD-Laufwerk ich die DVD lege ein unterschiediches Verhalten welches ich mir nicht erklären kann. Ich habe zwei gleiche DVD-Laufwerke eines am IDE1/Sekundary und eines am IDE2/Primary.
Wenn ich die DVD in das Laufwerk IDE2/Primary einlege kann ich im Arbeitsplatz-Konqueror entweder mit Rechte-Maustase->Laufwerk-einbinden" das Laufwerk einbinden oder durch Linke-Maustaste->"Ein Neues Gerät wurde gefunden. Was möchten Sie nun tun?" durch eine Aktion einhängen lassen.
Wenn ich die DVD aber in das Laufwerk IDE1/Sekundary einlegewird sie mir im Arbeitsplatz-Konwueror zwar angezeigt aber wenn ich die Rechte-Maus betätige habe ich kein "Laufwerk-einbinden" und mit der Linke-Maustaste bekomme ich auch kein Fenster "Ein Neues Gerät wurde gefunden. Was möchten Sie nun tun?"
Wieso ist das Verhalten bei den beiden Laufwerken unterschiedlich? Bitte Hilfe!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy