Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
openSUSE 11.4 & NVidia % nouveau

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 582
Wohnort: HSK

BeitragVerfasst am: 27. März 2011 0:21   Titel: openSUSE 11.4 & NVidia % nouveau

Hallo zusammen,

ich habe vorhin versucht, das neue 11.4 zu installieren. Ja klar, NVidia!! Der mittlerweile integrierte nouveau- Treiber kann mit meiner Grafikkarte nicht umgehen. Ich erhalte keinerlei nutzbares Bild, auch verschiedene Bootparameter und Neuinstallationen halfen da nicht.

Also kann ich das System nur von "außen" erreichen. Zunächst möchte ich den nouveau- Treiber vollständig "entsorgen"; aber: wie verhindere ich, daß der bei Updates wieder neu installiert wird?

Ich habe noch Tipps aus der aptosid- Zeit, bin mir aber nicht sicher, ob die apt-get- Befehle auch im openSUSE funktionieren. Jetzt muß ich zunächst probieren, wie ich auf die Konsole komme beim booten / Init3 anwählen kann.

Zur Info:
Bildschirm: 1680x1050@60Hz
Graka: "nVidia C68 [GeForce 7050 PV / nForce 630a]"

Einen Treiber "NVIDIA-Linux-x86_64-260.19.44" habe ich im Vorrat.

Weiß jemand, wie ich auf die Konsole komme und noveau "wirksam"entfernen kann?

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0


Zuletzt bearbeitet von Phoenix am 27. März 2011 23:15, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 27. März 2011 11:29   Titel:

Hallo Phoenix

1. Auf meiner 11.3 scheint der nouveau-Treiber noch installiert zu sein, ohne sich allerdings - da die proprietäten nVidia-Treiber installiert sind - irgendwie bemerkbar zu machen::
Code:

lothar@linux:~> rpm -qa | grep nouveau
xorg-x11-driver-video-nouveau-0.0.15_20100401_bfb95cc-1.10.i586
lothar@linux:~> rpm -qa | grep nvidia
x11-video-nvidiaG02-260.19.44-24.1.i586
nvidia-gfxG02-kmp-desktop-260.19.44_k2.6.34.0_12-23.1.i586
lothar@linux:~>


2. Von der Konsole aus löscht du (als root) Pakete mittels
    rpm -e <Paketname ohne Hardwarekennung und Endung>

Wenn du vorsichtig sein, kannst du einen vorherigen Testlauf machen mittels
    rpm -e --test <Paketname ohne Hardwarekennung und Endung>

In meinem Beispiel sieht das aus wie
Code:

linux:~ # rpm -e --test xorg-x11-driver-video-nouveau-0.0.15_20100401_bfb95cc-1.10
linux:~ #


Wenn rpm nicht meckert, steht dem Löschen nichts im Weg.

3. Zu allem, was ich hier herumgeredet habe, gibt es auch Lösungswege mit zypper. Ich selbst arbeite aber vorzugsweise über rpm, weil ich es seit vielen Jahren so gwohnt bin.

4. Wenn du ein Paket schadensfrei weggeputzt hast, besteht auch keine update-Gefahr mehr. Sobald deine Graphik wieder funktioniert, informiert dich YaST ohnehin vorher über alles, was er zu tun gedenkt.

Frohes Schaffen
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 582
Wohnort: HSK

BeitragVerfasst am: 27. März 2011 17:58   Titel:

Hallo lothar,

danke schonmal. Das Schlimmste war, die Konsole zu öffnen;
Zitat:
<Strg> + <Alt> + F1
bis
<Strg> + <Alt> + F7 bringen dich zu den einzelnen Konsolen. F7 ist die Grafische.

... aus dem Netz. Aber: in der Startphase ging das nicht, weil da schon die Grafikanzeige des Grub sichtbar war.
Also weiter: Startversuch des Systems, bis die Ansicht kam, die gewöhnlich der Anmeldebildschirm ist.

Jedoch war da wieder nichts zu aktivieren, weil außer einer Riesenanordnung von farbigen Rechtecken ("Pixel") nichts erkennbar war. Aber: jetzt klappte Strg+Alt+F1, die Konsole erschien.

Rootanmeldung klappte auch. Die Ermittlung des Treibers klappte weiter (xorg-x11-driver-video-nouveau-0.0.16_20110115_b795ca6-3.1.x86_64 heißt er bei mir).

Gelöscht ist er inzwischen auch. Weil ich versäumt hatte, den Treiber in das richtige Verzeichnis zu packen, muß ich die NVidia- Treiberinstallation später noch einmal versuchen. Aber ich will auch sehen, wie die Ansicht ohne nouveau jetzt aussieht.

Ich benutze übrigens die openSUSE 11.2 auf der internen Festplatte wie ein Livesystem. Schaden nehmen kann die Neuinstallation nicht, weil die völlig unabhängig auf der 2. Platte ist und jederzeit wieder gelöscht und neuinstalliert werden kann.

Ich melde mich später noch einmal.

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Phoenix



Anmeldungsdatum: 12.10.2008
Beiträge: 582
Wohnort: HSK

BeitragVerfasst am: 27. März 2011 23:24   Titel:

Hallo zusammen,

ich hab jetzt nach Löschung des nouveau- Treibers ein unerwartetes Ergebnis: an die Stelle trat wohl automatisch der freie nv- Treiber, welcher automatisch die Oberfläche in der richtigen Auflösung (!) anzeigte. Da ich 3-D nicht benötige, kann erst einmal die Installation des Herstellertreibers unterbleiben.

Im Moment kann ich den ja bequem aus den Oberflächenmenüs installieren; wahrscheinlich wäre es besser, den per Konsolenbefehl sogar auf der Konsole im runlevel 3 = init 3 zu installieren.

Die Detailkonfiguration ist wie üblich nervig und zeitraubend. Aber das versuche ich selbst.

Ich laß das Thema ein wenig ruhen vor einem "gelöst"

Nette Grüße

Phoenix
_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy