Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Energiesparmod lässt sich nicht abschalten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
brum
Gast





BeitragVerfasst am: 15. Apr 2011 14:08   Titel: Energiesparmod lässt sich nicht abschalten

Hallo Leute,

ich habe das Problem unter SLE 10, dass ich die Energiesparfunktion nicht abschalten kann. Der kommt einfach nach 10min Sad ...
Das benötige ich aber, weil sonst der Bildschirmschoner durch xautolock/xlock nicht einsetzt und dieser darum auf ein eine kleinere Zeit gesetzt werden muß.

Im Autostart von X habe ich schon erfolglos folgende Option gesetzt:
Code:

/usr/X11R6/bin/xset -dpms
/usr/X11R6/bin/xset dpms force on
/usr/X11R6/bin/xset -b

sie in der xorg.conf habe ich in der Section ServerLayout dieses probiert:
Code:
Option "BlankTime" "20"
Option "StandbyTime" "30"
Option "SuspendTime" "44"
Option "OffTime" "60


Bringt alles nix.
Gibt es noch weitere Ideen?

Viele grüße brum
 

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 16. Apr 2011 5:18   Titel:

Ein bischen Spielerei in squeeze:
Code:
$ xset s 32767 ; xset q | grep time
  timeout:  32767    cycle:  4

$ xset s 32768 ; xset q | grep time
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  107 (X_SetScreenSaver)
  Value in failed request:  0xffff8000
  Serial number of failed request:  8
  Current serial number in output stream:  10
  timeout:  32767    cycle:  4
32767 (Sekunden) ist der sauber akzeptierte Maxwert.
Exorbitante Phantasiewerte können Phantasieergebnisse haben:
Code:
$ xset s 000 ; xset q | grep time
  timeout:  0    cycle:  4
$ xset s 99999999999 ; xset q | grep time
  timeout:  600    cycle:  4


Code:
$ WERT=65535 ; xset dpms $WERT $WERT $WERT ; xset q | grep -i stand
  Standby: 65535    Suspend: 65535    Off: 65535
$ WERT=65536 ; xset dpms $WERT $WERT $WERT ; xset q | grep -i stand
  Standby: 0    Suspend: 0    Off: 0
Der saubere Maxwert ist 65535 (Sekunden).
Auch hier produzieren weitere Phantasiewerte Phantasieergebnisse.



Da keiner Deiner
Option "BlankTime" "20"
Option "StandbyTime" "30"
Option "SuspendTime" "44"
Option "OffTime" "60
mit den 10min korrespondiert ('xset q | egrep -i "time|stand"' ?),
wird dieser Wert eventuell von kde/gnome gesetzt?
(Die fehlenden Anführungszeichen sind nicht das Problem?)

Deaktiviert würden die Werte mit
Code:
xset s 0
xset dpms 0 0 0

_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

brum
Gast





BeitragVerfasst am: 16. Apr 2011 12:36   Titel: danke

Hhhmm, danke,

du kannst also die man-page besser deuten als ich Sad

Das werde ich dann am Montag gleich probieren...

Viele grüße
brum
 

brum
Gast





BeitragVerfasst am: 18. Apr 2011 8:36   Titel: der montag

Moin komsomolze,

also die Werte der xorg.conf tauchen nirgendwo auf....

Ich habe nun die Werte
Zitat:
xset s 0
xset dpms 0 0 0
in ein Skript eingetragen, welches dann von /etc/xdg/autostart/script.desktop aufgeufen wird, das wird zwar ausgeführt, aber die xset-Werte werden hier irgendwie ignoriert.

Code:
# xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  auto repeat delay:  250    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffdfffdfe5ef
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  0    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/baekmuk:unscaled,/usr/X11R6/lib/X11/fonts/truetype,/usr/X11R6/lib/X11/fonts/uni:unscaled,/opt/kde3/share/fonts
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 420    Suspend: 780    Off: 1140
  DPMS is Enabled
  Monitor is On
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/X11R6/lib64/modules/updates,/usr/X11R6/lib64/modules

Mit diesen Einstellungen kam nach 10 min ein Energie-Spar-Modus mit schwarzen Schirm.
Die Powersavemechanimen von Gnome und KDE wurden deinstalliert.

Manuelle Eingaben zum späteren Zeitpunkt wirken sich dann so aus:
Code:
# xset s 0
xset dpms 0 0 0

Code:
# xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  auto repeat delay:  250    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffdfffdfe5ef
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  0    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/baekmuk:unscaled,/usr/X11R6/lib/X11/fonts/truetype,/usr/X11R6/lib/X11/fonts/uni:unscaled,/opt/kde3/share/fonts
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/X11R6/lib64/modules/updates,/usr/X11R6/lib64/modules
  Log file:     /var/log/Xorg.0.log

DPMS bleibt "enabled", obwohl die Werte 0 sind.

Aber es funktioniert so, das der Bildschirmschoner angeht. Danke Wink
Aber die Werte der ersten Einstellung:
Code:
Standby: 420    Suspend: 780    Off: 1140
geben irgendwie keinen Sinn, wenn nach 10 der Energie-Modus anspricht....

Gruß brum
 

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 18. Apr 2011 12:49   Titel:

Zitat:

Aber die Werte der ersten Einstellung:
Code:
Standby: 420 Suspend: 780 Off: 1140
geben irgendwie keinen Sinn, wenn nach 10 der Energie-Modus anspricht....
Yepp, da dreht noch irgendwas dran,
resp. verwendet eigene Einstellungen.
Vielleicht noch irgendwo ein vergessenes Skript,
zBsp in /etc/X11/Xsession.d/? Irgendwas mit yast?
Die Standardwerte sind wohl "600 600 600" (?).


Zitat:
in ein Skript eingetragen, welches dann von /etc/xdg/autostart/script.desktop aufgeufen wird,
das wird zwar ausgeführt, aber die xset-Werte werden hier irgendwie ignoriert.
Dann kommt das oben angesprochene "irgendwas" noch danach zum Zuge.
Der screensaver-Timeout wird ja übernommen.
Als Kontrolle kannst Du in dem Skript noch ein
Code:
date >> /tmp/xset.log
xset q >> /tmp/xset.log
anfügen.


Zitat:

DPMS bleibt "enabled", obwohl die Werte 0 sind.
Vom Xserver aus kommt dann kein Timeout mehr,
andere können dann dpms aber wohl noch benutzen.
'xset -dpms' zum Deaktivieren,
siehe 'xset [--help]'.
_________________
mfg komsomolze
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy