Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Fehler mit Festplattendateisystem!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
bluscream



Anmeldungsdatum: 17.10.2011
Beiträge: 4

BeitragVerfasst am: 17. Okt 2011 0:38   Titel: Fehler mit Festplattendateisystem!

Hallo,

Ich bin neulich von meiner 80GB Toshiba mk8046gsx auf die 160GB ATA WDC WD1600BEVT-35ZCT0 umgezogen und habe jetzt auf der 160er eine 30GB Partition mit WIN7 und eine 30GB Partition mit Ubuntu. Dann wollte ich die 80er WesternDigital-Festplatte leermachen um sie als Transferplatte zu verwenden. Als ich sie mithilfe der Laufwerksverwaltung formatieren/partitionieren wollte brachte er mir folgende Fehlermeldung:
"Error creating file system: helper exited with exit code 1: cannot open /dev/sdb: Read-only file system"
Unter Windows habe ich das gleiche ebenfalls versucht, ohne Erfolg: Er fand die Platte nichtmal in der Datenträgerverwaltung. Ein Youtube-Video dieses Fehlers findet ihr auf: http://www.youtube.com/watch?v=4LthU9GKJ60
_________________
LG
-------------
Bluscream
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Okt 2011 12:34   Titel:

Klemm die Platte an, mach eine Konsole auf, dann:
Code:

$ sudo su
# fdisk -l

Ergebnis hier posten, dann geht es weiter.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

bluscream



Anmeldungsdatum: 17.10.2011
Beiträge: 4

BeitragVerfasst am: 17. Okt 2011 14:00   Titel: Fehler mit Festplattendateisystem!

Funzt immer noch nicht. Er sagt: "Festplatte /dev/dm-0 enthält keine gültige Partitionstabelle" Exclamation
Neues Youtube-Video: http://www.youtube.com/watch?v=ioQjKG_19sc
_________________
LG
-------------
Bluscream
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Okt 2011 20:10   Titel:

fdisk -l listet *alle* Platten, also auch welche, die nur virtuell sind. Die Fehlermeldung ist also egal. Bitte poste das vollständige Ergebnis hier als Text.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

bluscream



Anmeldungsdatum: 17.10.2011
Beiträge: 4

BeitragVerfasst am: 17. Okt 2011 21:06   Titel: Bitte sehr.

timo@Timos-Laptop:~$
Display all 3065 possibilities? (y or n)
timo@Timos-Laptop:~$
timo@Timos-Laptop:~$ sudo su
[sudo] password for timo:
root@Timos-Laptop:/home/timo# fdisk -l

Platte /dev/sda: 160.0 GByte, 160041885696 Byte
255 Köpfe, 63 Sektoren/Spur, 19457 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb6bbb4b7

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 26 208813+ 7 HPFS/NTFS
/dev/sda2 27 15633 125359507+ 7 HPFS/NTFS
/dev/sda4 15633 19458 30721025 5 Erweiterte
/dev/sda5 19281 19458 1423360 82 Linux Swap / Solaris
/dev/sda6 15633 19020 27202560 83 Linux
/dev/sda7 19020 19281 2094080 82 Linux Swap / Solaris

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/dm-0: 2144 MByte, 2144337920 Byte
255 Köpfe, 63 Sektoren/Spur, 260 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa480fadb

Festplatte /dev/dm-0 enthält keine gültige Partitionstabelle
root@Timos-Laptop:/home/timo#
_________________
LG
-------------
Bluscream
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 18. Okt 2011 16:39   Titel:

Ich sehe da als Grundproblem, dass er überhaupt nur zwei Geräte findet. Einmal die neue 160GB-Platte, einmal ein Device-Mapper-Gerät von 2GB Größe (ein verschlüsselter Container?). Die 80GB-Platte ist gar nicht anwesend.

Wie ist die 80GB-Platte angeschlossen? Wird sie vom BIOS beim Hochfahren erkannt?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

bluscream



Anmeldungsdatum: 17.10.2011
Beiträge: 4

BeitragVerfasst am: 19. Okt 2011 1:07   Titel: Antwort

Sie ist über eine USB-Hülle angeschlossen und wird vom BIOS erkannt.
Sie hat ja auch gebootet als ich win7 draufhatte.
_________________
LG
-------------
Bluscream
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 19. Okt 2011 14:11   Titel:

Dann vermute ich, dass sie mehr Strom braucht als ein einzelner USB-Port liefern kann und daher die programmierbare Sicherung dieses Ports anspringt. Manche USB-Hostcontroller sind sehr pingelig, was die Überstromerkennung angeht und der Linux-USB-Treiber glaubt der Hardware normalerweise, dass ein Fehler vorliegt, wenn diese einen meldet. Man kann das über Treiberoption "ignore_oc=1" (uhci_hcd und ehci_hcd) bzw. "distrust_firmware=1" (ohci_hcd) ausschalten, güstiger wäre es allerdings, die Festplatte extern mit zusätzlichem Strom zu versorgen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy