Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Drucker will jedesmal neu

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Der J
Gast





BeitragVerfasst am: 08. Dez 2011 10:43   Titel: Drucker will jedesmal neu

Hallo Leite,

wahrscheinlich gehört diese Anfrage in die Rubrik Software/System , ich vermute ein USB-Problem.

Mein Laserdrucker - Samsung ML2010- welcher noch niemals Probleme macht, spinnt nun.
Der Drucker muss nun _nach_ dem PC-Start eingeschaltet werden und manchmal auch zwischendurch beim Druck mehrerer einzeln in Auftrag gegebenen Seiten ein-/ausgeschaltet werden. Ein Restart von CUPS bring nichts.
Alternativ kann man auch den USB-Anschluss ab- und wieder anstecken. Der Drucker ist direkt und nicht über ein USB-Hub angeschlossen.

Für zündende Ideen bin ich dankbar Wink

LG
Der J
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. Dez 2011 12:08   Titel:

Was hast du geändert? Schau mal direkt nach so einem Problem mit dmesg im Kernel-Log nach, ob du dort nicht verdächtige Meldungen, z.B. zu dem von dir vermuteten USB-Problem, findest.
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Der J
Gast





BeitragVerfasst am: 08. Dez 2011 14:51   Titel: Update

Naja, ich habe auf eine andere Version per Neu-Installation (Mandriva 2010.0 -> 2010.2) gewechselt...
 

Der J
Gast





BeitragVerfasst am: 08. Dez 2011 15:34   Titel: dmesg

Also "system-config-printer" poppt eine meldung auf dem Bildschirm "Drucker ggf. nicht angeschlossen."
Die dmesg bringt noch
Code:
usb 4-2: usbfs: interface 0 claimed by usbfs while 'gcm-apply' sets config #1

Aber ob das damit etwas zu tun hat?

In usbview wird der Drucker angezeigt.
Code:
Aber erst nach ein-/ausschalten kommt dann bei dmesg:
usb 5-1: USB disconnect, address 2
usb 5-1: new full speed USB device using uhci_hcd and address 3
usb 5-1: New USB device found, idVendor=04e8, idProduct=326c
usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-1: Product: Samsung ML-2010
usb 5-1: Manufacturer: Samsung
usb 5-1: SerialNumber: 4421BKCP409183Y.

und der im System gelöschte Drucker wird wieder eingestellt.

Gruss
Der J
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. Dez 2011 20:47   Titel:

Das ist leider nicht aussagekräftig genug. Warte mal auf den Fehler, bei dem der Drucker mittendrin weg ist.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Der J
Gast





BeitragVerfasst am: 08. Dez 2011 21:00   Titel: Hardware

Es war wirklich die Hardware als Ursache Laughing
Die Klappe zum Tonerschacht war nicht richtig zu Rolling Eyes

Danke für alle Überlegungen Smile

Gruß
Der J
 

Der J
Gast





BeitragVerfasst am: 26. Dez 2011 12:12   Titel: Korrektur

Frohe Weihnachten,

ich ziehe meinen Beitrag - über diesen - zurück.
Es war Zufall, das der Drucker nach Schließen der Klappen wieder lief.

Ist ist nach wie vor so:
Nach PC-Start muss man den Drucker aus-/einschalten oder den USB-Anschluß aus-/einstecken. Sonst wird der Druckauftrag nicht transportiert.
Das geht eine Weile gut, dann wird der Druckauftrag in's Nirvana transportiert, und man muss wier ein/aus.....

Ich habe das Problem nun mit einem kleinen Netzwerk Druckserver gelöst.

Als Ursache sehe ich einen verpfuschten 2.6.33.7-Kernel von Mandriva 2010.2 an.
Bei Mandriva 2010.0 gab es keinerlei Probleme, eine super Distribution.

Verhärtet hat sich der Verdacht, das mein USB-Scanner nun genauso spinnt....

Frohe Weihnachten
Der J
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 26. Dez 2011 13:38   Titel:

Dann vermute ich, dass der USB-Host in deinem Rechner dem Treiber Überstrom meldet, obwohl gar kein Überstromfall vorliegt. Bei den neueren Hosttreibern wird dieses Flag der Hardware ausgewertet, und dann die USB-Verbindung gekappt.

Da du keine passenden dmesg-Meldungen gepostet hast, kann ich das aber nur vermuten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Der J
Gast





BeitragVerfasst am: 26. Dez 2011 15:18   Titel: keine Meldung

Es gibt leider keine auswertbare Meldung.

Im Fall 1, also vor dem ersten Disconnect, erscheint nichts,- es ist nur einfach kein Drucker da - erst danach, aber dann als erfolgreiche Einbindung und dann geht's eine Weile.

Im Fall 2 gibt's auch keinen Fehler, diesmal geht der Druckauftrag aber 'raus ... kommt aber nicht an. Das habe ich mit Onboard-USB und externer USB-Karte probiert.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy