Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Installation 12.1 mit Problem Grafikkarte

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 07. März 2012 13:35   Titel: Installation 12.1 mit Problem Grafikkarte

Hallo

ich habe versucht openSuse 12.1 zu installieren. Ging nicht richtig und zum Schluß landete ich immer in der Konsole. Von dort ließ sich nichts starten. Ich konnte mich erinnern, dass es schon mal Probleme mit der Grafikkarte gab. So habe ich eine uralt-Grafikkarte eingebaut.Da lief die Installation. Nun möchte ich ja wieder meine Grafikkarte zum laufen bringen. Als Treiber wird fbdev angezeigt. Die HD 3850 lief in openSuse 11.4 mit radeon, ich glaube besser wäre fglrx.

Mein PC hat eine älteres Asus Motherboard und die Grafikkarte ist Ati HD 3850.

Noch eine Frage. Wie kann man verhindern, dass nach der Installation die alten Einstellungen von der Version 11.4, die in meinem Homebereich stehen, übernommen werden ? Ich wollte aber die Daten im Homebereich erhalten.

Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. März 2012 11:39   Titel: Re: Installation 12.1 mit Problem Grafikkarte

Gillo hat folgendes geschrieben::
ich habe versucht openSuse 12.1 zu installieren. Ging nicht richtig und zum Schluß landete ich immer in der Konsole. Von dort ließ sich nichts starten. Ich konnte mich erinnern, dass es schon mal Probleme mit der Grafikkarte gab. So habe ich eine uralt-Grafikkarte eingebaut.Da lief die Installation. Nun möchte ich ja wieder meine Grafikkarte zum laufen bringen. Als Treiber wird fbdev angezeigt. Die HD 3850 lief in openSuse 11.4 mit radeon, ich glaube besser wäre fglrx.

Wenn du eine andere Grafikkarte einbaust, kannst du das Problem nicht diagnostizieren. Bau wieder die Radeon-Grafikkarte ein und arbeite auf der Textkonsole. AUch dort hast du Zugriff auf YaST, Textmodus-Browser und andere wichtige Werkzeuge. Nur der ganze Klickibunti-Kram geht nicht, aber den braucht man zur Fehlersuche auch nicht.

Die HD3850 besitzt den R6xx-Chipsatz, dieser wird schon eine zeitlang vom freien "radeon"-Grafiktreiber unterstützt, dieser sollte auch in SuSE12.1 in einer hinreichend aktuellen Version enthalten sein. Bitte trage in der Datei folgendes ein:
Code:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"
  #Option "ForceLowPowerMode" "Yes"
  Option "DMAForXv" "Off"
  Option "RenderAccel" "Yes"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  Option "monitor-LVDS" "Default Monitor"
EndSection

Ein brauchbarer Textmodus-Editor für Anfänger ist pico, allerdings ist der vielleicht nicht installiert. Ich benutze immer vi, denn der ist praktisch immer da: Also "vi /etc/X11/xorg.conf.d/50-device.conf, dann Insert-Taste drücken, den Text ändern und zum Schluß Escape :wq zum Speichern und Beenden. Kriegst du auch hin. Hilfe über Escape :help.

Dann einmal mit
Code:

# rcxdm restart

den X-Display-Manager neu starten. Nun sollte X starten. Wenn nicht, musst du das log in /var/log/Xorg.0.log untersuchen.


Zitat:

Noch eine Frage. Wie kann man verhindern, dass nach der Installation die alten Einstellungen von der Version 11.4, die in meinem Homebereich stehen, übernommen werden ? Ich wollte aber die Daten im Homebereich erhalten.

Die Einstellungen liegen in den .-Dateien und Unterverzeichnissen in deinem Homeverzeichnis. Das ist eine ganze Menge. Falls du z.B. KDE benutzt, kannst du die alten Einstellungen abschalten, indem du das ~/.kde-Verzeichnis in ~/.kde-old oder ähnlich umbenennst. Solltest du aber von einem Textmodus-Login aus machen, damit es kein Durcheinander von alten und neuen Einstellungen gibt.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 08. März 2012 20:52   Titel:

Hallo Janka,

hat leider nicht geklappt. Im Xorg.0.log ist folgender Fehler zu finden
Fatal: RadeonHD presently does not work with kernel modesetting(KMS)
Please disable KMS in your kernel

Als ich vi aufgerufen habe, wurde folgende Adresse angezeigt
https//bugs.freedesktop.org/show_bug.cgi?id=32430

Kannst Du damit was anfangen ?

Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. März 2012 22:02   Titel:

Gillo hat folgendes geschrieben::
Hallo Janka,

hat leider nicht geklappt. Im Xorg.0.log ist folgender Fehler zu finden
Fatal: RadeonHD presently does not work with kernel modesetting(KMS)
Please disable KMS in your kernel

Dazu musst du auf der Bootlader-Kommandozeile den Parameter "nomodeset" angeben.

Falls es dann klappt, kannst du es in /boot/grub/menu.lst fest eintragen.


Zitat:

Als ich vi aufgerufen habe, wurde folgende Adresse angezeigt
https//bugs.freedesktop.org/show_bug.cgi?id=32430

Öhm, vi ist ein Programm, keine Webseite.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 08. März 2012 22:17   Titel:

Hallo Janka,

als ich vi /etc/X11/xorg.conf.d/50-device.conf aufgerufen habe, kam ein englischer Text vor der Datei, die ich geändert habe. In diesem englischen Text war die Webseitenadresse angegeben.
Having multiple "Device" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
#
Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 08. März 2012 22:35   Titel:

Hallo Janka,

vielen, vielen Dank. Es hat geklappt. Das hätte ich allein nicht geschafft.

Schönen Abend noch..

Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 09. März 2012 12:35   Titel:

Hallo Janka,

noch eine Frage, mein Bildschirm ruckelt, liegt es an einer falschen Einstellung?

Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. März 2012 20:09   Titel:

Ruckeln? Kannst du eine besser vorstellbare Beschreibung geben?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 10. März 2012 19:23   Titel:

Beispiel: wenn ich In Calc mit der Pfeiltaste von Feld zu Feld springe, wackelt das ganze Bild. Erst wenn keine Eingabe oder keine Bewegung stattfindet beruhigt sich das Bild. Auch wenn Internetseiten aufgerufen werden ist der Bildschirm unruhig und die Ränder verschieben sich leicht hin und her.

Kannst Du damit was anfangen ?

Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. März 2012 21:35   Titel:

Ja. Vermutlich benutzt du einen TFT-Monitor und die eingestellte Bildwiederholrate ist für diesen zu hoch. Dann kriegt er Probleme, sobald sich Bildinhalte ändern. Normalerweise teilt der Monitor per EDID mit, was er kann, aber manche Monitorhersteller tragen da Mist ein. Ist genau wie mit RAM-Modulen.

Mach mal
Code:

$ xrandr | grep connected
VGA-0 connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
S-video disconnected (normal left inverted right x axis y axis)

Ah, die Ausgänge heißen also VGA-0, DVI-0, LVDS (interner Laptop-Screen) und S-Video. Dann also z.B.
Code:

$ xrandr --output VGA-0 --rate 60

Falls das klappt, kannst du die Eigenschaften deines Monitors auch in der Datei /etc/X11/xorg.conf.d/50-monitor.conf festlegen.
Code:

Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
  HorizSync 28-115
  VertRefresh 50-107

  ## Add your mode lines here, use e.g the cvt tool

EndSection

Bei VertRefresh 50-60 eintragen, damit er nicht darüber geht.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Gillo



Anmeldungsdatum: 12.11.2008
Beiträge: 58

BeitragVerfasst am: 12. März 2012 17:46   Titel:

ich glaube es ist besser geworden.

ich habe in Section "Monitor" die Doppelkreuze vor HorizSync und VertRefresh entfernt und bei VertRefresh 50-60 eingetragen.
Bei mir gibt es nur zwei Ausgänge DVI-I 1 und DVI-I 2 und für jeder Ausgang gibt es analog und digital. Auf den Ausgang wird ein AGB Adapter gesteckt.
Mit dem TFT Monitor hast Du recht.

Ich danke Dir für Deine Hilfe.

Viele Grüße
Roland
_________________
Bitte nicht auf englisch-sprachige Seiten verweisen, kann nur sächsisch
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy