Login
Login-Name Passwort


 
Newsletter

Thema: Splashscreen in StarOffice/OpenOffice.org deaktivieren

30 Kommentar(e) || Alle anzeigen ||  RSS || Kommentieren
Kommentare von Lesern spiegeln nicht unbedingt die Meinung der Redaktion wider.
0
Von Lord am Mo, 10. November 2003 um 22:45 #
>>>>So verhindert er effektiv ein Weiterarbeiten mit anderen Applikationen, während Office startet

Wie lange benötigt denn euer Openoffice zum starten, dass ich da mit anderen Programmen noch weiterarbeiten wollt.

Test auf meiner Maschine:

time nice oowriter

real 0m5.660s
user 0m2.960s
sys 0m0.120s

  • 0
    Von Schugy am Mo, 10. November 2003 um 23:24 #
    8 Sekunden für den soffice-Desktop, auf dem ich dann die gewünschte Dokumentenart wählen kann, sind wirklich nicht dramatisch. (XP2000+ & 512MB DDR RAM)
    Was soll man daran noch verbessen? Und wie klein ist daran der Anteil für den Splashscreen?


    MfG

    0
    Von at am Di, 11. November 2003 um 00:17 #
    Beim ersten Start? Braucht hier knapp 30s, wenn es mir meist nicht so lange vorkommt.
    0
    Von Sascha Dolenec am Mi, 12. November 2003 um 09:13 #
    >Wie lange benötigt denn euer Openoffice zum >starten, dass ich da mit anderen Programmen >noch weiterarbeiten wollt.

    Auf meinem Acer Notebook PII 400 mit 196MB Ram benötigt OOo etwa 5 Schluck aus meiner Kaffeetasse bis sich was tut. Jetzt allerdings ohne das nervige nicht zu entfernende Logo.
    Klasse Tip!

    Viele Grüße, Sascha.

0
Von Finck am Mo, 10. November 2003 um 22:48 #
Danke!!! Solche kleinen Tips sollten wir alle verstärkt sammeln! Für ein NOCH besseres "tuxen"!

Gruß

  • 0
    Von Matthias am Mo, 10. November 2003 um 23:20 #
    Stimmt
    noch praktischer wär aber so ein OO-Splash wie unter Knoppix, der beim draufklicken verschwindet, so wie der KDE-Splash dies tut

    gut gohn Matthias

    • 0
      Von Puppenkasper am Mo, 10. November 2003 um 23:51 #
      Ich habe noch gar nicht gewusst, dass der KDE-Splash bei einem Klick verschwindet. Muss ich direkt mal testen, wenn ich ihn das nächste mal sehe. Kann aber dauern, bis es soweit ist...
      • 0
        Von paul am Di, 11. November 2003 um 01:11 #
        Wofür ist das eigentlich brauchbar, dass der KDE-Splashscreen verschwindet? Hab aus versehen schon ein paar mal raufgeklickt und dachte mir immer das ist ein Bug. Ich meine Arbeiten kann man ja zu dem Zeitpunkt noch nicht.

        Grüße
        Paul

    0
    Von Pascal Brück am Di, 11. November 2003 um 12:56 #
    Dem kann ich mich nur anschliessen.
    Vielen Dank für eure Dienste, die einem das Leben manchmal doch stark erleichtern.

    ;)Pascal

0
Von berbog am Di, 11. November 2003 um 07:24 #
Komisch bei mir heißt die Datei soffice.ini (Windows). Der Start ist aber damit merklich schneller geworden. Trozdem danke für den Tip
  • 0
    Von fuffy am Di, 11. November 2003 um 09:04 #
    Laut Informationen aus dem Netz heisst die korrespondierende Datei in der Windows-Version der Office-Suite "soffice.ini".
    Wer lesen kann, ist klar im Vorteil. ;-)
    0
    Von Hassel am Di, 11. November 2003 um 09:26 #
    Nunja der Start wird dadurch ja auch nicht wirklich schneller,
    ABER :) du kannst nebenher noch was hochdramatisches schaffen..
    mails lesen z.B.

    mich nervt dieses always on top genöle ziemlich, von daher find ich das sehr praktisch sowas abschalten zu können

0
Von marting am Di, 11. November 2003 um 10:01 #
Super Tipp, kleine Ergaenzung fuer debian-user:
Falls man OO per debian-package installiert hat:
einfach /etc/openoffice/sofficerc aendern.
0
Von Peter am Di, 11. November 2003 um 10:29 #
Ein Programm, welches länger als ein Nano-Jahrhundert zum starten braucht ist nicht zu verwenden :-)
  • 0
    Von Stefan am Di, 11. November 2003 um 11:39 #
    Sehr qualifizierte Aussage!

    Der Splaschscreen kann bei der Installation mit Debian bereits deaktiviert werden.
    Auf meinem Laptop(Mobile P3-800MHZ) braucht die OOffice1.1 ca. 18 Sekunden zum starten.
    Dabei habe ich auf das Pre-Linking verzichtet, was die Geschwindigkeit nochmal erhoehen sollte.

    Word verwendet, soweit ich weiss, auch eine Art Pre-Linking.
    Kein Wunder also, wenn es schneller startet.
    Nun ist aber ein Officepaket kein Viewer, den man mal eben fuer 5 Sekunden offen hat.
    Dann waere alles, was nicht sofort geladen ist nervig.
    Wenn ich aber auch nur einen kleinen Brief schreibe, wird die Startzeit im Vergleich zur Programmlaufzeit vernachlaessigbar kurz. Deshalb befremdet mich die Startzeitdiskussion etwas.

    Ihr solltet lieber mal eure Erfahrungen mit den neuen Features posten.
    Vorschlaege:
    - Stabilitaet
    - Performance
    - Bedienbarkeit der neuen Oberflaeche
    - Qualitaet des PDF Creator
    - usw.

    Gruss, Stefan

    • 0
      Von Jochen am Di, 11. November 2003 um 13:28 #
      Die Startzeit von SO/OOo.org ist auch nicht Hintergrund des Tipps. Schliesslich ändert sich durch das Ausschalten des Logos die Dauer des Startvorgangs in keinster Weise. Ich stimme auch mit Dir überein, dass die Startzeit normalerweise bei einem Office-Paket nicht so wichtig ist. Aber wenn man während der Startzeit durch den Startvorgang gestört wird, ist m.E. jede Sekunde zuviel. Schliesslich hat man doch häufig einen Browser, ein Terminalfenster oder sonst irgendwelche Programme offen. Wozu hat man sonst ein Multitasking-taugliches System?

      > Ihr solltet lieber mal eure Erfahrungen mit den neuen Features posten.

      Prima! Ich freue mich auf Deinen Artikel!

      Jochen

      0
      Von Robmaster am So, 9. März 2003 um 12:45 #
      Hi , wie ich mitbekommen habe ,dauert das starten von OpenOffice bei euch zulange !
      Ihr müsst nicht den start splash deaktivieren das bringt garnichts , sonder ihr müsst OpenOffice prelinken , dass heist es werden beim start Automatisch 32MB eures Arbeitsspeichers reserviert um oO schneller zu starten !

      Bei Debian müsst ihr nur ein dpkg-reconfigure OpenOffice.org-bin ausführen , und dann Prelinken starten !!

      PS: Ich benutze einen Celleron 600 mit 512MB und brauche 6 sekunden !!

    0
    Von Jochen P. am Di, 11. November 2003 um 12:03 #
    Ein Jahr hat ca. Pi*10hoch7 Sek, also ein Jh Pi*10hoch9.
    Ein nJh sind demnach ca 3,1 Sek. Gibt es noch blödere Einheiten? Femtolichtjahr?
    • 0
      Von Jochen am Di, 11. November 2003 um 13:18 #
      Zu empfehlen wäre da das Furlong/Firkin/Fortnight-System. Ein Microfortnight ("Mikro-Doppelwoche") entspricht 1.2096 Sekunden. Siehe auch den Eintrag im Jargon-File.

      Jochen

      0
      Von Frank P. am Mi, 12. November 2003 um 10:28 #
      Hi Jochen,

      hier ein kleiner Hinweis - ein Lichtjahr ist keine Zeiteinheit, sondern eine Längeneinheit (die Entfernung, die das Licht in einem Jahr zurück legt -> 1Lj = 9,46 * 10^15 m) die in der Astronomie für "mittlere" Entfernungen benutzt wird.

      Gruß Frank

0
Von Heinrich Geis am Mi, 12. November 2003 um 07:19 #
Kann man mit sofficerc noch weitere Einstellungen vornehmen ? Nur Logo an/aus ist ja ein bisschen wenig für eine ganze Datei. ;-))) Danke und viele Grüße. H.
0
Von bz am Mi, 12. November 2003 um 23:18 #
Super tipp dankeschoen. Ich habe auch schon versucht den Splashscreen zu entfernen. Der ist total ueberfluessig und nervig.
0
Von Kane32 am Sa, 15. November 2003 um 08:16 #
Auf meinem Rechner (Debian SID) hat das ganze nur einen optischen Vorteil. Während des Ladens kann ich immer noch nicht weiterarbeiten
  • 0
    Von Gunnar am Mi, 19. November 2003 um 00:07 #
    OO-Start: 90 bis 150 sek.
    auf Compaq Deskpro 2000 mit 166 MHz, 96 MB, 1,6 GB Platte, SUSE 9.0, KDE oder Gnome
    (Ich versuche die 20 Uralt-PCs unserer Grundschule M$-frei zu halten)
    Übrigens: Auf gleichem PC mit Win2000 startet Staroffice in brauchbaren 4 sek.

    Bin für jeden Tipp dankbar!
    Grüße, Gunnar

    • 0
      Von Doki Nafaso am Fr, 12. Dezember 2003 um 15:59 #
      Hm.. installier OOo doch mal auf einer Reiser-Partition. Das hat bei mir eindeutig einen Geschwindigkeitsschub beim Starten gegeben. AMD K6/2 @400 Mhz ist auch nicht die schnellste CPU, immerhin ist OOo jetzt nach 22 Sekunden bereit.
      • 0
        Von dissenter am Do, 18. Dezember 2003 um 23:47 #
        Unter Woody mit Kernel 2.4.23 aus den Vanilla-Quellen und auf ext2fs-Partition benötigt OOo1.1.0 auf meinem Athlon XP 1600+ mit 256MB RAM beim ersten Start etwa 8 Sekunden, danach ca. 3. Auf meinem OmniBook 4150 (PII 366, 256MB RAM) sind es beim Erststart gute 21 Sekunden, danach ungefähr 8. Gestartet habe ich es aus dem WMaker und es handelt sich bei OOo um die fertigen Binärpakete. Ich halte die Zeiten für ausreichend. So, jetzt werd ich mal den Splashscreen abschalten. ;)
Pro-Linux
Unterstützer werden
Neue Nachrichten