Login
Login-Name Passwort


 
Newsletter
Werbung

Di, 23. August 2011, 15:34

Software::Entwicklung

Entwickler warnen vor PHP 5.3.7

Aufgrund eines Fehlers in der vor kurzem freigegebenen Version 5.3.7 warnen die Entwickler nun vor einem produktiven Einsatz dieser Version und empfehlen, auf die kommende Version 5.3.8 zu warten.

Nicht einmal fünf Tage ist die aktuelle Version 5.3.7 des »PHP: Hypertext Preprocessors« (PHP) alt. Wer allerdings auf die neueste Version aufsetzen will, sollte noch ein wenig warten. Wie die Entwickler schreiben, führt ein Fehler in der Funktion crypt() dazu, dass die im Zusammenhang mit dem Hash-Algorithmus MD5 generierten Hashwerte nicht das Ergebnis der Hash-Operation zurückliefern, sondern lediglich das Salt. Bei der Nutzung von DES oder Blowfish funktioniert crypt() weiter wie erwartet.

Die Entwickler warnen deshalb vor einer Nutzung der aktuellen Version und empfehlen, vorerst die alte Version einzusetzen. Mit der neuen Version 5.3.8, die das Problem behebt, ist in wenigen Tagen zu rechnen.

Werbung
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung