Login
Login-Name Passwort


 
Newsletter
Werbung

Di, 30. Juli 2002, 23:02

Software::Entwicklung

Qt 3.0.5

Die norwegische Firma Trolltech hat einen kleinen Update der Qt-Bibliothek fertiggestellt.

Version 3.0.5 soll ausschließlich Fehler beheben und mit der vorangegangenen Version kompatibel sein. Änderungen, die die Kompatibilität beeinträchtigen könnten, gab es dennoch.

Zum einen wurde das Format der Konstanten QT_VERSION geändert. In der neuen Version ist diese Konstante definiert als 0x030005.

Zum anderen wurde die Semantik beim Laden von Plugins geändert, um Probleme beim Laden von Plugins zu vermeiden, die mit anderen Versionen von Qt gelinkt sind. Plugins, die mit Qt 3.0.4 und früheren Versionen gelinkt sind, können in Qt 3.0.5 nicht geladen werden und müssen neu kompiliert werden.

Daneben wurden einige Methoden, die früher als inline deklariert waren, zu normalen Methoden gemacht, was den Code signifikant verkleinern soll.

Qt steht unter der GPL, kann aber auch käuflich mit einer kommerziellen Lizenz erworben werden. Die GPL-Version, die bekanntlich die Basis von KDE bildet, kann von der Trolltech Website heruntergeladen werden.

Werbung
Kommentare (Insgesamt: 10 || Alle anzeigen || Kommentieren )
15 Talge alte Meldung.... (Roadrunner, Mi, 31. Juli 2002)
Re[3]: Sommerloch? (Mike, Mi, 31. Juli 2002)
Re: KDE 3.0.2 Probleme? (Anonymous, Mi, 31. Juli 2002)
KDE 3.0.2 Probleme? (Daniel, Mi, 31. Juli 2002)
Re[2]: Sommerloch? (BufferOverflow, Mi, 31. Juli 2002)
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung