Login


 
Newsletter
Werbung
Sicherheit: Mangelnde Rechteprüfung in NX
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in NX
ID: 201201-07
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mo, 23. Januar 2012, 22:50
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3977

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig641C8E773FF13BA93DD9AAD9
Content-Type: text/plain; charset=ISO-8859-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201201-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: NX Server Free Edition, NX Node: Privilege escalation
Date: January 23, 2012
Bugs: #378345
ID: 201201-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An unspecified vulnerability in NX Server Free Edition and NX Node
could allow local attackers to gain root privileges.

Background
==========

NX Server Free Edition is a remote display technology by No Machine. NX
Node provides the shared components for NX Server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/nxserver-freeedition
< 3.5.0.5 >= 3.5.0.5
2 net-misc/nxnode < 3.5.0.4 >= 3.5.0.4
-------------------------------------------------------------------
2 affected packages

Description
===========

NX Server Free Edition and NX Node use nxconfigure.sh, a setuid script
containing an unspecified vulnerability.

Impact
======

A local attacker could gain escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All NX Server Free Edition users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v
">=net-misc/nxserver-freeedition-3.5.0.5"

All NX Node users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.5.0.4"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 23, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2011-3977
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-3977

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201201-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--------------enig641C8E773FF13BA93DD9AAD9
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iF4EAREIAAYFAk8dTpsACgkQAnl3SfnYR/iGIgD/axYyOmi4St74WzJNaCjq7lBe
nH8WYnsNuuSoe8z6ptYA/0XSvsr4gwOhhgm4AdY16ubJumKaRE9q8b33V0Z8uu+6
=YXv/
-----END PGP SIGNATURE-----

--------------enig641C8E773FF13BA93DD9AAD9--
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung