Login


 
Newsletter
Werbung
Sicherheit: Pufferüberlauf in libxml2
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libxml2
ID: openSUSE-SU-2012:1647-1
Distribution: SUSE
Plattformen: SUSE openSUSE 12.1, SUSE openSUSE 12.2
Datum: Mo, 17. Dezember 2012, 15:46
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5134

Originalnachricht

   openSUSE Security Update: libxml2: fixed buffer overflow during decoding
entities
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:1647-1
Rating: important
References: #793334
Cross-References: CVE-2012-5134
Affected Products:
openSUSE 12.2
openSUSE 12.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

A Heap-based buffer underflow in the
xmlParseAttValueComplex function in parser.c in libxml2
allowed remote attackers to cause a denial of service or
possibly execute arbitrary code via crafted entities in an
XML document.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2012-854

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-854

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

libxml2-2-2.7.8+git20120223-8.9.1
libxml2-2-debuginfo-2.7.8+git20120223-8.9.1
libxml2-debugsource-2.7.8+git20120223-8.9.1
libxml2-devel-2.7.8+git20120223-8.9.1
libxml2-tools-2.7.8+git20120223-8.9.1
libxml2-tools-debuginfo-2.7.8+git20120223-8.9.1
python-libxml2-2.7.8+git20120223-8.9.1
python-libxml2-debuginfo-2.7.8+git20120223-8.9.1
python-libxml2-debugsource-2.7.8+git20120223-8.9.1

- openSUSE 12.2 (x86_64):

libxml2-2-32bit-2.7.8+git20120223-8.9.1
libxml2-2-debuginfo-32bit-2.7.8+git20120223-8.9.1
libxml2-devel-32bit-2.7.8+git20120223-8.9.1

- openSUSE 12.2 (noarch):

libxml2-doc-2.7.8+git20120223-8.9.1

- openSUSE 12.1 (i586 x86_64):

libxml2-2.7.8+git20110708-3.15.1
libxml2-debuginfo-2.7.8+git20110708-3.15.1
libxml2-debugsource-2.7.8+git20110708-3.15.1
libxml2-devel-2.7.8+git20110708-3.15.1

- openSUSE 12.1 (x86_64):

libxml2-32bit-2.7.8+git20110708-3.15.1
libxml2-debuginfo-32bit-2.7.8+git20110708-3.15.1
libxml2-devel-32bit-2.7.8+git20110708-3.15.1

- openSUSE 12.1 (noarch):

libxml2-doc-2.7.8+git20110708-3.15.1

- openSUSE 12.1 (ia64):

libxml2-debuginfo-x86-2.7.8+git20110708-3.15.1
libxml2-x86-2.7.8+git20110708-3.15.1


References:

http://support.novell.com/security/cve/CVE-2012-5134.html
https://bugzilla.novell.com/793334

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Frohe Weihnachten Fest!
Neue Nachrichten
Werbung