Login


 
Newsletter
Werbung
Sicherheit: Mehrere Probleme in Xen
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Xen
ID: openSUSE-SU-2012:1685-1
Distribution: SUSE
Plattformen: SUSE openSUSE 12.2
Datum: Mo, 24. Dezember 2012, 10:35
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5510
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5511
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5512
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5513
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5514
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5515

Originalnachricht

   openSUSE Security Update: xen to fix various denial of service issues
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:1685-1
Rating: important
References: #777628 #789940 #789944 #789945 #789948 #789950
#789951 #789988 #792476
Cross-References: CVE-2012-5510 CVE-2012-5511 CVE-2012-5512
CVE-2012-5513 CVE-2012-5514 CVE-2012-5515

Affected Products:
openSUSE 12.2
______________________________________________________________________________

An update that solves 6 vulnerabilities and has three fixes
is now available.

Description:

This update of XEN fixes various denial of service bugs.


- bnc#789945 - CVE-2012-5510: xen: Grant table version
switch list corruption vulnerability (XSA-26)

- bnc#789944 - CVE-2012-5511: xen: Several HVM operations
do not validate the range of their inputs (XSA-27)

- bnc#789940 - CVE-2012-5512: xen: HVMOP_get_mem_access
crash / HVMOP_set_mem_access information leak (XSA-28)

- bnc#789951 - CVE-2012-5513: xen: XENMEM_exchange may
overwrite hypervisor memory (XSA-29)

- bnc#789948 - CVE-2012-5514: xen: Missing unlock in
guest_physmap_mark_populate_on_demand() (XSA-30)

- bnc#789950 - CVE-2012-5515: xen: Several memory hypercall
operations allow invalid extent order values (XSA-31)

- bnc#789988 - FATAL PAGE FAULT in hypervisor
(arch_do_domctl)
25931-x86-domctl-iomem-mapping-checks.patch

- Upstream patches from Jan
26132-tmem-save-NULL-check.patch
26134-x86-shadow-invlpg-check.patch
26148-vcpu-timer-overflow.patch (Replaces
CVE-2012-4535-xsa20.patch)
26149-x86-p2m-physmap-error-path.patch (Replaces
CVE-2012-4537-xsa22.patch)
26150-x86-shadow-unhook-toplevel-check.patch (Replaces
CVE-2012-4538-xsa23.patch)
26151-gnttab-compat-get-status-frames.patch (Replaces
CVE-2012-4539-xsa24.patch)


- bnc#777628 - guest "disappears" after live migration
Updated block-dmmd script

- Fix exception in balloon.py and osdep.py
xen-max-free-mem.diff

- bnc#792476 - efi files missing in latest XEN update
Revert c/s 25751 EFI Makefile changes in
23614-x86_64-EFI-boot.patch


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2012-870

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

xen-debugsource-4.1.3_06-5.17.1
xen-devel-4.1.3_06-5.17.1
xen-kmp-default-4.1.3_06_k3.4.11_2.16-5.17.1
xen-kmp-default-debuginfo-4.1.3_06_k3.4.11_2.16-5.17.1
xen-kmp-desktop-4.1.3_06_k3.4.11_2.16-5.17.1
xen-kmp-desktop-debuginfo-4.1.3_06_k3.4.11_2.16-5.17.1
xen-libs-4.1.3_06-5.17.1
xen-libs-debuginfo-4.1.3_06-5.17.1
xen-tools-domU-4.1.3_06-5.17.1
xen-tools-domU-debuginfo-4.1.3_06-5.17.1

- openSUSE 12.2 (x86_64):

xen-4.1.3_06-5.17.1
xen-doc-html-4.1.3_06-5.17.1
xen-doc-pdf-4.1.3_06-5.17.1
xen-libs-32bit-4.1.3_06-5.17.1
xen-libs-debuginfo-32bit-4.1.3_06-5.17.1
xen-tools-4.1.3_06-5.17.1
xen-tools-debuginfo-4.1.3_06-5.17.1

- openSUSE 12.2 (i586):

xen-kmp-pae-4.1.3_06_k3.4.11_2.16-5.17.1
xen-kmp-pae-debuginfo-4.1.3_06_k3.4.11_2.16-5.17.1


References:

http://support.novell.com/security/cve/CVE-2012-5510.html
http://support.novell.com/security/cve/CVE-2012-5511.html
http://support.novell.com/security/cve/CVE-2012-5512.html
http://support.novell.com/security/cve/CVE-2012-5513.html
http://support.novell.com/security/cve/CVE-2012-5514.html
http://support.novell.com/security/cve/CVE-2012-5515.html
https://bugzilla.novell.com/777628
https://bugzilla.novell.com/789940
https://bugzilla.novell.com/789944
https://bugzilla.novell.com/789945
https://bugzilla.novell.com/789948
https://bugzilla.novell.com/789950
https://bugzilla.novell.com/789951
https://bugzilla.novell.com/789988
https://bugzilla.novell.com/792476

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Frohe Weihnachten Fest!
Neue Nachrichten
Werbung