Login


 
Newsletter
Werbung
Sicherheit: Ausführen beliebiger Kommandos in automake
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in automake
ID: RHSA-2013:0526-02
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: Do, 21. Februar 2013, 09:14
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3386

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Low: automake security update
Advisory ID: RHSA-2013:0526-02
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2013-0526.html
Issue date: 2013-02-21
CVE Names: CVE-2012-3386
=====================================================================

1. Summary:

An updated automake package that fixes one security issue is now available
for Red Hat Enterprise Linux 6.

The Red Hat Security Response Team has rated this update as having low
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop Optional (v. 6) - noarch
Red Hat Enterprise Linux HPC Node (v. 6) - noarch
Red Hat Enterprise Linux Server (v. 6) - noarch
Red Hat Enterprise Linux Workstation (v. 6) - noarch

3. Description:

Automake is a tool for automatically generating Makefile.in files compliant
with the GNU Coding Standards.

It was found that the distcheck rule in Automake-generated Makefiles made a
directory world-writable when preparing source archives. If a malicious,
local user could access this directory, they could execute arbitrary code
with the privileges of the user running "make distcheck".
(CVE-2012-3386)

Red Hat would like to thank Jim Meyering for reporting this issue. Upstream
acknowledges Stefano Lattarini as the original reporter.

Users of automake are advised to upgrade to this updated package, which
corrects this issue.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

5. Bugs fixed (http://bugzilla.redhat.com/):

838286 - CVE-2012-3386 automake: locally exploitable "make distcheck"
bug

6. Package List:

Red Hat Enterprise Linux Desktop Optional (v. 6):

Source:
automake-1.11.1-4.el6.src.rpm

noarch:
automake-1.11.1-4.el6.noarch.rpm

Red Hat Enterprise Linux HPC Node (v. 6):

Source:
automake-1.11.1-4.el6.src.rpm

noarch:
automake-1.11.1-4.el6.noarch.rpm

Red Hat Enterprise Linux Server (v. 6):

Source:
automake-1.11.1-4.el6.src.rpm

noarch:
automake-1.11.1-4.el6.noarch.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
automake-1.11.1-4.el6.src.rpm

noarch:
automake-1.11.1-4.el6.noarch.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2012-3386.html
https://access.redhat.com/security/updates/classification/#low

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2013 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFRJcQyXlSAg2UNWIIRAgnyAJ9dD5zbPo7pHCs3XhEzRDKQ3T96oACeNDGZ
CSOzHRnJmVwwby3KFf7C99k=
=wCjX
-----END PGP SIGNATURE-----


--
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
Pro-Linux
Frohe Ostern
Neue Nachrichten
Werbung