Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Denial of Service in clamav
Aktuelle Meldungen Distributionen
Name: Denial of Service in clamav
ID: FEDORA-2015-1461
Distribution: Fedora
Plattformen: Fedora 21
Datum: Sa, 31. Januar 2015, 09:41
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9328

Originalnachricht

Name        : clamav
Product : Fedora 21
Version : 0.98.6
Release : 1.fc21
URL : http://www.clamav.net
Summary : End-user tools for the Clam Antivirus scanner
Description :
Clam AntiVirus is an anti-virus toolkit for UNIX. The main purpose of this
software is the integration with mail servers (attachment scanning). The
package provides a flexible and scalable multi-threaded daemon, a command
line scanner, and a tool for automatic updating via Internet. The programs
are based on a shared library distributed with the Clam AntiVirus package,
which you can use with your own software. The virus database is based on
the virus database from OpenAntiVirus, but contains additional signatures
(including signatures for popular polymorphic viruses, too) and is KEPT UP
TO DATE.

-------------------------------------------------------------------------------
-
Update Information:

ClamAV 0.98.6
=============

ClamAV 0.98.6 is a bug fix release correcting the following:

* library shared object revisions.
* installation issues on some Mac OS X and FreeBSD platforms.
* includes a patch from Sebastian Andrzej Siewior making ClamAV pid files
compatible with systemd.
* Fix a heap out of bounds condition with crafted Yoda's crypter files.
This issue was discovered by Felix Groebert of the Google Security Team.
* Fix a heap out of bounds condition with crafted mew packer files. This
issue was discovered by Felix Groebert of the Google Security Team.
* Fix a heap out of bounds condition with crafted upx packer files. This
issue was discovered by Kevin Szkudlapski of Quarkslab.
* Fix a heap out of bounds condition with crafted upack packer files. This
issue was discovered by Sebastian Andrzej Siewior. CVE-2014-9328.
* Compensate a crash due to incorrect compiler optimization when handling
crafted petite packer files. This issue was discovered by Sebastian Andrzej Siewior.
-------------------------------------------------------------------------------
-
ChangeLog:

* Thu Jan 29 2015 Robert Scheck <robert@fedoraproject.org> - 0.98.6-1
- Upgrade to 0.98.6 and updated daily.cvd (#1187050)
* Wed Nov 19 2014 Robert Scheck <robert@fedoraproject.org> - 0.98.5-2
- Corrected summary of clamav-server-systemd package (#1165672)
* Wed Nov 19 2014 Robert Scheck <robert@fedoraproject.org> - 0.98.5-1
- Upgrade to 0.98.5 and updated daily.cvd (#1138101)
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1187050 - CVE-2014-9328 clamav: heap out of bounds condition with
crafted upack packer files
https://bugzilla.redhat.com/show_bug.cgi?id=1187050
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update clamav' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung