Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Denial of Service in libevent
Aktuelle Meldungen Distributionen
Name: Denial of Service in libevent
ID: 201502-07
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 7. Februar 2015, 22:37
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-6272

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--xDfjqHIeKtlmf1aQ5xq81qSDf3DkomPGS
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201502-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libevent: User-assisted execution of arbitrary code
Date: February 07, 2015
Bugs: #535774
ID: 201502-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflow errors in libevent could result in execution
of arbitrary code or Denial of Service.

Background
==========

libevent is a library to execute a function when a specific event
occurs on a file descriptor.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libevent < 2.0.22 >= 2.0.22

Description
===========

Multiple integer overflow errors in libevent could cause a heap-based
buffer overflow.

Impact
======

A context-dependent attacker could cause an application linked against
libevent to pass an excessively long input through evbuffer, possibly
resulting in execution of arbitrary code with the privileges of the
process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libevent users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libevent-2.0.22"

References
==========

[ 1 ] CVE-2014-6272
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6272

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201502-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2015 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



--xDfjqHIeKtlmf1aQ5xq81qSDf3DkomPGS
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEcBAEBCgAGBQJU1nZyAAoJEP7VAChXwav6NcQIAKjM7uMETkORoT38MNyRVw+u
c1pfrIn/JGqIiq7N02L20rpHLn8hm4pOkFF+Vug8R6oEncxWB25CL8G0JvHICL+t
/Bz2Ejmw+0RR4QBpn1hrDxf7w7AdhXIs/mudLHRLWDbHzfSsX8eoeHMAZZQK3PIR
+sVm8Wz6mGx7De676FQHYuNQK8+TmyBnfkJ1+oCkWaKDb8PpOq2f6JluYb83TKsx
+iRR7dQzx2w1oDZaT/1kuOGNos1il3kU9FiyUI6LHvenYaGX0LKn0VPP4x+KDn6s
02JDXS7xzrsat55a8AuCvKQ2xHXa1b/u7eNBItEtcJBlDJ/F2G2YYnvkiVaIYVc=
=Wda2
-----END PGP SIGNATURE-----

--xDfjqHIeKtlmf1aQ5xq81qSDf3DkomPGS--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung