Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Zwei Probleme in ruby1.8
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in ruby1.8
ID: DSA-3159-1
Distribution: Debian
Plattformen: Debian sid, Debian wheezy, Debian jessie
Datum: Di, 10. Februar 2015, 22:40
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8080
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8090

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-3159-1 security@debian.org
http://www.debian.org/security/ Alessandro Ghedini
February 10, 2015 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : ruby1.8
CVE ID : CVE-2014-8080 CVE-2014-8090

It was discovered that the REXML parser, part of the interpreter for the
Ruby language, could be coerced into allocating large string objects that
could consume all available memory on the system. This could allow remote
attackers to cause a denial of service (crash).

For the stable distribution (wheezy), this problem has been fixed in version
1.8.7.358-7.1+deb7u2.

For the upcoming stable distribution (jessie), this problem has been fixed in
version 2.1.5-1 of the ruby2.1 source package.

For the unstable distribution (sid), this problem has been fixed in version
2.1.5-1 of the ruby2.1 source package.

We recommend that you upgrade your ruby1.8 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJU2kR0AAoJEBDCk7bDfE42SSEQAJy3m3wriQa2WEclrrjIjbdP
NKjj/ZIKRx2y6QSd1JAJK0j6XyuXcCrWGvZu+UgZ9LgRZcR+mNjgyTb+75WE/3Dl
6KAwYCZ2S5xOfQXhwQfUOlIE5tGCkvi4PLlnp4PY6OURe+5l0+GFAIVVEMSnb+R0
Ab2eb4zkZFMXZ84rnI4zQ+Leibrq0eZ5ashbZI8jlTfMznOudrZtG8E6Z+k8Jx2w
T691sTLkekeVE338C3C6xoyQPMchqXJVQ+zvsfwN8bBX0EdkMq156bjs3RbePuNS
7/dDHeovNoAL0YBKiZWm+3s+sh86rM0+tId8LW4PLTowjm+vpJvknEjKdVadYny4
bSeS9Ae7/ocD6gbt1klMWYjfIIMnXwkTNiHx5bgdBKbWJF5Wlnq4bsQqOCYaxj5a
ZaIM9jb98oTDwbWmsC8XoANTx4jXfzU50N9KNN/do5jZL0sjPqDvVRgAPiaYmgKf
WUnys1CiFOkHcjKhM42Ex/LZmAiLXlBFC97B77D2IreGUJVee91MioHYELFjh+z6
frUbmEBCvvK29ftdpZWaXNwAWZ3EtsHlMHh+9ZjUQv53UI62Ys2kQiUcrP9AxQMZ
r7W814fueni4/aldTGsEr4KO/2/sErUNH46ObDxy8PU6Ueasl8GG5I8JvFRmcyNX
csYuagZpPY8bAObYwDic
=1EC3
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: https://lists.debian.org/20150210174920.GA6898@pisco.westfalen.local
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung