Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in PostgreSQL
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in PostgreSQL
ID: USN-2499-1
Distribution: Ubuntu
Plattformen: Ubuntu 10.04 LTS, Ubuntu 12.04 LTS, Ubuntu 14.04 LTS, Ubuntu 14.10
Datum: Mi, 11. Februar 2015, 21:25
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8161
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0241
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0243
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0244

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============4329340019456177417==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="QipGQlvfuRIDeITX7aIdan5fj1VxRBhWJ"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--QipGQlvfuRIDeITX7aIdan5fj1VxRBhWJ
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-2499-1
February 11, 2015

postgresql-8.4, postgresql-9.1, postgresql-9.3, postgresql-9.4 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.10
- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS
- Ubuntu 10.04 LTS

Summary:

Several security issues were fixed in PostgreSQL.

Software Description:
- postgresql-9.4: Object-relational SQL database
- postgresql-9.3: Object-relational SQL database
- postgresql-9.1: Object-relational SQL database
- postgresql-8.4: Object-relational SQL database

Details:

Stephen Frost discovered that PostgreSQL incorrectly displayed certain
values in error messages. An authenticated user could gain access to seeing
certain values, contrary to expected permissions. (CVE-2014-8161)

Andres Freund, Peter Geoghegan and Noah Misch discovered that PostgreSQL
incorrectly handled buffers in to_char functions. An authenticated attacker
could possibly use this issue to cause PostgreSQL to crash, resulting in a
denial of service, or possibly execute arbitrary code. (CVE-2015-0241)

It was discovered that PostgreSQL incorrectly handled memory in the
pgcrypto extension. An authenticated attacker could possibly use this issue
to cause PostgreSQL to crash, resulting in a denial of service, or possibly
execute arbitrary code. (CVE-2015-0243)

Emil Lenngren discovered that PostgreSQL incorrectly handled extended
protocol message reading. An authenticated attacker could possibly use this
issue to cause PostgreSQL to crash, resulting in a denial of service, or
possibly inject query messages. (CVE-2015-0244)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.10:
postgresql-9.4 9.4.1-0ubuntu0.14.10

Ubuntu 14.04 LTS:
postgresql-9.3 9.3.6-0ubuntu0.14.04

Ubuntu 12.04 LTS:
postgresql-9.1 9.1.15-0ubuntu0.12.04

Ubuntu 10.04 LTS:
postgresql-8.4 8.4.22-0ubuntu0.10.04.1

This update uses a new upstream release, which includes additional bug
fixes. In general, a standard system update will make all the necessary
changes.

References:
http://www.ubuntu.com/usn/usn-2499-1
CVE-2014-8161, CVE-2015-0241, CVE-2015-0243, CVE-2015-0244

Package Information:
https://launchpad.net/ubuntu/+source/postgresql-9.4/9.4.1-0ubuntu0.14.10
https://launchpad.net/ubuntu/+source/postgresql-9.3/9.3.6-0ubuntu0.14.04
https://launchpad.net/ubuntu/+source/postgresql-9.1/9.1.15-0ubuntu0.12.04
https://launchpad.net/ubuntu/+source/postgresql-8.4/8.4.22-0ubuntu0.10.04.1



--QipGQlvfuRIDeITX7aIdan5fj1VxRBhWJ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJU26AXAAoJEGVp2FWnRL6TMEwQAKfhXwZQlw6ulCX/RphvkUdP
MAL3HGf+iR8gqdffC8bZOcrWP3T1VypGieCnWI6P07RJbmAOE0xyuL7RHWVg2RzG
ZI1isQYeZa0dyquyypW2zbZZcDgfvdMjTudnmeyj5IA2YD1rfBEHPZQndM/P7oN+
c+oV6/LgZ7xxWDfQnGusXUJHFIlaikFoV05gXTzo2jpNBlmVI9M/erTZAQbbnWDS
vAZYEJ+4UWy83goA5pvKNNvN3qBIqVFYdI8Dm7CBqhQ64rbT+uBa+1YvMi6dlD08
Vffdt8g+EjcIqiXoXGqL/1i586+g+2I7rVJwKy/oX2KJ1Ih5vXFZyYbr0fQbWXGi
FDNLTC6hG71mmn7F6H4h/wkp40El9xOtfS9K1h8IroDIigk2J/YHVirayWBKnQoF
40Z2Lnl8eTnPPDwxc3LUqRGF4opSTxQwgzuA/obvdD3I3p/VNJQ1z6E/w7sRmSuJ
LmTPm92i6ep3w2T/vu49O5OJ3UY+AbgJL7KP784KQvN5MsTLqTRsrQaawCLaxSUV
2rwBQH07zOUInPxxN9jg5MS3lzFBzeZH2nAjZNO1PcXWwYbARiMtbuMQvKNIpKp0
19JcuQ4xjWHc5W2SybC8j52Y77ZkVJJrIQyvc5twUSDJ8FLXMieIpZNvayTwkbNE
m2C6m016BUsmQ+RXY0lT
=PmpU
-----END PGP SIGNATURE-----

--QipGQlvfuRIDeITX7aIdan5fj1VxRBhWJ--


--===============4329340019456177417==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============4329340019456177417==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung