Login-Name Passwort


Sicherheit: Zwei Probleme in apache-poi
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in apache-poi
ID: FEDORA-2015-2087
Distribution: Fedora
Plattformen: Fedora 21
Datum: Mo, 23. Februar 2015, 12:57
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3529


Name        : apache-poi
Product : Fedora 21
Version : 3.10.1
Release : 2.fc21
URL : http://poi.apache.org/
Summary : The Java API for Microsoft Documents
Description :
The Apache POI Project's mission is to create and maintain Java APIs for
manipulating various file formats based upon the Office Open XML standards
(OOXML) and Microsoft's OLE 2 Compound Document format (OLE2). In short,
can read and write MS Excel files using Java. In addition, you can read and
write MS Word and MS PowerPoint files using Java. Apache POI is your Java
Excel solution (for Excel 97-2008). We have a complete API for porting other
OOXML and OLE2 formats and welcome others to participate.

OLE2 files include most Microsoft Office files such as XLS, DOC, and PPT as
well as MFC serialization API based file formats. The project provides APIs
for the OLE2 Filesystem (POIFS) and OLE2 Document Properties (HPSF).

Office OpenXML Format is the new standards based XML file format found in
Microsoft Office 2007 and 2008. This includes XLSX, DOCX and PPTX. The
project provides a low level API to support the Open Packaging Conventions
using openxml4j.

For each MS Office application there exists a component module that attempts
to provide a common high level Java API to both OLE2 and OOXML document
formats. This is most developed for Excel workbooks (SS=HSSF+XSSF). Work is
progressing for Word documents (HWPF+XWPF) and PowerPoint presentations

The project has recently added support for Outlook (HSMF). Microsoft opened
the specifications to this format in October 2007. We would welcome

There are also projects for Visio (HDGF) and Publisher (HPBF).

Update Information:

fix for RHBZ#1138135 (CVE-2014-3574)

* Wed Feb 11 2015 gil cattaneo <puntogil@libero.it> 3.10.1-2
- fix for RHBZ#1138135 (CVE-2014-3574)
- introduce license macro

[ 1 ] Bug #1138135 - CVE-2014-3529 apache-poi: XML eXternal Entity (XXE) flaw

This update can be installed with the "yum" update program. Use
su -c 'yum update apache-poi' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
package-announce mailing list
Traut euch!
Neue Nachrichten