Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Pufferüberlauf in CUPS
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in CUPS
ID: USN-2520-1
Distribution: Ubuntu
Plattformen: Ubuntu 10.04 LTS, Ubuntu 12.04 LTS, Ubuntu 14.04 LTS, Ubuntu 14.10
Datum: Do, 26. Februar 2015, 17:48
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9679

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============0365363149957742489==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="lO1TQl8kRWWSsORAHtMqKBLmrsLSUHkMn"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--lO1TQl8kRWWSsORAHtMqKBLmrsLSUHkMn
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-2520-1
February 26, 2015

cups vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.10
- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS
- Ubuntu 10.04 LTS

Summary:

CUPS could be made to crash or run programs if it processed a specially
crafted file.

Software Description:
- cups: Common UNIX Printing System(tm)

Details:

Peter De Wachter discovered that CUPS incorrectly handled certain malformed
compressed raster files. A remote attacker could use this issue to cause
CUPS to crash, resulting in a denial of service, or possibly execute
arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.10:
cups 1.7.5-3ubuntu3.1

Ubuntu 14.04 LTS:
cups 1.7.2-0ubuntu1.5

Ubuntu 12.04 LTS:
cups 1.5.3-0ubuntu8.6

Ubuntu 10.04 LTS:
cups 1.4.3-1ubuntu1.14

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-2520-1
CVE-2014-9679

Package Information:
https://launchpad.net/ubuntu/+source/cups/1.7.5-3ubuntu3.1
https://launchpad.net/ubuntu/+source/cups/1.7.2-0ubuntu1.5
https://launchpad.net/ubuntu/+source/cups/1.5.3-0ubuntu8.6
https://launchpad.net/ubuntu/+source/cups/1.4.3-1ubuntu1.14



--lO1TQl8kRWWSsORAHtMqKBLmrsLSUHkMn
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJU70koAAoJEGVp2FWnRL6TK3IP/1J9eWOLuzZS/+rsTNgl9hQQ
3lSLWtJFKth149Xnmo+1qWXXBD87pWB/4MKMxCzSGdZ6NB9LBhkdlO+FjxDQ/JHy
zWxe7PKcsXc+02Jsh2rNjpU4ZZVxLNsUOUHVHkOqCPRnmajYp2NQkjm4jtgv4Wj8
UaTEDsymzkZDzwSTW6ym5KUPpAHRQRa3S9l8aXEk5vB89pCrZnwRMYA/+nb7tWiM
KkTsjBQszcwQrOOxYdUc5+z9IWHlypVzyqPjgXqkVo4nVa7unpsqEHcbcSu/0fCx
TwSdyLlCHFxEUA0x3bKuFX3mAyVZ2o14b4gBa6nJRpp2jYTc21CI1+yJLAXbssbR
W4kq521UwO6GFJASX1bEPU2ZZuE6/VyeCXIYSgqa4Yq/2XMBg7WZBTCWjRnTqCkh
maDyYIbhmP0SVsvaqnpzGoH5Yut8yWt6hl7qz/t65v3J01TnXQ4Op9igkP+tRwZL
tixYvFOcqn7HrmRysd9qFaL2tEt3JISA3q7R1sceWar38epBfRyfdq1DYx1z2zKf
5u7eFSBQIP910Eev1PQeG3jR8uGbTJhMnhYWqfzkpDsfbBxL4r2B/s/poipT0tM4
qlryxhPbBWfiwhCHv4UVrw+3njMrOSFPdtYogRXv0BakyunoZSSR2dj4NkUEGW6w
QCME0fsiQXpLRD4XZuTC
=pwLt
-----END PGP SIGNATURE-----

--lO1TQl8kRWWSsORAHtMqKBLmrsLSUHkMn--


--===============0365363149957742489==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============0365363149957742489==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung