Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in gnupg
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in gnupg
ID: DSA-3184-1
Distribution: Debian
Plattformen: Debian sid, Debian wheezy
Datum: Do, 12. März 2015, 20:14
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3591
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0837
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1606

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

- -------------------------------------------------------------------------
Debian Security Advisory DSA-3184-1 security@debian.org
http://www.debian.org/security/ Alessandro Ghedini
March 12, 2015 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : gnupg
CVE ID : CVE-2014-3591 CVE-2015-0837 CVE-2015-1606

Multiple vulnerabilities were discovered in GnuPG, the GNU Privacy Guard:

CVE-2014-3591

The Elgamal decryption routine was susceptible to a side-channel
attack discovered by researchers of Tel Aviv University. Ciphertext
blinding was enabled to counteract it. Note that this may have a
quite noticeable impact on Elgamal decryption performance.

CVE-2015-0837

The modular exponentiation routine mpi_powm() was susceptible to a
side-channel attack caused by data-dependent timing variations when
accessing its internal pre-computed table.

CVE-2015-1606

The keyring parsing code did not properly reject certain packet
types not belonging in a keyring, which caused an access to memory
already freed. This could allow remote attackers to cause a denial
of service (crash) via crafted keyring files.

For the stable distribution (wheezy), these problems have been fixed in
version 1.4.12-7+deb7u7.

For the upcoming stable distribution (jessie), these problems have been
fixed in version 1.4.18-7.

For the unstable distribution (sid), these problems have been fixed in
version 1.4.18-7.

We recommend that you upgrade your gnupg packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBCAAGBQJVAdGHAAoJEFb2GnlAHawEJp4IAI50qDF5+QdQQ/1cvcP1tqda
H9QOu6omsKtiXtyTKQnoRfDmZ6dKblWdJMfH9cK9bfoziixwTTkol374u0xuTucY
MW6x08InvELESJKrgGvnnoj+g3xAvHDBOt0BXcL9tBYV81ZzaHBCS75VwwMwHD8n
B3mErX24JpnTH0Y2C4xAi+SuQ74KasB9FGSz3aAbrkvpwTEOumtLc9NG4mROjRXg
ARRJRIQv+PZ8VW2/vImoMiuAgALRttREtoVbaRoKOg8if/r9g49Ix28QFxrfJV7x
P2CaHXLfdcJq5oPuRltJK7vXmQUYwbgQAzv2Xmy0350HzfQcTTvBUFbld2Nd9dE=
=TLCo
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: https://lists.debian.org/20150312175045.07F775A210@kinkhorst.com
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung