Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Denial of Service in libmspack
Aktuelle Meldungen Distributionen
Name: Denial of Service in libmspack
ID: FEDORA-2015-3205
Distribution: Fedora
Plattformen: Fedora 20
Datum: Sa, 14. März 2015, 00:13
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9556

Originalnachricht

Name        : libmspack
Product : Fedora 20
Version : 0.5
Release : 0.1.alpha.fc20
URL : http://www.cabextract.org.uk/libmspack/
Summary : Library for CAB and related files compression and decompression
Description :
The purpose of libmspack is to provide both compression and decompression of
some loosely related file formats used by Microsoft.

-------------------------------------------------------------------------------
-
Update Information:

updated to bugfix release 0.5alpha
-------------------------------------------------------------------------------
-
ChangeLog:

* Tue Mar 3 2015 Dan Horák <dan[at]danny.cz> - 0.5-0.1.alpha
- updated to 0.5alpha
* Sun Aug 17 2014 Fedora Release Engineering
<rel-eng@lists.fedoraproject.org> - 0.4-0.4.alpha
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 7 2014 Fedora Release Engineering
<rel-eng@lists.fedoraproject.org> - 0.4-0.3.alpha
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1196153 - libmspack: off-by-one(?) buffer under-read in
mspack/lzxd.c
https://bugzilla.redhat.com/show_bug.cgi?id=1196153
[ 2 ] Bug #1196157 - libmspack: off-by-one buffer over-read in
mspack/mszipd.c
https://bugzilla.redhat.com/show_bug.cgi?id=1196157
[ 3 ] Bug #1180177 - libmspack: pointer arithmetic overflow during CHM
decompression
https://bugzilla.redhat.com/show_bug.cgi?id=1180177
[ 4 ] Bug #1180175 - libmspack: denial of service while processing crafted
CHM file (floating point exception)
https://bugzilla.redhat.com/show_bug.cgi?id=1180175
[ 5 ] Bug #1178867 - CVE-2014-9556 libmspack: buffer overflow causing denial
of service in qtmd_decompress()
https://bugzilla.redhat.com/show_bug.cgi?id=1178867
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update libmspack' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung