Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in file
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in file
ID: 201503-08
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Di, 17. März 2015, 07:55
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2270
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9620
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9621

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--MKALRrKhWurkd0hrX0SNqAg058KWO0sIh
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201503-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: file: Denial of Service
Date: March 16, 2015
Bugs: #503582, #532768
ID: 201503-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Vulnerabilities in file could allow a context-dependent attack to
create a Denial of Service condition.

Background
==========

The file utility attempts to identify a file’s format by scanning
binary data for patterns.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/file < 5.22 >= 5.22

Description
===========

Multiple issues with the ELF parser used by the file utility have been
detected and fixed.

Impact
======

A context-dependent attacker can cause Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All file users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/file-5.22"

References
==========

[ 1 ] CVE-2014-2270
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2270
[ 2 ] CVE-2014-9620
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9620
[ 3 ] CVE-2014-9621
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9621

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201503-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2015 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



--MKALRrKhWurkd0hrX0SNqAg058KWO0sIh
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iJwEAQECAAYFAlUHMdUACgkQG9wOWsQutdaYYwQAm+mRfo8hX35UKzZJsjSpnVEu
QfaRRqvKLHEXdnfkJBwSGx9IJJdOse/WK0f+PbwpTm324kmP8z5BnLS7fQDyXAZX
WxVBHtLXI02OoCWgmLHbo6g8E7JUVThL2cLaR45NfytsEBTlLwsfBNLsins9rVpz
VzwW2JEYh9O9RffJCyg=
=ipv6
-----END PGP SIGNATURE-----

--MKALRrKhWurkd0hrX0SNqAg058KWO0sIh--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung