Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Xen
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Xen
ID: SUSE-SU-2015:0613-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Software Development Kit 12, SUSE Linux Enterprise Desktop 12
Datum: Fr, 27. März 2015, 12:10
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3615
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9065
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9066
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0361
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2044
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2045
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2151
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2152

Originalnachricht

   SUSE Security Update: Security update for Xen
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:0613-1
Rating: important
References: #861318 #882089 #895528 #901488 #903680 #904255
#906996 #910254 #910681 #912011 #918995 #918998
#919098 #919464 #919663
Cross-References: CVE-2014-3615 CVE-2014-9065 CVE-2014-9066
CVE-2015-0361 CVE-2015-2044 CVE-2015-2045
CVE-2015-2151 CVE-2015-2152
Affected Products:
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that solves 8 vulnerabilities and has 7 fixes is
now available.

Description:


The XEN hypervisor received updates to fix various security issues and
bugs.

The following security issues were fixed:
- CVE-2015-2151: XSA-123: A hypervisor memory corruption due to x86
emulator flaw.
- CVE-2015-2045: XSA-122: Information leak through version information
hypercall.
- CVE-2015-2044: XSA-121: Information leak via internal x86 system device
emulation.
- CVE-2015-2152: XSA-119: HVM qemu was unexpectedly enabling emulated VGA
graphics backends.
- CVE-2014-3615: Information leakage when guest sets high graphics
resolution.
- CVE-2015-0361: XSA-116: A xen crash due to use after free on hvm guest
teardown.
- CVE-2014-9065, CVE-2014-9066: XSA-114: xen: p2m lock starvation.

Also the following bugs were fixed:
- bnc#919098 - XEN blktap device intermittently fails to connect
- bnc#882089 - Windows 2012 R2 fails to boot up with greater than 60 vcpus
- bnc#903680 - Problems with detecting free loop devices on Xen guest
startup
- bnc#861318 - xentop reports "Found interface vif101.0 but domain 101
does not exist."
- Update seabios to rel-1.7.3.1 which is the correct version for Xen 4.4
- Enhancement to virsh/libvirtd "send-key" command The xen side
small fix.
(FATE#317240)
- bnc#901488 - Intel ixgbe driver assigns rx/tx queues per core resulting
in irq problems on servers with a large amount of CPU cores
- bnc#910254 - SLES11 SP3 Xen VT-d igb NIC doesn't work
- Add domain_migrate_constraints_set API to Xend's http interface
(FATE#317239)
- Restore missing fixes from block-dmmd script
- bnc#904255 - XEN boot hangs in early boot on UEFI system
- bsc#912011 - high ping latency after upgrade to latest SLES11SP3 on xen
Dom0
- Fix missing banner by restoring the figlet program.


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12:

zypper in -t patch SUSE-SLE-SDK-12-2015-147=1

- SUSE Linux Enterprise Server 12:

zypper in -t patch SUSE-SLE-SERVER-12-2015-147=1

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-147=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 12 (x86_64):

xen-debugsource-4.4.1_10-9.1
xen-devel-4.4.1_10-9.1

- SUSE Linux Enterprise Server 12 (x86_64):

xen-4.4.1_10-9.1
xen-debugsource-4.4.1_10-9.1
xen-doc-html-4.4.1_10-9.1
xen-kmp-default-4.4.1_10_k3.12.36_38-9.1
xen-kmp-default-debuginfo-4.4.1_10_k3.12.36_38-9.1
xen-libs-32bit-4.4.1_10-9.1
xen-libs-4.4.1_10-9.1
xen-libs-debuginfo-32bit-4.4.1_10-9.1
xen-libs-debuginfo-4.4.1_10-9.1
xen-tools-4.4.1_10-9.1
xen-tools-debuginfo-4.4.1_10-9.1
xen-tools-domU-4.4.1_10-9.1
xen-tools-domU-debuginfo-4.4.1_10-9.1

- SUSE Linux Enterprise Desktop 12 (x86_64):

xen-4.4.1_10-9.1
xen-debugsource-4.4.1_10-9.1
xen-kmp-default-4.4.1_10_k3.12.36_38-9.1
xen-kmp-default-debuginfo-4.4.1_10_k3.12.36_38-9.1
xen-libs-32bit-4.4.1_10-9.1
xen-libs-4.4.1_10-9.1
xen-libs-debuginfo-32bit-4.4.1_10-9.1
xen-libs-debuginfo-4.4.1_10-9.1


References:

http://support.novell.com/security/cve/CVE-2014-3615.html
http://support.novell.com/security/cve/CVE-2014-9065.html
http://support.novell.com/security/cve/CVE-2014-9066.html
http://support.novell.com/security/cve/CVE-2015-0361.html
http://support.novell.com/security/cve/CVE-2015-2044.html
http://support.novell.com/security/cve/CVE-2015-2045.html
http://support.novell.com/security/cve/CVE-2015-2151.html
http://support.novell.com/security/cve/CVE-2015-2152.html
https://bugzilla.suse.com/861318
https://bugzilla.suse.com/882089
https://bugzilla.suse.com/895528
https://bugzilla.suse.com/901488
https://bugzilla.suse.com/903680
https://bugzilla.suse.com/904255
https://bugzilla.suse.com/906996
https://bugzilla.suse.com/910254
https://bugzilla.suse.com/910681
https://bugzilla.suse.com/912011
https://bugzilla.suse.com/918995
https://bugzilla.suse.com/918998
https://bugzilla.suse.com/919098
https://bugzilla.suse.com/919464
https://bugzilla.suse.com/919663

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung