Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in wpa_supplicant
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in wpa_supplicant
ID: openSUSE-SU-2015:0813-1
Distribution: SUSE
Plattformen: SUSE openSUSE 13.1, SUSE openSUSE 13.2
Datum: Sa, 2. Mai 2015, 10:35
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1863

Originalnachricht

   openSUSE Security Update: Security update for wpa_supplicant
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0813-1
Rating: important
References: #927558
Cross-References: CVE-2015-1863
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The wireless network encryption and authentication daemon wpa_supplicant
was updated to fix a security issue.

The following vulnerability was fixed:

* CVE-2015-1863: A buffer overflow in handling SSIDs in P2P management
frames allowed attackers in radio range to crash, expose memory content
or potentially execute arbitrary code.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-341=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-341=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

wpa_supplicant-2.2-5.4.1
wpa_supplicant-debuginfo-2.2-5.4.1
wpa_supplicant-debugsource-2.2-5.4.1
wpa_supplicant-gui-2.2-5.4.1
wpa_supplicant-gui-debuginfo-2.2-5.4.1

- openSUSE 13.1 (i586 x86_64):

wpa_supplicant-2.0-3.11.1
wpa_supplicant-debuginfo-2.0-3.11.1
wpa_supplicant-debugsource-2.0-3.11.1
wpa_supplicant-gui-2.0-3.11.1
wpa_supplicant-gui-debuginfo-2.0-3.11.1


References:

https://www.suse.com/security/cve/CVE-2015-1863.html
https://bugzilla.suse.com/927558

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung