Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Oxide
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Oxide
ID: USN-2860-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 15.04, Ubuntu 15.10
Datum: Di, 12. Januar 2016, 07:20
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6789
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8548
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6790
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8664
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6791

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============0432705173496080435==
Content-Type: multipart/signed; micalg=pgp-sha256;
protocol="application/pgp-signature";
boundary="N7c1Dm1DOJWhTHqKS5X1L2fFTx9ttpOIF"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--N7c1Dm1DOJWhTHqKS5X1L2fFTx9ttpOIF
Content-Type: text/plain; charset=windows-125
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-2860-1
January 11, 2016

oxide-qt vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 15.04
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in Oxide.

Software Description:
- oxide-qt: Web browser engine library for Qt (QML plugin)

Details:

A race condition was discovered in the MutationObserver implementation in
Blink. If a user were tricked in to opening a specially crafted website,
an attacker could potentially exploit this to cause a denial of service
via renderer crash, or execute arbitrary code with the privileges of the
sandboxed render process. (CVE-2015-6789)

An issue was discovered with the page serializer in Blink. If a user were
tricked in to opening a specially crafted website, an attacker could
potentially exploit this to inject arbitrary script or HTML.
(CVE-2015-6790)

Multiple security issues were discovered in Chromium. If a user were
tricked in to opening a specially crafted website, an attacker could
potentially exploit these to read uninitialized memory, cause a denial
of service via application crash or execute arbitrary code with the
privileges of the user invoking the program. (CVE-2015-6791)

Multiple security issues were discovered in V8. If a user were tricked
in to opening a specially crafted website, an attacker could potentially
exploit these to read uninitialized memory, cause a denial of service via
renderer crash or execute arbitrary code with the privileges of the
sandboxed render process. (CVE-2015-8548)

An integer overflow was discovered in the WebCursor::Deserialize function
in Chromium. If a user were tricked in to opening a specially crafted
website, an attacker could potentially exploit this to cause a denial of
service via application crash, or execute arbitrary code with the
privileges of the user invoking the program. (CVE-2015-8664)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
liboxideqtcore0 1.11.4-0ubuntu0.15.10.1

Ubuntu 15.04:
liboxideqtcore0 1.11.4-0ubuntu0.15.04.1

Ubuntu 14.04 LTS:
liboxideqtcore0 1.11.4-0ubuntu0.14.04.1

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-2860-1
CVE-2015-6789, CVE-2015-6790, CVE-2015-6791, CVE-2015-8548,
CVE-2015-8664

Package Information:
https://launchpad.net/ubuntu/+source/oxide-qt/1.11.4-0ubuntu0.15.10.1
https://launchpad.net/ubuntu/+source/oxide-qt/1.11.4-0ubuntu0.15.04.1
https://launchpad.net/ubuntu/+source/oxide-qt/1.11.4-0ubuntu0.14.04.1



--N7c1Dm1DOJWhTHqKS5X1L2fFTx9ttpOIF
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEcBAEBCAAGBQJWk+DDAAoJEGEfvezVlG4PqigH/jeff8aSGLeH95nKlkBLC69Q
xMg1YyH1EoJLqFkRSmQJC/MfFkuaHzeN3F10LCYBX3BA2IOUwTz0FsstRIXnLiAh
u7dUbA0M5eJZfLA4ejoo821CjO95zSJe57ZC1ZG9isnQRI9Y+IyWKujJSyooshSs
VfNQyAFBNj6SGrg2iUcEiIsO6RkHiVWpJe3n4Orr63mr4NAbPDk/UGJm8nmHd848
Lan8yaMGTCEK/67BRpRAFWCu0CelW9dS2DVVgmpeNpw9P7xRM2wp8RI+zg19WkPa
WfkDexpT/+ktCThGulkGCtCsroDL/CAcvrVymQ7lvBBlUz0dBBWdXz+UulN5qTc=
=YQ4J
-----END PGP SIGNATURE-----

--N7c1Dm1DOJWhTHqKS5X1L2fFTx9ttpOIF--


--===============0432705173496080435==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============0432705173496080435==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung