Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in nginx
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in nginx
ID: USN-2892-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 15.10
Datum: Mi, 10. Februar 2016, 07:26
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0746
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0747
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0742

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============2677581410883063539==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="wQW3W94kKTn9VqIlbKT3rHmdA24nIH57c"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--wQW3W94kKTn9VqIlbKT3rHmdA24nIH57c
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-2892-1
February 09, 2016

nginx vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in nginx.

Software Description:
- nginx: small, powerful, scalable web/proxy server

Details:

It was discovered that nginx incorrectly handled certain DNS server
responses when the resolver is enabled. A remote attacker could possibly
use this issue to cause nginx to crash, resulting in a denial of service.
(CVE-2016-0742)

It was discovered that nginx incorrectly handled CNAME response processing
when the resolver is enabled. A remote attacker could use this issue to
cause nginx to crash, resulting in a denial of service, or possibly execute
arbitrary code. (CVE-2016-0746)

It was discovered that nginx incorrectly handled CNAME resolution when
the resolver is enabled. A remote attacker could possibly use this issue to
cause nginx to consume resources, resulting in a denial of service.
(CVE-2016-0747)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
nginx-core 1.9.3-1ubuntu1.1
nginx-extras 1.9.3-1ubuntu1.1
nginx-full 1.9.3-1ubuntu1.1
nginx-light 1.9.3-1ubuntu1.1

Ubuntu 14.04 LTS:
nginx-core 1.4.6-1ubuntu3.4
nginx-extras 1.4.6-1ubuntu3.4
nginx-full 1.4.6-1ubuntu3.4
nginx-light 1.4.6-1ubuntu3.4
nginx-naxsi 1.4.6-1ubuntu3.4

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-2892-1
CVE-2016-0742, CVE-2016-0746, CVE-2016-0747

Package Information:
https://launchpad.net/ubuntu/+source/nginx/1.9.3-1ubuntu1.1
https://launchpad.net/ubuntu/+source/nginx/1.4.6-1ubuntu3.4



--wQW3W94kKTn9VqIlbKT3rHmdA24nIH57c
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCgAGBQJWui8/AAoJEGVp2FWnRL6TvGwP/j8dqyEPiTm7knmTZpRxDLXh
C+XHmIAzJWcqChWmFRCDeZuXBxPVcHZJFaSrMcygEeteGSuPN32r1E+DNxvHmhic
vDWwLFLk8aUcKF51tIqZhqkeoRN4RRjBVONa5wZeieVnJ8cxhq/f123TzF80mNpH
s5Hz2qiqk061noIY/sQbvfrDsooyLK7XMcmXFy+nOV+GKtkJyslsZItff6UX523F
mh/CBIfGIms6chW0xWqA9SUfDmgba+wUl8YG+kUXevgHnU0u4lJNkv6DmDFxGAJL
lpTQVEXrYZ5EHBTdu8ITnW3InEtQHtz/Q7fRPOsVcCjXNoydNfxqFBdzSTI+Ai0H
0nwxs7ngGQ/uC37vXyMSZvauSKsD4JDYZsmX6OCefq6d897Z9Kj2NwS6U5HK4Be1
bqm1zSfigTnSqmwYYJJWjXxKecs6wpcuZ6MSOevgJnFTHfV4Hnd/5fAg8oqE/rBs
B/rAuDQ3VoLSQxDHDSdZK4yP77WvDkMuVUOn4+ydbWcNBG7txSsk+eWYgxAY7U7o
XeOmGa5m/gllt8xCmlI7RYcBSDIv0oeQ94KTf9rJce9kgyY4dZg3x6vPj6Z5pwHP
3xEyBuL3bjUe7IbGRCgIeUl9WbU4RDadLNuKZj/6tHZPRESHNxGgpjdaH8spXS6g
qXjfzZLUUoxjEvZxI0Tq
=CRW4
-----END PGP SIGNATURE-----

--wQW3W94kKTn9VqIlbKT3rHmdA24nIH57c--


--===============2677581410883063539==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============2677581410883063539==--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung