Login


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in IBM JDK for Linux
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in IBM JDK for Linux
ID: SUSE-SU-2016:0428-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Legacy Software 12
Datum: Do, 11. Februar 2016, 16:08
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8540
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0402
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5041
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7575
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8472
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8126
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0466
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7981
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0448
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0494
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0483

Originalnachricht

   SUSE Security Update: Security update for java-1_6_0-ibm
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:0428-1
Rating: important
References: #960286 #960402 #963937
Cross-References: CVE-2015-5041 CVE-2015-7575 CVE-2015-7981
CVE-2015-8126 CVE-2015-8472 CVE-2015-8540
CVE-2016-0402 CVE-2016-0448 CVE-2016-0466
CVE-2016-0483 CVE-2016-0494
Affected Products:
SUSE Linux Enterprise Module for Legacy Software 12
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:


This update for java-1_6_0-ibm fixes the following issues by updating to
6.0-16.20 (bsc#963937)

- CVE-2015-5041: Could could have invoked non-public interface methods
under certain circumstances
- CVE-2015-7575: The TLS protocol could allow weaker than expected
security caused by a collision attack when using the MD5 hash function
for signing a ServerKeyExchange message during a TLS handshake. An
attacker could exploit this vulnerability using man-in-the-middle
techniques to impersonate a TLS server and obtain credentials
- CVE-2015-7981: libpng could allow a remote attacker to obtain sensitive
information, caused by an out-of-bounds read in the
png_convert_to_rfc1123 function. An attacker could exploit this
vulnerability to obtain sensitive information
- CVE-2015-8126: buffer overflow in libpng caused by improper bounds
checking by the png_set_PLTE() and png_get_PLTE() functions
- CVE-2015-8472: buffer overflow in libpng caused by improper bounds
checking by the png_set_PLTE() and png_get_PLTE() functions
- CVE-2015-8540: libpng is vulnerable to a buffer overflow, caused by a
read underflow in png_check_keyword in pngwutil.c. By sending an overly
long argument, a remote attacker could overflow a buffer and execute
arbitrary code on the system or cause the application to crash.
- CVE-2016-0402: An unspecified vulnerability related to the Networking
component has no confidentiality impact, partial integrity impact, and
no availability impact
- CVE-2016-0448: An unspecified vulnerability related to the JMX component
could allow a remote attacker to obtain sensitive information
- CVE-2016-0466: An unspecified vulnerability related to the JAXP
component could allow a remote attacker to cause a denial of service
- CVE-2016-0483: An unspecified vulnerability related to the AWT component
has complete confidentiality impact, complete integrity impact, and
complete availability impact
- CVE-2016-0494: An unspecified vulnerability related to the 2D component
has complete confidentiality impact, complete integrity impact, and
complete availability impact

The following bugs were fixed:

- bsc#960402: resolve package conflicts in devel package
- bsc#960286: resolve package conflicts in the fonts subpackage


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Legacy Software 12:

zypper in -t patch SUSE-SLE-Module-Legacy-12-2016-244=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Module for Legacy Software 12 (s390x x86_64):

java-1_6_0-ibm-1.6.0_sr16.20-30.1
java-1_6_0-ibm-fonts-1.6.0_sr16.20-30.1
java-1_6_0-ibm-jdbc-1.6.0_sr16.20-30.1

- SUSE Linux Enterprise Module for Legacy Software 12 (x86_64):

java-1_6_0-ibm-plugin-1.6.0_sr16.20-30.1


References:

https://www.suse.com/security/cve/CVE-2015-5041.html
https://www.suse.com/security/cve/CVE-2015-7575.html
https://www.suse.com/security/cve/CVE-2015-7981.html
https://www.suse.com/security/cve/CVE-2015-8126.html
https://www.suse.com/security/cve/CVE-2015-8472.html
https://www.suse.com/security/cve/CVE-2015-8540.html
https://www.suse.com/security/cve/CVE-2016-0402.html
https://www.suse.com/security/cve/CVE-2016-0448.html
https://www.suse.com/security/cve/CVE-2016-0466.html
https://www.suse.com/security/cve/CVE-2016-0483.html
https://www.suse.com/security/cve/CVE-2016-0494.html
https://bugzilla.suse.com/960286
https://bugzilla.suse.com/960402
https://bugzilla.suse.com/963937

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung