Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Überschreiben von Dateien in FUSE
Aktuelle Meldungen Distributionen
Name: Überschreiben von Dateien in FUSE
ID: 201603-04
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Do, 10. März 2016, 06:50
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3202

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--TX3GQVIhIIWJ9p4qvjGTaSvpoFTRjpPTm
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201603-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: FUSE: incorrect filtering of environment variables leading to
privilege escalation
Date: March 09, 2016
Bugs: #550152
ID: 201603-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The fusermount binary in FUSE does not properly clear the environment
before invoking mount or umount as root that allows a local user to
overwrite arbitrary files.

Background
==========

FUSE provides an interface for filesystems implemented in userspace.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-fs/fuse < 2.9.4 >= 2.9.4

Description
===========

The fusermount binary calls setuid(geteuid()) to reset the RUID when it
invokes /bin/mount so that it can use privileged mount options that are
normally restricted if RUID != EUID. FUSE does not properly clear
environment variables before invoking mount or umount as root allowing
this to be passed to operations using elevated privileges such as
LIBMOUNT_MTAB that is used by the mount commands debugging feature.

Impact
======

The FUSE vulnerability allows a local, unprivileged user to overwrite
arbitrary files on the system.

Workaround
==========

There is no known work around at this time.

Resolution
==========

All FUSE users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-fs/fuse-2.9.4"

References
==========

[ 1 ] CVE-2015-3202
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3202

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201603-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2016 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--TX3GQVIhIIWJ9p4qvjGTaSvpoFTRjpPTm
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEcBAEBCgAGBQJW4Ga3AAoJECULev7WN52FpRkIALdlfEFtuV1w1jDcQ24niTNY
sH4TN1+Sy760edrPyc0kOE9DfzZnRhF2BeC6YiGbSJ7uEpPjIEwBp5azEzvkThqG
sr8jwuQUQuRyfrLDjVvp9rkxhsvTlKDqcbQK6PcxE2NViUeh3CuKodGSDmGdIeDb
r5jKz55op6LPgp+9Y/7Mbv2SHMnZZzDF6sokXFpIRXP2ElxFe8ZtRZzCZWzJ0D4S
/7/SBGXpftgWSyyA1CX6CVUmwybFszRQJx1YII24hpiLV8GIroFkdLL/n1gs/92z
1KTbBY2S2zfEii+Qz4cWKUL7M78380fM9WYh9+3qqa9djyCddgRbmQfrRJyHd/g=
=vPkT
-----END PGP SIGNATURE-----

--TX3GQVIhIIWJ9p4qvjGTaSvpoFTRjpPTm--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung