Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in OpenSSL
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in OpenSSL
ID: openSUSE-SU-2016:1240-1
Distribution: SUSE
Plattformen: SUSE openSUSE 13.1
Datum: Fr, 6. Mai 2016, 07:58
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2106
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2108
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2109
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2107
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2105

Originalnachricht

   openSUSE Security Update: Security update for openssl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1240-1
Rating: important
References: #976942 #976943 #977614 #977615 #977616 #977617

Cross-References: CVE-2016-2105 CVE-2016-2106 CVE-2016-2107
CVE-2016-2108 CVE-2016-2109
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that solves 5 vulnerabilities and has one errata
is now available.

Description:

This update for openssl fixes the following issues:

- CVE-2016-2105: EVP_EncodeUpdate overflow (bsc#977614)
- CVE-2016-2106: EVP_EncryptUpdate overflow (bsc#977615)
- CVE-2016-2107: Padding oracle in AES-NI CBC MAC check (bsc#977616)
- CVE-2016-2108: Memory corruption in the ASN.1 encoder (bsc#977617)
- CVE-2016-2109: ASN.1 BIO excessive memory allocation (bsc#976942)
- bsc#976943: Buffer overrun in ASN1_parse


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch 2016-562=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

libopenssl-devel-1.0.1k-11.87.1
libopenssl1_0_0-1.0.1k-11.87.1
libopenssl1_0_0-debuginfo-1.0.1k-11.87.1
openssl-1.0.1k-11.87.1
openssl-debuginfo-1.0.1k-11.87.1
openssl-debugsource-1.0.1k-11.87.1

- openSUSE 13.1 (x86_64):

libopenssl-devel-32bit-1.0.1k-11.87.1
libopenssl1_0_0-32bit-1.0.1k-11.87.1
libopenssl1_0_0-debuginfo-32bit-1.0.1k-11.87.1

- openSUSE 13.1 (noarch):

openssl-doc-1.0.1k-11.87.1


References:

https://www.suse.com/security/cve/CVE-2016-2105.html
https://www.suse.com/security/cve/CVE-2016-2106.html
https://www.suse.com/security/cve/CVE-2016-2107.html
https://www.suse.com/security/cve/CVE-2016-2108.html
https://www.suse.com/security/cve/CVE-2016-2109.html
https://bugzilla.suse.com/976942
https://bugzilla.suse.com/976943
https://bugzilla.suse.com/977614
https://bugzilla.suse.com/977615
https://bugzilla.suse.com/977616
https://bugzilla.suse.com/977617

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung