Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in OpenSSL
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in OpenSSL
ID: openSUSE-SU-2016:1242-1
Distribution: SUSE
Plattformen: SUSE openSUSE 13.2, SUSE openSUSE Leap 42.1
Datum: Fr, 6. Mai 2016, 08:05
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2108
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2105
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2109
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2106
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0702

Originalnachricht

   openSUSE Security Update: Security update for libopenssl0_9_8
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1242-1
Rating: important
References: #968050 #976942 #976943 #977614 #977615 #977617

Cross-References: CVE-2016-0702 CVE-2016-2105 CVE-2016-2106
CVE-2016-2108 CVE-2016-2109
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that solves 5 vulnerabilities and has one errata
is now available.

Description:

This update for libopenssl0_9_8 fixes the following issues:

- CVE-2016-2105: EVP_EncodeUpdate overflow (bsc#977614)
- CVE-2016-2106: EVP_EncryptUpdate overflow (bsc#977615)
- CVE-2016-2108: Memory corruption in the ASN.1 encoder (bsc#977617)
- CVE-2016-2109: ASN.1 BIO excessive memory allocation (bsc#976942)
- CVE-2016-0702: Side channel attack on modular exponentiation
"CacheBleed" (bsc#968050)
- bsc#976943: Buffer overrun in ASN1_parse


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-565=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-565=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libopenssl0_9_8-0.9.8zh-17.1
libopenssl0_9_8-debuginfo-0.9.8zh-17.1
libopenssl0_9_8-debugsource-0.9.8zh-17.1

- openSUSE Leap 42.1 (x86_64):

libopenssl0_9_8-32bit-0.9.8zh-17.1
libopenssl0_9_8-debuginfo-32bit-0.9.8zh-17.1

- openSUSE 13.2 (i586 x86_64):

libopenssl0_9_8-0.9.8zh-9.6.1
libopenssl0_9_8-debuginfo-0.9.8zh-9.6.1
libopenssl0_9_8-debugsource-0.9.8zh-9.6.1

- openSUSE 13.2 (x86_64):

libopenssl0_9_8-32bit-0.9.8zh-9.6.1
libopenssl0_9_8-debuginfo-32bit-0.9.8zh-9.6.1


References:

https://www.suse.com/security/cve/CVE-2016-0702.html
https://www.suse.com/security/cve/CVE-2016-2105.html
https://www.suse.com/security/cve/CVE-2016-2106.html
https://www.suse.com/security/cve/CVE-2016-2108.html
https://www.suse.com/security/cve/CVE-2016-2109.html
https://bugzilla.suse.com/968050
https://bugzilla.suse.com/976942
https://bugzilla.suse.com/976943
https://bugzilla.suse.com/977614
https://bugzilla.suse.com/977615
https://bugzilla.suse.com/977617

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung