Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in OpenSSL
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in OpenSSL
ID: SUSE-SU-2016:1360-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 10 SP4 LTSS
Datum: Do, 19. Mai 2016, 23:07
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2105
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0702
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2109
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2106
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2108

Originalnachricht

   SUSE Security Update: Security update for openssl
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:1360-1
Rating: important
References: #968050 #973223 #976942 #976943 #977614 #977615
#977617
Cross-References: CVE-2016-0702 CVE-2016-2105 CVE-2016-2106
CVE-2016-2108 CVE-2016-2109
Affected Products:
SUSE Linux Enterprise Server 10 SP4 LTSS
______________________________________________________________________________

An update that solves 5 vulnerabilities and has two fixes
is now available.

Description:


This update for OpenSSL fixes the following security issues:

* CVE-2016-2105: EVP_EncodeUpdate overflow (bsc#977614)
* CVE-2016-2106: EVP_EncryptUpdate overflow (bsc#977615)
* CVE-2016-2108: Memory corruption in the ASN.1 encoder (bsc#977617)
* CVE-2016-2109: ASN.1 BIO excessive memory allocation (bsc#976942)
* CVE-2016-0702: Side channel attack on modular exponentiation
"CacheBleed" (bsc#968050)

Additionally, the following non-security issues have been fixed:

* Fix buffer overrun in ASN1_parse. (bsc#976943)
* Allow weak DH groups. (bsc#973223)

Security Issues:

* CVE-2016-2105
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2105>
* CVE-2016-2106
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2106>
* CVE-2016-2108
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2108>
* CVE-2016-2109
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2109>
* CVE-2016-0702
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-0702>



Package List:

- SUSE Linux Enterprise Server 10 SP4 LTSS (i586 s390x x86_64):

openssl-0.9.8a-18.96.1
openssl-devel-0.9.8a-18.96.1
openssl-doc-0.9.8a-18.96.1

- SUSE Linux Enterprise Server 10 SP4 LTSS (s390x x86_64):

openssl-32bit-0.9.8a-18.96.1
openssl-devel-32bit-0.9.8a-18.96.1


References:

https://www.suse.com/security/cve/CVE-2016-0702.html
https://www.suse.com/security/cve/CVE-2016-2105.html
https://www.suse.com/security/cve/CVE-2016-2106.html
https://www.suse.com/security/cve/CVE-2016-2108.html
https://www.suse.com/security/cve/CVE-2016-2109.html
https://bugzilla.suse.com/968050
https://bugzilla.suse.com/973223
https://bugzilla.suse.com/976942
https://bugzilla.suse.com/976943
https://bugzilla.suse.com/977614
https://bugzilla.suse.com/977615
https://bugzilla.suse.com/977617
https://download.suse.com/patch/finder/?keywords=bfdaa5a35088a70db557cea0e263ef89

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung