Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Fehlerhafte Zugriffsrechte in usbmuxd und libimobiledevice
Aktuelle Meldungen Distributionen
Name: Fehlerhafte Zugriffsrechte in usbmuxd und libimobiledevice
ID: SUSE-SU-2016:1639-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Software Development Kit 12, SUSE Linux Enterprise Desktop 12, SUSE Linux Enterprise Workstation Extension 12, SUSE Linux Enterprise Workstation Extension 12-SP1, SUSE Linux Enterprise Desktop 12-SP1, SUSE Linux Enterprise Software Development Kit 12-SP1, SUSE Linux Enterprise Server 12-SP1
Datum: Di, 21. Juni 2016, 18:39
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-5104

Originalnachricht

   SUSE Security Update: Security update for libimobiledevice, usbmuxd
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:1639-1
Rating: important
References: #982014
Cross-References: CVE-2016-5104
Affected Products:
SUSE Linux Enterprise Workstation Extension 12-SP1
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Software Development Kit 12-SP1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Server 12-SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Desktop 12-SP1
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

libimobiledevice, usbmuxd were updated to fix one security issue.

This security issue was fixed:
- CVE-2016-5104: Sockets listening on INADDR_ANY instead of only locally
(982014).


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 12-SP1:

zypper in -t patch SUSE-SLE-WE-12-SP1-2016-973=1

- SUSE Linux Enterprise Workstation Extension 12:

zypper in -t patch SUSE-SLE-WE-12-2016-973=1

- SUSE Linux Enterprise Software Development Kit 12-SP1:

zypper in -t patch SUSE-SLE-SDK-12-SP1-2016-973=1

- SUSE Linux Enterprise Software Development Kit 12:

zypper in -t patch SUSE-SLE-SDK-12-2016-973=1

- SUSE Linux Enterprise Server 12-SP1:

zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-973=1

- SUSE Linux Enterprise Server 12:

zypper in -t patch SUSE-SLE-SERVER-12-2016-973=1

- SUSE Linux Enterprise Desktop 12-SP1:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-973=1

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2016-973=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Workstation Extension 12-SP1 (x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-tools-1.1.5-6.1
libimobiledevice-tools-debuginfo-1.1.5-6.1

- SUSE Linux Enterprise Workstation Extension 12 (x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-tools-1.1.5-6.1
libimobiledevice-tools-debuginfo-1.1.5-6.1

- SUSE Linux Enterprise Software Development Kit 12-SP1 (ppc64le s390x
x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-devel-1.1.5-6.1
libusbmuxd-devel-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1

- SUSE Linux Enterprise Software Development Kit 12 (ppc64le s390x x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-devel-1.1.5-6.1
libusbmuxd-devel-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1

- SUSE Linux Enterprise Server 12-SP1 (ppc64le s390x x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice4-1.1.5-6.1
libimobiledevice4-debuginfo-1.1.5-6.1
libusbmuxd2-1.0.8-12.1
libusbmuxd2-debuginfo-1.0.8-12.1
usbmuxd-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1

- SUSE Linux Enterprise Server 12 (ppc64le s390x x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice4-1.1.5-6.1
libimobiledevice4-debuginfo-1.1.5-6.1
libusbmuxd2-1.0.8-12.1
libusbmuxd2-debuginfo-1.0.8-12.1
usbmuxd-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1

- SUSE Linux Enterprise Desktop 12-SP1 (x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-tools-1.1.5-6.1
libimobiledevice-tools-debuginfo-1.1.5-6.1
libimobiledevice4-1.1.5-6.1
libimobiledevice4-debuginfo-1.1.5-6.1
libusbmuxd2-1.0.8-12.1
libusbmuxd2-debuginfo-1.0.8-12.1
usbmuxd-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1

- SUSE Linux Enterprise Desktop 12 (x86_64):

libimobiledevice-debugsource-1.1.5-6.1
libimobiledevice-tools-1.1.5-6.1
libimobiledevice-tools-debuginfo-1.1.5-6.1
libimobiledevice4-1.1.5-6.1
libimobiledevice4-debuginfo-1.1.5-6.1
libusbmuxd2-1.0.8-12.1
libusbmuxd2-debuginfo-1.0.8-12.1
usbmuxd-1.0.8-12.1
usbmuxd-debuginfo-1.0.8-12.1
usbmuxd-debugsource-1.0.8-12.1


References:

https://www.suse.com/security/cve/CVE-2016-5104.html
https://bugzilla.suse.com/982014

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung