Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in ImageMagick
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in ImageMagick
ID: openSUSE-SU-2016:1653-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.1
Datum: Mi, 22. Juni 2016, 18:42
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-5118

Originalnachricht

   openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1653-1
Rating: important
References: #867943 #982178
Cross-References: CVE-2016-5118
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for ImageMagick fixes the following issues:

This security issue was fixed:
- CVE-2016-5118: Prevent code execution via popen() (bsc#982178)

This non-security issue was fixed:
- Fix encoding of /Title in generated PDFs. (bsc#867943) This update was
imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-757=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

ImageMagick-6.8.8.1-12.1
ImageMagick-debuginfo-6.8.8.1-12.1
ImageMagick-debugsource-6.8.8.1-12.1
ImageMagick-devel-6.8.8.1-12.1
ImageMagick-extra-6.8.8.1-12.1
ImageMagick-extra-debuginfo-6.8.8.1-12.1
libMagick++-6_Q16-3-6.8.8.1-12.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-12.1
libMagick++-devel-6.8.8.1-12.1
libMagickCore-6_Q16-1-6.8.8.1-12.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-12.1
libMagickWand-6_Q16-1-6.8.8.1-12.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-12.1
perl-PerlMagick-6.8.8.1-12.1
perl-PerlMagick-debuginfo-6.8.8.1-12.1

- openSUSE Leap 42.1 (noarch):

ImageMagick-doc-6.8.8.1-12.1

- openSUSE Leap 42.1 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-12.1
libMagick++-6_Q16-3-32bit-6.8.8.1-12.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-12.1
libMagick++-devel-32bit-6.8.8.1-12.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-12.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-12.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-12.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-12.1


References:

https://www.suse.com/security/cve/CVE-2016-5118.html
https://bugzilla.suse.com/867943
https://bugzilla.suse.com/982178

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung