Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in OCaml
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in OCaml
ID: RHSA-2016:1296-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: Do, 23. Juni 2016, 23:34
Referenzen: https://access.redhat.com/security/cve/CVE-2015-8869

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: ocaml security update
Advisory ID: RHSA-2016:1296-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2016:1296
Issue date: 2016-06-23
CVE Names: CVE-2015-8869
=====================================================================

1. Summary:

An update for ocaml is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security
impact of Moderate. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available for each
vulnerability from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client Optional (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode Optional (v. 7) - x86_64
Red Hat Enterprise Linux Server Optional (v. 7) - ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Workstation Optional (v. 7) - x86_64

3. Description:

OCaml is a high-level, strongly-typed, functional, and object-oriented
programming language from the ML family of languages. The ocaml packages
contain two batch compilers (a fast bytecode compiler and an optimizing
native-code compiler), an interactive top level system, parsing tools
(Lex, Yacc, Camlp4), a replay debugger, a documentation generator, and
a comprehensive library.

Security Fix(es):

* OCaml versions 4.02.3 and earlier have a runtime bug that, on 64-bit
platforms, causes size arguments to internal memmove calls to be
sign-extended from 32- to 64-bits before being passed to the memmove
function. This leads to arguments between 2GiB and 4GiB being interpreted
as larger than they are (specifically, a bit below 2^64), causing a
buffer overflow. Further, arguments between 4GiB and 6GiB are interpreted
as 4GiB smaller than they should be, causing a possible information
leak. (CVE-2015-8869)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1332090 - CVE-2015-8869 ocaml: sizes arguments are sign-extended from 32 to 64
bits

6. Package List:

Red Hat Enterprise Linux Client Optional (v. 7):

Source:
ocaml-4.01.0-22.7.el7_2.src.rpm

x86_64:
ocaml-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-docs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-emacs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-runtime-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-source-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-x11-4.01.0-22.7.el7_2.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional (v. 7):

Source:
ocaml-4.01.0-22.7.el7_2.src.rpm

x86_64:
ocaml-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-docs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-emacs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-runtime-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-source-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-x11-4.01.0-22.7.el7_2.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 7):

Source:
ocaml-4.01.0-22.7.el7_2.src.rpm

ppc64:
ocaml-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-docs-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-emacs-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-labltk-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-runtime-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-source-4.01.0-22.7.el7_2.ppc64.rpm
ocaml-x11-4.01.0-22.7.el7_2.ppc64.rpm

ppc64le:
ocaml-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-docs-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-emacs-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-labltk-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-runtime-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-source-4.01.0-22.7.el7_2.ppc64le.rpm
ocaml-x11-4.01.0-22.7.el7_2.ppc64le.rpm

s390x:
ocaml-4.01.0-22.7.el7_2.s390x.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.s390x.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.s390x.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.s390x.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.s390x.rpm
ocaml-docs-4.01.0-22.7.el7_2.s390x.rpm
ocaml-emacs-4.01.0-22.7.el7_2.s390x.rpm
ocaml-labltk-4.01.0-22.7.el7_2.s390x.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.s390x.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.s390x.rpm
ocaml-runtime-4.01.0-22.7.el7_2.s390x.rpm
ocaml-source-4.01.0-22.7.el7_2.s390x.rpm
ocaml-x11-4.01.0-22.7.el7_2.s390x.rpm

x86_64:
ocaml-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-docs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-emacs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-runtime-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-source-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-x11-4.01.0-22.7.el7_2.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 7):

Source:
ocaml-4.01.0-22.7.el7_2.src.rpm

x86_64:
ocaml-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-camlp4-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-compiler-libs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-debuginfo-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-docs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-emacs-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-labltk-devel-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-ocamldoc-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-runtime-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-source-4.01.0-22.7.el7_2.x86_64.rpm
ocaml-x11-4.01.0-22.7.el7_2.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2015-8869
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2016 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFXbEFFXlSAg2UNWIIRAs92AKChir6K9yzmb4pqiONlCyjpFTvqcACePv55
MenhYSW4Y0bnpnjmo3U5Xws=
=/nKN
-----END PGP SIGNATURE-----


--
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung