Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Zwei Probleme in gstreamer-plugins-bad
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in gstreamer-plugins-bad
ID: openSUSE-SU-2016:3158-1
Distribution: SUSE
Plattformen: SUSE openSUSE 13.2, SUSE openSUSE Leap 42.1
Datum: Mi, 14. Dezember 2016, 18:27
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9446
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9445

Originalnachricht

   openSUSE Security Update: Security update for gstreamer-plugins-bad
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:3158-1
Rating: important
References: #1010829
Cross-References: CVE-2016-9445 CVE-2016-9446
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for gstreamer-plugins-bad fixes the following issues:

- Maliciously crafted VMnc (VMware video) streams (typically contained in
.avi files) could cause code execution during decoding or information
leaks due to an unitialized buffer (CVE-2016-9445, CVE-2016-9446,
boo#1010829).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1483=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-1483=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

gstreamer-plugins-bad-1.4.5-8.1
gstreamer-plugins-bad-debuginfo-1.4.5-8.1
gstreamer-plugins-bad-debugsource-1.4.5-8.1
gstreamer-plugins-bad-devel-1.4.5-8.1
gstreamer-plugins-bad-doc-1.4.5-8.1
libgstbadbase-1_0-0-1.4.5-8.1
libgstbadbase-1_0-0-debuginfo-1.4.5-8.1
libgstbadvideo-1_0-0-1.4.5-8.1
libgstbadvideo-1_0-0-debuginfo-1.4.5-8.1
libgstbasecamerabinsrc-1_0-0-1.4.5-8.1
libgstbasecamerabinsrc-1_0-0-debuginfo-1.4.5-8.1
libgstcodecparsers-1_0-0-1.4.5-8.1
libgstcodecparsers-1_0-0-debuginfo-1.4.5-8.1
libgstgl-1_0-0-1.4.5-8.1
libgstgl-1_0-0-debuginfo-1.4.5-8.1
libgstinsertbin-1_0-0-1.4.5-8.1
libgstinsertbin-1_0-0-debuginfo-1.4.5-8.1
libgstmpegts-1_0-0-1.4.5-8.1
libgstmpegts-1_0-0-debuginfo-1.4.5-8.1
libgstphotography-1_0-0-1.4.5-8.1
libgstphotography-1_0-0-debuginfo-1.4.5-8.1
libgsturidownloader-1_0-0-1.4.5-8.1
libgsturidownloader-1_0-0-debuginfo-1.4.5-8.1
libgstwayland-1_0-0-1.4.5-8.1
libgstwayland-1_0-0-debuginfo-1.4.5-8.1

- openSUSE Leap 42.1 (x86_64):

gstreamer-plugins-bad-32bit-1.4.5-8.1
gstreamer-plugins-bad-debuginfo-32bit-1.4.5-8.1
libgstbadbase-1_0-0-32bit-1.4.5-8.1
libgstbadbase-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstbadvideo-1_0-0-32bit-1.4.5-8.1
libgstbadvideo-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstbasecamerabinsrc-1_0-0-32bit-1.4.5-8.1
libgstbasecamerabinsrc-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstcodecparsers-1_0-0-32bit-1.4.5-8.1
libgstcodecparsers-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstgl-1_0-0-32bit-1.4.5-8.1
libgstgl-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstinsertbin-1_0-0-32bit-1.4.5-8.1
libgstinsertbin-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstmpegts-1_0-0-32bit-1.4.5-8.1
libgstmpegts-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstphotography-1_0-0-32bit-1.4.5-8.1
libgstphotography-1_0-0-debuginfo-32bit-1.4.5-8.1
libgsturidownloader-1_0-0-32bit-1.4.5-8.1
libgsturidownloader-1_0-0-debuginfo-32bit-1.4.5-8.1
libgstwayland-1_0-0-32bit-1.4.5-8.1
libgstwayland-1_0-0-debuginfo-32bit-1.4.5-8.1

- openSUSE Leap 42.1 (noarch):

gstreamer-plugins-bad-lang-1.4.5-8.1

- openSUSE 13.2 (i586 x86_64):

gstreamer-plugins-bad-1.4.3-3.1
gstreamer-plugins-bad-debuginfo-1.4.3-3.1
gstreamer-plugins-bad-debugsource-1.4.3-3.1
gstreamer-plugins-bad-devel-1.4.3-3.1
gstreamer-plugins-bad-doc-1.4.3-3.1
libgstbadbase-1_0-0-1.4.3-3.1
libgstbadbase-1_0-0-debuginfo-1.4.3-3.1
libgstbadvideo-1_0-0-1.4.3-3.1
libgstbadvideo-1_0-0-debuginfo-1.4.3-3.1
libgstbasecamerabinsrc-1_0-0-1.4.3-3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-1.4.3-3.1
libgstcodecparsers-1_0-0-1.4.3-3.1
libgstcodecparsers-1_0-0-debuginfo-1.4.3-3.1
libgstgl-1_0-0-1.4.3-3.1
libgstgl-1_0-0-debuginfo-1.4.3-3.1
libgstinsertbin-1_0-0-1.4.3-3.1
libgstinsertbin-1_0-0-debuginfo-1.4.3-3.1
libgstmpegts-1_0-0-1.4.3-3.1
libgstmpegts-1_0-0-debuginfo-1.4.3-3.1
libgstphotography-1_0-0-1.4.3-3.1
libgstphotography-1_0-0-debuginfo-1.4.3-3.1
libgsturidownloader-1_0-0-1.4.3-3.1
libgsturidownloader-1_0-0-debuginfo-1.4.3-3.1

- openSUSE 13.2 (x86_64):

gstreamer-plugins-bad-32bit-1.4.3-3.1
gstreamer-plugins-bad-debuginfo-32bit-1.4.3-3.1
libgstbadbase-1_0-0-32bit-1.4.3-3.1
libgstbadbase-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstbadvideo-1_0-0-32bit-1.4.3-3.1
libgstbadvideo-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstbasecamerabinsrc-1_0-0-32bit-1.4.3-3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstcodecparsers-1_0-0-32bit-1.4.3-3.1
libgstcodecparsers-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstgl-1_0-0-32bit-1.4.3-3.1
libgstgl-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstinsertbin-1_0-0-32bit-1.4.3-3.1
libgstinsertbin-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstmpegts-1_0-0-32bit-1.4.3-3.1
libgstmpegts-1_0-0-debuginfo-32bit-1.4.3-3.1
libgstphotography-1_0-0-32bit-1.4.3-3.1
libgstphotography-1_0-0-debuginfo-32bit-1.4.3-3.1
libgsturidownloader-1_0-0-32bit-1.4.3-3.1
libgsturidownloader-1_0-0-debuginfo-32bit-1.4.3-3.1

- openSUSE 13.2 (noarch):

gstreamer-plugins-bad-lang-1.4.3-3.1


References:

https://www.suse.com/security/cve/CVE-2016-9445.html
https://www.suse.com/security/cve/CVE-2016-9446.html
https://bugzilla.suse.com/1010829

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung