Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Pufferüberlauf in ppp
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in ppp
ID: 201701-50
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mo, 23. Januar 2017, 07:52
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3310

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--GoGeJslim05kKPj2qeCEU8VlW04FuG2lo
Content-Type: multipart/mixed;
boundary="aWI0FGjCTLUtXLuhAJaBFAQxRowETKe78"
From: Aaron Bauman <bman@gentoo.org>
To: gentoo-announce@lists.gentoo.org
Message-ID: <b99cc2a4-7ac2-d3cf-4503-12bf1268e364@gentoo.org>
Subject: [ GLSA 201701-50 ] PPP: Buffer overflow

--aWI0FGjCTLUtXLuhAJaBFAQxRowETKe78
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201701-50
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PPP: Buffer overflow
Date: January 23, 2017
Bugs: #546554
ID: 201701-50

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in PPP might allow remote attackers to cause a Denial
of Service condition.

Background
==========

PPP is a Unix implementation of the Point-to-Point Protocol

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-dialup/ppp < 2.4.7-r3 >= 2.4.7-r3

Description
===========

A buffer overflow was discovered in the rc_mksid function in
plugins/radius/util.c in PPP when the PID for pppd is greater than
65535.

Impact
======

A remote attacker could cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PPP users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dialup/ppp-2.4.7-r3"

References
==========

[ 1 ] CVE-2015-3310
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3310

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201701-50

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--aWI0FGjCTLUtXLuhAJaBFAQxRowETKe78--

--GoGeJslim05kKPj2qeCEU8VlW04FuG2lo
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQJ8BAEBCgBmBQJYhXVsXxSAAAAAAC4AKGlzc3Vlci1mcHJAbm90YXRpb25zLm9w
ZW5wZ3AuZmlmdGhob3JzZW1hbi5uZXQ1OTcyRDI4NDhFOEE0NDYwRTdERTY4QUM5
RjI4QkQ4QkQxRTM5NUZGAAoJEJ8ovYvR45X/ObYP/iIMsLPjZbn2Bc0vAEb5HUKl
uzn9Peals0b6ZYBBO3Pij6N9TtnXG7fS40iH7jGW9WGhiPbQKVyZlHeWM1L9U1X9
Yp7HWBYUwruk0QahVf3kJaRwZef/ERHCb1q537FQngYkTwIJ/tN6xwfbJD7Bw7EX
vCsIUhVN7Sep6jOBf2ZlRgI6nUX/pGTxWsKMu8iOoJLBiHi3ekYVBzxXUCpiMEQF
jSx0yQcTUiyqdtxRBmSFbGe+JYC5XT8TIdHQDhp/UJjt+aXjYlSpHA4caS7UYZzf
ZO9kpRBOVjlYVtXfDLolftuiMEPma0IVH9ua7p6DB8Q9cwKiZ8woVs7ye7nQvXvi
Mqtj+wwNjuD610aBwmOiAwNf1cmw3EkJX3i9ifqgtZpK9YAt7gWNqylKhK1wIJw9
i/WXvFJxGjFpdEl0iWlq2kRBz4/ll80w3h3+tbLnvDEe3mDezwB+Rf183HJpmf8+
BNwQ/p+nrk9tmFuhhqhkBeVqWeMKLE8XyQWuRClW15g52S6YghB3IpEv+2BhCYvd
5zTEWIMnqqG2s1ZlMIwB9NypAdArRNiRQs3yF0HMkRBqEv6NnCYXpiRXM2T8ZDut
T24/4HWxgJrqApBbKO030tIs0M9b3PEVc1uX4OA1QyG0b0N3nlY+2aPmAQpWTBxK
jS2qSNG098w0H7ePQnk4
=WxFS
-----END PGP SIGNATURE-----

--GoGeJslim05kKPj2qeCEU8VlW04FuG2lo--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung