Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in GNU Transport Layer Security Library
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in GNU Transport Layer Security Library
ID: 201702-04
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 11. Februar 2017, 10:05
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5335
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5337
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5336
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5334

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--5SF4cHKJwUmOkWHvitCNHOgIBgW8wRxwQ
Content-Type: multipart/mixed;
boundary="SjUxonl6xABCSXrK4nUhnjXAVmCl1dGkC";
protected-headers="v1"
From: Thomas Deutschmann <whissi@gentoo.org>
To: gentoo-announce@lists.gentoo.org
Message-ID: <f3ed31bf-c380-9453-c761-c0dca0652e39@gentoo.org>
Subject: [ GLSA 201702-04 ] GnuTLS: Multiple vulnerabilities

--SjUxonl6xABCSXrK4nUhnjXAVmCl1dGkC
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201702-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GnuTLS: Multiple vulnerabilities
Date: February 10, 2017
Bugs: #605238
ID: 201702-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GnuTLS, the worst of which
may allow execution of arbitrary code.

Background
==========

GnuTLS is an Open Source implementation of the TLS and SSL protocols.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/gnutls < 3.3.26 >= 3.3.26

Description
===========

Multiple heap and stack overflows and double free vulnerabilities have
been discovered in GnuTLS by the OSS-Fuzz project. Please review the
CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user or automated system to process a
specially crafted certificate using an application linked against
GnuTLS. This could possibly result in the execution of arbitrary code
with the privileges of the process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GnuTLS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-3.3.26"

References
==========

[ 1 ] CVE-2017-5334
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5334
[ 2 ] CVE-2017-5335
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5335
[ 3 ] CVE-2017-5336
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5336
[ 4 ] CVE-2017-5337
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-5337

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201702-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--SjUxonl6xABCSXrK4nUhnjXAVmCl1dGkC--

--5SF4cHKJwUmOkWHvitCNHOgIBgW8wRxwQ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0

iQJ8BAEBCgBmBQJYnkemXxSAAAAAAC4AKGlzc3Vlci1mcHJAbm90YXRpb25zLm9w
ZW5wZ3AuZmlmdGhob3JzZW1hbi5uZXQzM0M1ODQ4MkM0MDIyOTJEMkUzQzVDMDY5
NzA5RjkwQzNDOTZGRkM4AAoJEJcJ+Qw8lv/ImAYP/0t38W0PhZlZGEHv2gqKs71b
hyVZfWt1qq37hrqWekEHI8BAwfrukjhphVONyvr2l6ILG3tAaYHEimGQCIaEDsZJ
BARPIfP7stuFLTpopZqUe+ZpC72sLSURUIPLs9I0y9C4/jSC/W/WEY60MkFE3t/J
3WrJPa687ClTDxpEd7sEKEifGCdEQTK4cHowKCHUW3GmJgqynA+Sp6mgC51ew40O
IDr9V0Ws3OBfMQbkVZPNbIhbL5rj3E+IWIG56DGUvtAis+VszCNJfK4pq6lTNYW4
BgvkgfDJzhro80t3T9EYocH0/Ahr8d6ix7vJ9+MfkkRHDq/JW8+lcSyTn0o7CcJ2
gUCYdqYfmIHVfda4nu813jCpoLTqMZcMD2KWTOP20HsrVmGyXQNZzKccJLWhl0J7
2r3WzSQS5BAG9kJOVlQeqFf3IOSwZ6r/QYZV5vcJvsOmzOrFmonQ30cQRynEG1z/
ipJg8s8u9Dl7q6S2/8negNoUct95sfTtPjG9nBQtbYfxxuo8mM8+KbysY/v65DkZ
1YBXTeDp8uB/ZxrwqIWjfCsXfUIvmqCW6YWJm+J8p+VjRlpYE+7PTQHQb+ZnUYgC
JS+y1TjRP5wP6QSu1TvGkOWkuOaYaF+twnM/tGz4Uh2qx/e4uwfOg8RjiMkiTPcu
LGNZFqKznBsUjGhMewmZ
=9ojz
-----END PGP SIGNATURE-----

--5SF4cHKJwUmOkWHvitCNHOgIBgW8wRxwQ--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung