Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mangelnde Rechteprüfung in AppArmor
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in AppArmor
ID: openSUSE-SU-2017:0969-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.1, SUSE openSUSE Leap 42.2
Datum: Mo, 10. April 2017, 19:04
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6507

Originalnachricht

   openSUSE Security Update: Security update for apparmor
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0969-1
Rating: important
References: #1016259 #1017260 #1029696
Cross-References: CVE-2017-6507
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:


This update for apparmor fixes the following issues:

These security issues were fixed:

- CVE-2017-6507: Preserve unknown profiles when reloading apparmor.service
(lp#1668892, boo#1029696)
- boo#1017260: Migration to apparmor.service accidently disable AppArmor.
Note: This will re-enable AppArmor if it was disabled by the last
update. You'll need to "rcapparmor reload" to actually load
the
profiles, and then check aa-status for programs that need to be
restarted to apply the profiles.

These non-security issues were fixed:

- Fixed crash in aa-logprof on specific change_hat events
- boo#1016259: Added var.mount dependeny to apparmor.service

The aa-remove-unknown utility was added to unload unknown profiles
(lp#1668892)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-452=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-452=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

apache2-mod_apparmor-2.10.2-12.3.1
apache2-mod_apparmor-debuginfo-2.10.2-12.3.1
apparmor-debugsource-2.10.2-12.3.1
apparmor-parser-2.10.2-12.3.1
apparmor-parser-debuginfo-2.10.2-12.3.1
libapparmor-devel-2.10.2-12.3.1
libapparmor1-2.10.2-12.3.1
libapparmor1-debuginfo-2.10.2-12.3.1
pam_apparmor-2.10.2-12.3.1
pam_apparmor-debuginfo-2.10.2-12.3.1
perl-apparmor-2.10.2-12.3.1
perl-apparmor-debuginfo-2.10.2-12.3.1
python3-apparmor-2.10.2-12.3.1
python3-apparmor-debuginfo-2.10.2-12.3.1
ruby-apparmor-2.10.2-12.3.1
ruby-apparmor-debuginfo-2.10.2-12.3.1

- openSUSE Leap 42.2 (x86_64):

libapparmor1-32bit-2.10.2-12.3.1
libapparmor1-debuginfo-32bit-2.10.2-12.3.1
pam_apparmor-32bit-2.10.2-12.3.1
pam_apparmor-debuginfo-32bit-2.10.2-12.3.1

- openSUSE Leap 42.2 (noarch):

apparmor-abstractions-2.10.2-12.3.1
apparmor-docs-2.10.2-12.3.1
apparmor-parser-lang-2.10.2-12.3.1
apparmor-profiles-2.10.2-12.3.1
apparmor-utils-2.10.2-12.3.1
apparmor-utils-lang-2.10.2-12.3.1

- openSUSE Leap 42.1 (i586 x86_64):

apache2-mod_apparmor-2.10.2-12.1
apache2-mod_apparmor-debuginfo-2.10.2-12.1
apparmor-debugsource-2.10.2-12.1
apparmor-parser-2.10.2-12.1
apparmor-parser-debuginfo-2.10.2-12.1
libapparmor-devel-2.10.2-12.1
libapparmor1-2.10.2-12.1
libapparmor1-debuginfo-2.10.2-12.1
pam_apparmor-2.10.2-12.1
pam_apparmor-debuginfo-2.10.2-12.1
perl-apparmor-2.10.2-12.1
perl-apparmor-debuginfo-2.10.2-12.1
python3-apparmor-2.10.2-12.1
python3-apparmor-debuginfo-2.10.2-12.1
ruby-apparmor-2.10.2-12.1
ruby-apparmor-debuginfo-2.10.2-12.1

- openSUSE Leap 42.1 (noarch):

apparmor-abstractions-2.10.2-12.1
apparmor-docs-2.10.2-12.1
apparmor-parser-lang-2.10.2-12.1
apparmor-profiles-2.10.2-12.1
apparmor-utils-2.10.2-12.1
apparmor-utils-lang-2.10.2-12.1

- openSUSE Leap 42.1 (x86_64):

libapparmor1-32bit-2.10.2-12.1
libapparmor1-debuginfo-32bit-2.10.2-12.1
pam_apparmor-32bit-2.10.2-12.1
pam_apparmor-debuginfo-32bit-2.10.2-12.1


References:

https://www.suse.com/security/cve/CVE-2017-6507.html
https://bugzilla.suse.com/1016259
https://bugzilla.suse.com/1017260
https://bugzilla.suse.com/1029696

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung