Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen von Code mit höheren Privilegien in sudo
Aktuelle Meldungen Distributionen
Name: Ausführen von Code mit höheren Privilegien in sudo
ID: SUSE-SU-2017:1450-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP2, SUSE Linux Enterprise Software Development Kit 12-SP2, SUSE Linux Enterprise Server 12-SP2, SUSE Linux Enterprise Server for Raspberry Pi 12-SP2, SUSE OpenStack Cloud Magnum Orchestration 7
Datum: Di, 30. Mai 2017, 22:30
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000367

Originalnachricht

   SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:1450-1
Rating: important
References: #1015351 #1024145 #1039361 #981124
Cross-References: CVE-2017-1000367
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP2
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
SUSE Linux Enterprise Server 12-SP2
SUSE Linux Enterprise Desktop 12-SP2
OpenStack Cloud Magnum Orchestration 7
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:


This update for sudo fixes the following issues:

CVE-2017-1000367:
- Due to incorrect assumptions in /proc/[pid]/stat parsing, a local
attacker can pretend that his tty is any file on the filesystem, thus
gaining arbitrary file write access on SELinux-enabled systems.
[bsc#1039361]
- Fix FQDN for hostname. [bsc#1024145]
- Filter netgroups, they aren't handled by SSSD. [bsc#1015351]
- Fix problems related to "krb5_ccname" option [bsc#981124]


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP2:

zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-889=1

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-889=1

- SUSE Linux Enterprise Server 12-SP2:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-889=1

- SUSE Linux Enterprise Desktop 12-SP2:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-889=1

- OpenStack Cloud Magnum Orchestration 7:

zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-889=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le
s390x x86_64):

sudo-debuginfo-1.8.10p3-10.5.1
sudo-debugsource-1.8.10p3-10.5.1
sudo-devel-1.8.10p3-10.5.1

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):

sudo-1.8.10p3-10.5.1
sudo-debuginfo-1.8.10p3-10.5.1
sudo-debugsource-1.8.10p3-10.5.1

- SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le x86_64):

sudo-1.8.10p3-10.5.1
sudo-debuginfo-1.8.10p3-10.5.1
sudo-debugsource-1.8.10p3-10.5.1

- SUSE Linux Enterprise Desktop 12-SP2 (x86_64):

sudo-1.8.10p3-10.5.1
sudo-debuginfo-1.8.10p3-10.5.1
sudo-debugsource-1.8.10p3-10.5.1

- OpenStack Cloud Magnum Orchestration 7 (x86_64):

sudo-1.8.10p3-10.5.1
sudo-debuginfo-1.8.10p3-10.5.1
sudo-debugsource-1.8.10p3-10.5.1


References:

https://www.suse.com/security/cve/CVE-2017-1000367.html
https://bugzilla.suse.com/1015351
https://bugzilla.suse.com/1024145
https://bugzilla.suse.com/1039361
https://bugzilla.suse.com/981124

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung