Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in libffi
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in libffi
ID: DSA-3889-1
Distribution: Debian
Plattformen: Debian sid, Debian jessie, Debian stretch, Debian buster
Datum: Mo, 19. Juni 2017, 22:18
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000376

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-3889-1 security@debian.org
https://www.debian.org/security/ Yves-Alexis Perez
June 19, 2017 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : libffi
CVE ID : CVE-2017-1000376
Debian Bug : 751907

libffi, a library used to call code written in one language from code written
in a different language, was enforcing an executable stack on the i386
architecture. While this might not be considered a vulnerability by itself,
this could be leveraged when exploiting other vulnerabilities, like for example
the "stack clash" class of vulnerabilities discovered by Qualys
Research Labs.
For the full details, please refer to their advisory published at:
https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt

For the oldstable distribution (jessie), this problem has been fixed
in version 3.1-2+deb8u1.

For the stable distribution (stretch), this problem has been fixed in
version 3.2.1-4.

For the testing distribution (buster), this problem has been fixed
in version 3.2.1-4.

For the unstable distribution (sid), this problem has been fixed in
version 3.2.1-4.

We recommend that you upgrade your libffi packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEl0WwInMjgf6efq/1bdtT8qZ1wKUFAllH+HUACgkQbdtT8qZ1
wKULnwf+OjvPYV8LaTEiFq/PkffgQEIM3AZ7C4Z5DZ/tNl7jb1DTT/BN/iuLMlsQ
4cbcbUOryZBgD2BcmVX+Qcc6pktcVmBenMpyORCX8329ZpCWCehT1yx7UhEVxtHn
qpsn9frNtNFVMpyP+7e1WiyVwjRTT0o33PyhkyXoGPytt8Q8y5glynDnF7LabEU5
IIG9Of9KVII5zEdGnZj6vwlZq0Yn0R9qXtLHy2HCoOms9051MylVZtKqUryqN6Au
JZ/kfTRiC73gDgq2X+NVFsX2tvkWwzlt84P2IL4llPigSI9SKRqZgpLgcahiDA4p
D5pfm+yPV5SFPfWF2fj5PHxxDY85oA==
=e1sg
-----END PGP SIGNATURE-----
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung