Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen von Code mit höheren Privilegien in GNU C library
Aktuelle Meldungen Distributionen
Name: Ausführen von Code mit höheren Privilegien in GNU C library
ID: openSUSE-SU-2017:1629-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.2
Datum: Mi, 21. Juni 2017, 06:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000366

Originalnachricht

   openSUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1629-1
Rating: important
References: #1039357 #1040043
Cross-References: CVE-2017-1000366
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for glibc fixes the following issues:

- CVE-2017-1000366: Fix a potential privilege escalation vulnerability
that allowed unprivileged system users to manipulate the stack of setuid
binaries to gain special privileges. [bsc#1039357]

- A bug in glibc that could result in deadlocks between malloc() and
fork() has been fixed. [bsc#1040043]

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-715=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 i686 x86_64):

glibc-2.22-4.9.1
glibc-debuginfo-2.22-4.9.1
glibc-debugsource-2.22-4.9.1
glibc-devel-2.22-4.9.1
glibc-devel-debuginfo-2.22-4.9.1
glibc-devel-static-2.22-4.9.1
glibc-locale-2.22-4.9.1
glibc-locale-debuginfo-2.22-4.9.1
glibc-profile-2.22-4.9.1

- openSUSE Leap 42.2 (i586 x86_64):

glibc-extra-2.22-4.9.1
glibc-extra-debuginfo-2.22-4.9.1
glibc-utils-2.22-4.9.1
glibc-utils-debuginfo-2.22-4.9.1
glibc-utils-debugsource-2.22-4.9.1
nscd-2.22-4.9.1
nscd-debuginfo-2.22-4.9.1

- openSUSE Leap 42.2 (x86_64):

glibc-32bit-2.22-4.9.1
glibc-debuginfo-32bit-2.22-4.9.1
glibc-devel-32bit-2.22-4.9.1
glibc-devel-debuginfo-32bit-2.22-4.9.1
glibc-devel-static-32bit-2.22-4.9.1
glibc-locale-32bit-2.22-4.9.1
glibc-locale-debuginfo-32bit-2.22-4.9.1
glibc-profile-32bit-2.22-4.9.1
glibc-utils-32bit-2.22-4.9.1
glibc-utils-debuginfo-32bit-2.22-4.9.1

- openSUSE Leap 42.2 (noarch):

glibc-html-2.22-4.9.1
glibc-i18ndata-2.22-4.9.1
glibc-info-2.22-4.9.1

- openSUSE Leap 42.2 (i586):

glibc-obsolete-2.22-4.9.1
glibc-obsolete-debuginfo-2.22-4.9.1


References:

https://www.suse.com/security/cve/CVE-2017-1000366.html
https://bugzilla.suse.com/1039357
https://bugzilla.suse.com/1040043

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung