Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Cross-Site Request Forgery in PHP
Aktuelle Meldungen Distributionen
Name: Cross-Site Request Forgery in PHP
ID: SUSE-SU-2017:1709-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP4
Datum: Mi, 28. Juni 2017, 23:56
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7272

Originalnachricht

   SUSE Security Update: Security update for php53
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:1709-1
Rating: important
References: #1031246 #1044976
Cross-References: CVE-2017-7272
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for php53 fixes the following issues:

- The fix for CVE-2017-7272 was reverted, as it caused regressions in the
mysql server connect module. [bsc#1044976] The security fix tried to
avoid a server side request forgery, and will be submitted when a better
fix becomes available.


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-php53-13179=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-php53-13179=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-php53-13179=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
s390x x86_64):

php53-devel-5.3.17-111.2
php53-imap-5.3.17-111.2
php53-posix-5.3.17-111.2
php53-readline-5.3.17-111.2
php53-sockets-5.3.17-111.2
php53-sqlite-5.3.17-111.2
php53-tidy-5.3.17-111.2

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

apache2-mod_php53-5.3.17-111.2
php53-5.3.17-111.2
php53-bcmath-5.3.17-111.2
php53-bz2-5.3.17-111.2
php53-calendar-5.3.17-111.2
php53-ctype-5.3.17-111.2
php53-curl-5.3.17-111.2
php53-dba-5.3.17-111.2
php53-dom-5.3.17-111.2
php53-exif-5.3.17-111.2
php53-fastcgi-5.3.17-111.2
php53-fileinfo-5.3.17-111.2
php53-ftp-5.3.17-111.2
php53-gd-5.3.17-111.2
php53-gettext-5.3.17-111.2
php53-gmp-5.3.17-111.2
php53-iconv-5.3.17-111.2
php53-intl-5.3.17-111.2
php53-json-5.3.17-111.2
php53-ldap-5.3.17-111.2
php53-mbstring-5.3.17-111.2
php53-mcrypt-5.3.17-111.2
php53-mysql-5.3.17-111.2
php53-odbc-5.3.17-111.2
php53-openssl-5.3.17-111.2
php53-pcntl-5.3.17-111.2
php53-pdo-5.3.17-111.2
php53-pear-5.3.17-111.2
php53-pgsql-5.3.17-111.2
php53-pspell-5.3.17-111.2
php53-shmop-5.3.17-111.2
php53-snmp-5.3.17-111.2
php53-soap-5.3.17-111.2
php53-suhosin-5.3.17-111.2
php53-sysvmsg-5.3.17-111.2
php53-sysvsem-5.3.17-111.2
php53-sysvshm-5.3.17-111.2
php53-tokenizer-5.3.17-111.2
php53-wddx-5.3.17-111.2
php53-xmlreader-5.3.17-111.2
php53-xmlrpc-5.3.17-111.2
php53-xmlwriter-5.3.17-111.2
php53-xsl-5.3.17-111.2
php53-zip-5.3.17-111.2
php53-zlib-5.3.17-111.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):

php53-debuginfo-5.3.17-111.2
php53-debugsource-5.3.17-111.2


References:

https://www.suse.com/security/cve/CVE-2017-7272.html
https://bugzilla.suse.com/1031246
https://bugzilla.suse.com/1044976

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung