Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Zwei Probleme in ncurses
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in ncurses
ID: SUSE-SU-2017:1790-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP4
Datum: Do, 6. Juli 2017, 16:44
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10685
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10684

Originalnachricht

   SUSE Security Update: Recommended update for ncurses
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:1790-1
Rating: important
References: #1046853 #1046858
Cross-References: CVE-2017-10684 CVE-2017-10685
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for ncurses fixes the following issues:

Security issues fixed:
- CVE-2017-10684: Possible RCE via stack-based buffer overflow in the
fmt_entry function. (bsc#1046858)
- CVE-2017-10685: Possible RCE with format string vulnerability in the
fmt_entry function. (bsc#1046853)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-ncurses-13197=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-ncurses-13197=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-ncurses-13197=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 x86_64):

ncurses-devel-5.6-92.1
tack-5.6-92.1

- SUSE Linux Enterprise Software Development Kit 11-SP4 (x86_64):

ncurses-devel-32bit-5.6-92.1

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

libncurses5-5.6-92.1
libncurses6-5.6-92.1
ncurses-devel-5.6-92.1
ncurses-utils-5.6-92.1
tack-5.6-92.1
terminfo-5.6-92.1
terminfo-base-5.6-92.1

- SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):

libncurses5-32bit-5.6-92.1
libncurses6-32bit-5.6-92.1
ncurses-devel-32bit-5.6-92.1

- SUSE Linux Enterprise Server 11-SP4 (ia64):

libncurses5-x86-5.6-92.1
libncurses6-x86-5.6-92.1

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):

ncurses-debuginfo-5.6-92.1
ncurses-debugsource-5.6-92.1


References:

https://www.suse.com/security/cve/CVE-2017-10684.html
https://www.suse.com/security/cve/CVE-2017-10685.html
https://bugzilla.suse.com/1046853
https://bugzilla.suse.com/1046858

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung