Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in rubygem-puppet
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in rubygem-puppet
ID: openSUSE-SU-2017:1948-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.2, SUSE openSUSE Leap 42.3
Datum: Di, 25. Juli 2017, 06:30
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2295

Originalnachricht

   openSUSE Security Update: Security update for rubygem-puppet
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1948-1
Rating: important
References: #1040151
Cross-References: CVE-2017-2295
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for rubygem-puppet fixes the following issues:

- CVE-2017-2295: A remote attacker could have forced unsafe YAML
deserialization which could have led to code execution (bsc#1040151)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-835=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-835=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

ruby2.1-rubygem-puppet-3.8.7-20.1
ruby2.1-rubygem-puppet-doc-3.8.7-20.1
ruby2.1-rubygem-puppet-testsuite-3.8.7-20.1
ruby2.2-rubygem-puppet-3.8.7-20.1
ruby2.2-rubygem-puppet-doc-3.8.7-20.1
ruby2.2-rubygem-puppet-testsuite-3.8.7-20.1
ruby2.3-rubygem-puppet-3.8.7-20.1
ruby2.3-rubygem-puppet-doc-3.8.7-20.1
ruby2.3-rubygem-puppet-testsuite-3.8.7-20.1
ruby2.4-rubygem-puppet-3.8.7-20.1
ruby2.4-rubygem-puppet-doc-3.8.7-20.1
ruby2.4-rubygem-puppet-testsuite-3.8.7-20.1
rubygem-puppet-3.8.7-20.1
rubygem-puppet-master-3.8.7-20.1

- openSUSE Leap 42.3 (noarch):

rubygem-puppet-emacs-3.8.7-20.1
rubygem-puppet-master-unicorn-3.8.7-20.1
rubygem-puppet-vim-3.8.7-20.1

- openSUSE Leap 42.2 (i586 x86_64):

ruby2.1-rubygem-puppet-3.8.7-17.3.1
ruby2.1-rubygem-puppet-doc-3.8.7-17.3.1
ruby2.1-rubygem-puppet-testsuite-3.8.7-17.3.1
rubygem-puppet-3.8.7-17.3.1
rubygem-puppet-master-3.8.7-17.3.1

- openSUSE Leap 42.2 (noarch):

rubygem-puppet-emacs-3.8.7-17.3.1
rubygem-puppet-master-unicorn-3.8.7-17.3.1
rubygem-puppet-vim-3.8.7-17.3.1


References:

https://www.suse.com/security/cve/CVE-2017-2295.html
https://bugzilla.suse.com/1040151

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung